Closed Bug 468103 Opened 11 years ago Closed 11 years ago

Recreate the SeaMonkey throbber as APNG

Categories

(SeaMonkey :: UI Design, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a3

People

(Reporter: lam, Assigned: kairo)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.9.1b3pre) Gecko/20081128 SeaMonkey/2.0a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.9.1b3pre) Gecko/20081128 SeaMonkey/2.0a2pre

SeaMonkey logo clearly shows some light pixels around it, which looks ugly.

Probably this belongs to a theme, please reassign accordingly, as I don't have knowledge of appropriate component for this.

I'll attach a screenshot of the Navigation Toolbar, which demonstrates this problem.

Reproducible: Always
Attached image a tiny screenshot
This looks like it is an issue with your theme. You can go to your addons dialog, find which you are using, then please contact the designers of the theme.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
Version: unspecified → Trunk
The theme is "SeaMonkey Default Theme 1.0". It's not my job to contact designers of the _default_ theme, it's a thing someone from SM team is supposed to do...

Or do you want to tell me using Darklooks GTK theme is an INVALID configuration? I wouldn't say so, because every other button and icon is okay, only the logo isn't. Please, check for yourself before making such comments.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
You are saying that the Seamonkey logo should not have the white line around it? Then this is different, it is an enhancement.
Severity: normal → enhancement
Summary: SeaMonkey logo isn't smoothed to background → Clean up Seamonkey logo
Whiteboard: DUPEME
Attached image another demonstration
I'm saying that the "edges" are smoothed to some light background instead of using transparency. No other graphical element that I see in SM has this problem.

The new screenshot shows that the logo (not exactly same-looking) is nicely smoothed to dark background on the theme preview.

The icon used on window list/task switcher also uses transparency properly. The only bad-looking logo is the one on Navigation Toolbar, which gets animated when page is being loaded.
Yeah, it's an animimated gif. We need an apng instead.
Summary: Clean up Seamonkey logo → Convert Seamonkey logo to APNG
Status: UNCONFIRMED → NEW
Component: General → UI Design
Ever confirmed: true
Flags: blocking-seamonkey2.0a3?
QA Contact: general → ui-design
OS: Linux → All
We know about this, no "demonstration" needed. This has been in my mind for a while, but the whole throbber needs to be redone for this from original images which I hope I have around somewhere. The problem is that I'm not sure if I have a decent APNG editor around somewhere.

This does not block an alpha, but is something we really should do.
Flags: blocking-seamonkey2.0a3? → blocking-seamonkey2.0a3-
Summary: Convert Seamonkey logo to APNG → Recreate the SeaMonkey throbber as APNG
Whiteboard: DUPEME
Flags: wanted-seamonkey2?
Blocks: 321591
> The problem is that I'm not sure if I
> have a decent APNG editor around somewhere.

http://animat.megabase.ch/en/index.html

"Animat is a Firefox extension allowing you to create an animated image using the Animated Portable Network Graphics (APNG) format."
This patch switches both our included themes to (A)PNG version of the throbber images. Unfortunately, there aren't many APNG tools out there, so the APNGs are not as optimized as they probably could be (ideally, each frame would only contain the changes to the frame before but the images here contain full frames). All the frames for the APNG images have been recreated from the original work of our logo author, who also designed this "bubble" throbber by extracting frame by frame from his original swf files into svg format and rendering those SVGs to PNG images.
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Attachment #356516 - Flags: review?(neil)
Duplicate of this bug: 321591
Just for demoing how it looks, here's the 32px APNG that also is contained in the patch (FYI, I locally even created 128px and 64px versions but they get rather large - ~200 KB and ~530 KB).
But I bet they look great. Perhaps you should blog about it so that we can link to some large size throbbers in the agenda of the current meeting?
Presumably a limitation of the old GIF format is that the bubbles didn't extend outisde the circle. I actually don't like the effect of them utilising the whole square, as that means the bubbles get a square cut off at the top and bottom.

I notice that the new throbber makes better use of 32x32 than the old one :-)
I actually like the effect of the bubbles extending outside the circle (esp. since it nicely shades over the background with the alpha transparency), but I also noticed the hard cut-off at the top or bottom. I may be able to create another GIMP patch script or so to make the outer pixels get some kind of fade-out effect or so, but even the one I did for creating the PNGs from the SVGs took quite long to write, and assembling those PNGs to an APNG is also something that takes up more time than necessary - and I'm not sure that fading effect would even be much noticeable.

Of course, this extension outside the circle is something we can do much nicer with APNG than GIF, as the latter did not allow us to have alpha transparency. IIRC, the original images we got even had that effect of the bubbles extending outside the circle, but that would have worked only against one single shade of gray, i.e. would have looked even worse in much more situations.
Comment on attachment 356516 [details] [diff] [review]
switch to (A)PNG throbber images

Let's just wait for the complaints to bubble up ;-)
Attachment #356516 - Flags: review?(neil) → review+
Pushed as http://hg.mozilla.org/comm-central/rev/f1e4747febbf
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a3
I've just installed today's nightly build and let me say it looks great on my dark background! Thank you.
Flags: wanted-seamonkey2?
You need to log in before you can comment on or make changes to this bug.