folder with name starting with a dot (ex: ".Mac") and included messages thrown away on quit

RESOLVED DUPLICATE of bug 229522

Status

--
critical
RESOLVED DUPLICATE of bug 229522
13 years ago
13 years ago

People

(Reporter: hjbor1, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; fr-fr) AppleWebKit/312.5.2 (KHTML, like Gecko) Safari/312.3.1
Build Identifier: version 1.0.7

As a first test of Thunderbird, I download files from .Mac account....  I create various folders.  One of them was ".Mac" : via two subfolders, I put into it messages about my .mac account itself and its renewal, rather important information in fact...  After quitting and restarting Thunderbird, the ".Mac" folder no longer existed! 
Just in case, I examined every other folder, but ".Mac" was not present in any of them.  I launched a search for messages according to their contents : only messages in other folder did appear depending on the search keys... 
Also, I made a test with a folder name ".Test" with one message into it.  Same results : both the folder and the message had vanished after a quit...
I haven't tested if the problem appears when the dot is not in first position.  I haven't tested other special characters (yet, if I remember well, somebody reports a problem when using a "/" character inside a folder name).
I haven't tested if the problem appears only with a top-level folder. 

Reproducible: Always

Steps to Reproduce:
1. create a ".<foldername>" folder
2. spend time adding your most sensitive data into it 
3. quit
4: restart Thunderbird : your ".<foldername> folder and data inside are all gone!

Actual Results:  
The <.foldername> folder and its contents are all gone

Expected Results:  
I would have preferred Thunderbird to prevent the user from naming a folder ".<foldername>".  
But, better would be to let the user choose whatever folder name he/sheI wants (Thunderbird does this well now) AND... to avoid erasing that folder and all its contents...

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 229522 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.