Spurious mousemove events when mouse is over appearing/disappearing fixed positioned div

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: Ere Maijala (slow))

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
See upcoming testcase.
Move the mouse over the green blinking div and leave it there.
While the mouse is blinking, you should not get any new mousemove events (if you don't move the mouse).
That's not happening in current trunk builds, though.

Probably a regression from bug 312566.
Ria, could you check this? Thanks!
(Reporter)

Comment 1

13 years ago
Created attachment 206936 [details]
testcase
(Assignee)

Comment 3

13 years ago
Oh my, when am I going to get this right?
(Assignee)

Comment 4

13 years ago
Created attachment 206996 [details] [diff] [review]
Patch v1

This patch fixes the detection of move messages caused by widget creation. After my previous changes the detection went wrong because two widget-based coordinates were compared. This patch changes is so that gLastMouseMovePoint is again in screen coordinates and appropriate conversions are used everywhere.
Assignee: win32 → emaijala
Status: NEW → ASSIGNED
Attachment #206996 - Flags: superreview?(roc)
Attachment #206996 - Flags: review?(roc)
Attachment #206996 - Flags: superreview?(roc)
Attachment #206996 - Flags: superreview+
Attachment #206996 - Flags: review?(roc)
Attachment #206996 - Flags: review+
(Assignee)

Comment 5

13 years ago
Fix checked in to trunk. Martijn, could you file another bug against Gtk? Linux builds seem to show the same problem although it's milder there (single mousemove only when the div appears).
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

13 years ago
Sure, I filed bug 321794 for it.
(In reply to comment #3)
> Oh my, when am I going to get this right?
> 
I hardly dare to ask,
but could this have caused bug 321897 ?
(Reporter)

Updated

13 years ago
Depends on: 321816
(Reporter)

Updated

13 years ago
Depends on: 321794
You need to log in before you can comment on or make changes to this bug.