RFE: Escape key in location bar should revert URL

VERIFIED DUPLICATE of bug 47863

Status

SeaMonkey
Location Bar
P3
enhancement
VERIFIED DUPLICATE of bug 47863
19 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: Alec Flett)

Tracking

({helpwanted})

Trunk
mozilla0.9.1
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: blake)

(Reporter)

Description

19 years ago
Pressing escape while editing the URL in the location bar should cause the URL 
to revert to the URL of the page displayed.  Currently a user must hit reload 
to figure out the URL of the current page.

If a new page is being loaded, but hasn't started rendering, while escape is 
pressed (but the location bar still has focus), the first escape should stop 
the loading of the new page without reverting the location bar to the previous 
page.  Pressing escape a second time should revert the URL.  See also bug 
#29085 (escape key should stop page loading) - this bug might depend on 29085.

Comment 1

18 years ago
-> don
Assignee: cbegle → don
Status: UNCONFIRMED → NEW
Component: Browser-General → XPApps
Ever confirmed: true
QA Contact: asadotzler → paulmac

Updated

18 years ago
QA Contact: paulmac → claudius

Comment 2

18 years ago
spam, changing selected qa contact on selected bugs from paulmac@netscape.com to 
claudius@netscape.com

Updated

18 years ago
Target Milestone: --- → Future
(Reporter)

Updated

18 years ago
Blocks: 55416
(Reporter)

Updated

18 years ago
No longer blocks: 55416
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 4

18 years ago
nav triage team:

I would personally like to do this, but got lots of other things to do for 
beta1. Marking nsbeta1-, adding helpwanted
Keywords: helpwanted, nsbeta1-

Updated

18 years ago
Whiteboard: blake
spam: over to urlbar.
QA Contact: claudius → sairuh
gah, really this time...
Assignee: vishy → alecf
Component: XP Apps → History: URLBar
QA Contact: sairuh → claudius

Comment 7

18 years ago
*** Bug 68176 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
Since I plused the one about not overwriting url bar if you type in it, you
kinda need this feature. Marking nsbeta1+
Keywords: nsbeta1- → nsbeta1+
Target Milestone: Future → mozilla0.9
(Assignee)

Comment 9

17 years ago
as much as I'd like to fix this in mozilla 0.9, I am overloaded and must push
this back a milestone. Sorry!
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9 → mozilla0.9.1
(Reporter)

Comment 10

17 years ago
Cc Doron, who suggested selecting the contents of the location bar after 
reverting the url.  So now we have:

Esc in the location bar while the page isn't loading should revert and select 
the contents of the location bar.  (If the url doesn't need to be reverted, the 
url should still be selected.)

It might be necessary to turn off the selecting on Linux.  It would probably 
make sense to copy code from the Ctrl+L handler to take care of platform 
differences.
(Reporter)

Comment 11

17 years ago
Doron has a fix in bug 47863, "Pressing Esc in address field should restore URL 
to that of page".

*** This bug has been marked as a duplicate of 47863 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.