linker flags error - libpipnss.so

RESOLVED DUPLICATE of bug 321457

Status

()

Firefox
Build Config
--
minor
RESOLVED DUPLICATE of bug 321457
12 years ago
12 years ago

People

(Reporter: g. fischer, Unassigned)

Tracking

Trunk
SGI
IRIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP27; en-US; rv:1.9a1) Gecko/R-A-C SeaMonkey/1.5a
Build Identifier: 

little error detected:

CC -I/usr/local/include -I/usr/nekoware/include  -LANG:exceptions=OFF -woff 3262 -G 4 -n32  -DNDEBUG -DTRIMMED -O -KPIC -elf -shared -o libpipnss.so  md4.o nsCipherInfo.o nsNSSCallbacks.o nsNSSComponent.o nsNSSIOLayer.o nsNSSModule.o nsSSLSocketProvider.o nsTLSSocketProvider.o nsSDR.o nsPK11TokenDB.o nsNSSCertificate.o nsPKCS12Blob.o nsNSSASN1Object.o nsKeygenHandler.o nsCrypto.o nsPKCS11Slot.o nsKeygenThread.o nsCMSSecureMessage.o nsCMS.o nsCertPicker.o nsCRLInfo.o nsNSSCertCache.o nsNSSCertHelper.o nsNSSCertificateDB.o nsNSSCertTrust.o nsNSSCertValidity.o nsOCSPResponder.o nsUsageArrayHelper.o nsCRLManager.o nsNSSShutDown.o nsNTLMAuthModule.o nsNSSEvent.o nsSmartCardMonitor.o nsSmartCardEvent.o nsCertTree.o    -lpthread -L/usr/local/lib -L/usr/nekoware/lib -n32   ../../../../dist/lib/libunicharutil_s.a -L../../../../dist/bin -lxpcom -lxpcom_core -L../../../../dist/bin -L../../../../dist/lib -lplds4 -lplc4 -lnspr4 -L/usr/local/lib -L/usr/nekoware/lib -lpthread -ldl -L../../../../dist/bin -lmozjs -L-L../../../../dist/bin -L../../../../dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lsoftokn3   -lsocket -ldl -lm    
CC ERROR parsing -L:  no argument given for option
gmake[5]: *** [libpipnss.so] Error 2

just one '-L' too much after -lmozjs.
executing the corrected line manually works fine.
first encountered about one week ago.

Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 1

12 years ago
Can you attach your mozconfig?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Can you attach your mozconfig?
> 

i don't use one. just commandline switches.
anyway it also happened with seamonkey (where the options differ) so it may not be of much help.
but of course i can post both if needed.

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 321457 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.