Copying or moving sent mail to different folder - From: mail address is not set correctly

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
9 years ago

People

(Reporter: ghost_zero5, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-12-15)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8) Gecko/20051111 Firefox/1.5

If you copy or move a sent mail to a different folder, the from mail adress is not set correctly, it is set to the default-mail-adress instead. That is especially anoying if you have set an reply-e-mail-adress because then you have the reply-e-mail-adress of the default-e-mail-adress and the old reply-e-mail-adress.
If you then change to the other e-mail-adress you have that e-mail-adress double as reply-e-mail-adress.

This bug exists in Mozilla Thunderbird v1.0.7 and still in Mozilla Thunderbird v1.5 RC2.

Reproducible: Always

Steps to Reproduce:
1.Copy or Move Mail from sent mail to different folder
2.Open mail
3.Look at from e-mail-adress and at reply-adresses (are two then)

Actual Results:  
Wrong (default) From-Mail-Adress and two reply-addresses (old and new one)

Expected Results:  
From-Mail-Adress should be the one from which account it was sent and reply-adress should not be doubled if you change account but replaced.
Do you mean when you hit reply? That would be bug 85296 (fixed on trunk, not in 1.5 though)

Comment 2

13 years ago
Andreas, ping? Do you mean when you hit reply? Or do you expect us to alter the message when it's copied to another account? Your report is unclear. We're not going to change the headers of a message just because it was moved/copied.
(Reporter)

Comment 3

13 years ago
No not reply, I just meant if you have SENT a message FROM another account than the standard-account it is in the Sent-Folder (so far everything is correct). If it has an reply-to-information in the header and you copy or move the message to (e.g.)the Drafts-Folder the sender-account of the message is changed to the standard-account and therefore also a second reply-to-information is added... 
What I would think is that if you copy or move a message from Sent-Folder that the sender-account stays the same and is not reversed to the standard-sender-account (because it is a copy or a movement) and therefore there would then also not be two differend reply-to-information but just the one from the sender-account that was used before (as it is if I copy or move an e-mail from the standard-sender-account from Sent-Folder to [e.g.] Draft-Folder)...

Hope it is clear now... And sorry fro letting you waiting so long (I nearly forgot about that bug report)...
QA Contact: front-end
(Reporter)

Comment 4

11 years ago
OK. Here is a sample (especially look at From and Reply-To-Info):
Before Copying (a message in Sent-Folder):

X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:                                                                                 
Message-ID: <46E84007.2060104@first.mail>
Date: Wed, 12 Sep 2007 21:37:43 +0200
From: Andreas Allacher <mynotdefault@first.mail>
Reply-To:  mynotdefault@first.mail
User-Agent: Thunderbird 2.0.0.6 (Windows/20070728)
MIME-Version: 1.0
To: Andreas Allacher <mydefault@second.mail>
Subject: Sample
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit


After being copied to Draft-Folder:
X-Mozilla-Status: 0000
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
FCC: mailbox://nobody@Local%20Folders/Sent
X-Identity-Key: id1
Message-ID: <46E840EC.9080008@first.mail>
Date: Wed, 12 Sep 2007 21:41:32 +0200
From: Andreas Allacher <mydefault@second.mail>
Reply-To:   mynotdefault@first.mail,  mydefault@second.mail
X-Mozilla-Draft-Info: internal/draft; vcard=0; receipt=0; uuencode=0
User-Agent: Thunderbird 2.0.0.6 (Windows/20070728)
MIME-Version: 1.0
To: Andreas Allacher <mydefault@second.mail>
Subject: SampleAfterCopy
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Version: unspecified → 2.0
(Reporter)

Comment 5

11 years ago
Furthermore I want to say that I use POP3.
Assignee: mscott → nobody

Comment 6

10 years ago
Is this seen in beta? 
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Component: Mail Window Front End → Backend
Product: Thunderbird → MailNews Core
QA Contact: front-end → backend
Summary: Copying or moving sent mail to different folder - From mail adress is not set correctly → Copying or moving sent mail to different folder - From: mail address is not set correctly
Version: 2.0 → unspecified

Updated

9 years ago
Whiteboard: closeme 2009-12-15
RESO INCO due to lack of response to previous question. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.