Closed Bug 322833 Opened 17 years ago Closed 17 years ago

Can't install plugins with Plugin Finder - gets stuck at license

Categories

(Toolkit Graveyard :: Plugin Finder Service, defect)

1.8 Branch
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.8.1alpha1

People

(Reporter: Peter6, Assigned: doronr)

References

Details

(Keywords: regression, verified1.8.1)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060108 Firefox/1.6a1 ID:2006010901

repro:
1. Rename NPSWF32.dll (shockwave flash 8.0.22 plugin)
2. Open Firefox
3. Open a page with flash
4. The Plugin Finder bar pops up, press [Install Missing Plugins...]
5. The Plugin Finder Service pops up and tells you you need Macromedia Flash Player
6. Press the [Next] button
7. "read" the licence and select the radiobutton [I agree]

result: The next button remains grayed out and you can only close the dialog

expected: to continue and install the plugin
Flags: blocking1.9a1?
probably my fault
Assignee: nobody → doronr
Attached patch patchSplinter Review
D'oh.  I was only setting pluginsToInstallNum if the user changed the selection of plugins to be installed in the plugin list.  So now, init it when we show the plugin list page.
Attachment #208016 - Flags: review?
Dorn, you've set the review flag to no one. I don't think that was meant, is it?
Comment on attachment 208016 [details] [diff] [review]
patch

oops
Attachment #208016 - Flags: review? → review?(mconnor)
*** Bug 324280 has been marked as a duplicate of this bug. ***
Summary: Can't install plugins → Can't install plugins with Plugin Finder - gets stuck at license
I'm suck on this too. Hopefully a fix'll get committed before too long.
Confirmed. And I agree -- this needs a fix soon. 

It's not surprising that many users have a hard time finding and using the other UI path to plugins (Tools->Extensions, click on Get More Extensions, let page open, click on Plugins tab). Not the most obvious ;)
Any chance anyone else can review this patch.
mconnor has 100+ reviews in his queue and obviously doesn't have the time look at them.
cc: rob strong in case he want to review :)

This is trunk only though, you should be using 1.8.1 branch and testing for FF2 folks! :)
(In reply to comment #10)
> This is trunk only though, you should be using 1.8.1 branch and testing for FF2
> folks! :)
Nah, we catch the bugs before they land on banch ;-)
Comment on attachment 208016 [details] [diff] [review]
patch

Looks good.
Attachment #208016 - Flags: review?(mconnor) → review+
thanks for the review!
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
I'm experiencing this bug with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20060223 Firefox/1.5  (latest branch nightly)
(In reply to comment #14)
> I'm experiencing this bug with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
> rv:1.8) Gecko/20060223 Firefox/1.5  (latest branch nightly)
> 

File a bug if it happens in 1.8.1 branch bits.
Bug 328365 was filed (poor Comment 0 so! ;-).
Flags: blocking1.9a1?
Comment on attachment 208016 [details] [diff] [review]
patch

The patch from bug 283274 was landed on the 1.8 branch in bug 264282, so this patch needs to be landed on the branch too.
Attachment #208016 - Flags: approval-branch-1.8.1?(mconnor)
*** Bug 328365 has been marked as a duplicate of this bug. ***
Flags: blocking-firefox2?
Attachment #208016 - Flags: approval-branch-1.8.1?(mconnor) → approval-branch-1.8.1+
Flags: blocking-firefox2? → blocking-firefox2+
mozilla/toolkit/mozapps/plugins/content/pluginInstallerWizard.js; 1.13.2.2;
Keywords: fixed1.8.1
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → Firefox 2 alpha1
Version: Trunk → 2.0 Branch
verfied fixed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b2) Gecko/20060829 BonEcho/2.0b2
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.