Times out reading large IMAP folders (should increase timeout value!)

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Braden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Thunderbird 1.5 now times out when reading large IMAP folders (e.g., 6600 messages). This worked in 1.0.7.

Comment 1

13 years ago
try increasing the network timeout pref, tools | options | advanced | network connection timeout - make it 10000 or so...

Comment 2

13 years ago
we might want to think about making this a bit longer David. I've gotten comments from folks in the office about this too, they keep running into the timeout. 

Comment 3

13 years ago
yes, I guess so - we could make it two minutes. I also like the idea of letting the user change the timeout directly from the alert, or at least having a button to take them to the ui for setting the timeout.
(Reporter)

Comment 4

13 years ago
Yes; that works. Thanks.

A longer default timeout would be nice; but making this option discoverable by putting it in the timeout dialog (with a "Retry" button) is probably the Right solution.

Comment 5

12 years ago
i frequently get problems on a folder with >3,000
QA Contact: front-end

Updated

10 years ago
Flags: wanted-thunderbird3?

Updated

10 years ago
Assignee: mscott → nobody
Summary: Times out reading large IMAP folders → Times out reading large IMAP folders (should increase timeout value!)

Updated

10 years ago
Keywords: regression

Comment 6

10 years ago
David, do you see any value to morphing this to enhancement for the UI you suggest in comment 3?  Perhaps dubious unless your experience negates the lack of dupes and other open bugs which include

bug 340265 can't remove/delete large number of messages at the same time, timeout error
bug 406929 "message was sent but copying to sent folder failed" error after IMAP timeout
bug 468490 IMAP IDLE does not reconnect after a server timeout drops the connection
409259 Thunderbird timeouts of IMAP operations 


(In reply to comment #5)
> i frequently get problems on a folder with >3,000

I no longer remember the context in which I saw this - but I don't see timeout anymore (perhaps a slow vpn?).

anyways, Braden reports he doesn't see this and "I think performance issues on the server were resolved."
(Reporter)

Comment 7

9 years ago
I haven't observed a problem like this for some time; and I'm skeptical there's enough information in this bug report for anyone to do anything useful with it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.