Mail marked as junk by message filters is not moved to the Junk folder

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: dalangalma, Assigned: mscott)

Tracking

Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird version 1.5 (20051201)

I have message rules that automatically mark some messages as junk. I also have the setting "Move incoming mail determined to be junk to Junk" clicked. However, while my filters correctly set the mail as junk, the mail does not go to the Junk folder.

Reproducible: Always

Comment 1

13 years ago
I can verify this bug.  I was going to file a new one, but I found this.

Another variation is that I have "move incoming messages determined to be junk to..." deselected, but "When I manually mark messages as junk... Move them to the Junk folder" selected.

This is very important for me because I use server-side Bayesian filtering (spamprobe works well, BTW).  I need to use the "Junk"  folder to train the filter, but the junk won't budge from where I mark it.

Comment 2

13 years ago
the same thing happens on thunderbird 1.5, windows 2000 server

Comment 3

13 years ago
right, if I understand you, this is by design; if you also want it to get moved to the junk folder by the filter, add a filter action to do that.

Comment 4

13 years ago
How can it be that the design is to have "When I manually mark messages as junk... Move them to the Junk folder" not make TB move messages to the junk folder when I mark them as junk?

Comment 5

13 years ago
manually means through the UI, i.e., with your hands on the keyboard. With a filter is more automatic, I think. Also, the filter lets you do it either way, so it gives the user more flexibility.

Comment 6

13 years ago
We seem to be talking past each other.  Maybe I'm missing something.

My points are:

 * There is an option I'd like to use
 * It doesn't do what it says it will

When I mark a message as spam, I want it to immediately go into the junk folder as advertised.

Comment 7

13 years ago
so i have to say it again: when i have received some junk messages, all have been moved automatically to the junk folder EXCEPT one, wich, even if it was marked correctly as junk was left on the inbox. resetting and then setting again the junk field (on this message), the message was moved automatically as planned, to the junk folder. wich means, the filter was already there, only it didn't work as it was supposed to be.

Comment 8

13 years ago
no, I think you're talking about a different issue than the bug reporter, who was talking about message filters. If you're selecting a message, marking it as junk, and it's not moving, that's a different issue, and now that you've clarified things, one I've heard of before (though it works fine for me)

Comment 9

13 years ago
(In reply to comment #8)
> no, I think you're talking about a different issue than the bug reporter, who
> was talking about message filters. If you're selecting a message, marking it as
> junk, and it's not moving, that's a different issue, and now that you've
> clarified things, one I've heard of before (though it works fine for me)
> 
 oh, sorry boys :) i thought it's my bug :) anyway: i was talking by the same bug (apparently) only i found it on windows 2000 with thunderbird 1.5, as reported here: https://bugzilla.mozilla.org/show_bug.cgi?id=324777
and it looks to me like the same ....

Comment 10

13 years ago
I made the assumption that there would be a common "move when flagged as junk" bit of code, especially since the checkboxes are right next to one another.  I apologize if that's not the case.  This is one of the consequences of relying on random people to search for existing bug reports before submitting a new one.

Updated

12 years ago
Flags: blocking-thunderbird2?

Comment 11

12 years ago
Ben Hollis, can you still reproduce on a newer build? 
(Assignee)

Updated

12 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Comment 12

12 years ago
Ben Hollis and "6e77a 70 6e 6e7a" both seem to have been reporting the same basic issue, which (per comment 3) is by design.  So:  => Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → MailNews: Composition
OS: Windows XP → All
Product: Thunderbird → Core
Hardware: PC → All
Resolution: --- → INVALID
Version: unspecified → Trunk

Comment 13

12 years ago
Ben Hollis and "6e77a 70 6e 6e7a" both seem to have been reporting the same basic issue, which (per comment 3) is by design.  So:  => Invalid
Component: MailNews: Composition → MailNews: Filters

Comment 14

12 years ago
*** Bug 293564 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.