If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

document shift+click+drag to move bookmark folders on bookmarks toolbar

VERIFIED FIXED

Status

support.mozilla.org
Knowledge Base Articles
--
enhancement
VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: RenegadeX, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

It is possible to move a Bookmark Folder in the (browser view) Bookmarks Menu by doing a SHIFT+Click-Drag. This appears to be an 'undocumented feature', that I think should be added to the 'Mouse Shortcuts' section of the Help window.

I had seen a couple of people asking how to this on #Firefox, and I had wondered the same thing myself for a while - until their prompting led me to some trial-and-error testing whereby I discovered the solution.

Why the SHIFT-key modifier is needed, I do not know. Internet Explorer treated ('Favorites')bookmark folders as it did regular bookmarks. But that is another issue. It is the way it is, and should be documented.

Reproducible: Always

Steps to Reproduce:
1. Attempt to move a (webpage) bookmark in the Bookmarks menu by left-clicking on an item and while holding the left-mouse button, dragging it to another position in the menu-list; note the cursor change (to the 'drag' cursor) and note the black horizontal line indicating the drag-insertion-point.
2. Attempt to move a bookmark folder in the Bookmarks menu by using a similar method as the one described above; note that it is impossible.
3. Repeat #2 with the addition of holding down the SHIFT key prior while clicking on the folder to be moved; note the cursor change and black horizontal line indicating drag-insertion-point.

Comment 1

12 years ago
bug 235244 will remove it ...

Comment 2

10 years ago
This doesn't work at all currently in trunk builds, see bug 389914.
Depends on: 389914
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
For what I know, now folders or live bookmarks in bookmarks toolbar can be moved with ALT+drag. WORKSFORME?
Nothing, please ignore my previous comment.

I think a documentation abou ALT (or CONTROL)+drag is very useful, because it's not so obvious. For example I didn't know that in Fx2 bookmark folders can be drag with SHIFT+drag. What about a tooltip?

Comment 5

9 years ago
Moving to sumo.

Should be documented in the bookmarks article:
http://support.mozilla.com/kb/Bookmarks#Drag_and_drop
Note that this (shift+click+drag to move bookmark folders in bookmarks toolbar) currently works on Windows only. Bug 389914 is about reimplementing this on Mac.
Status: UNCONFIRMED → NEW
Component: Help Documentation → Knowledge Base Articles
Ever confirmed: true
Product: Firefox → Sumo
QA Contact: help.documentation → kb-articles
Summary: Mouse Shortcuts should add Undocumented Command: SHIFT+Click+Drag to move Bookmark Folders in Bookmarks Menu → document shift+click+drag to move bookmark folders on bookmarks toolbar
Version: Trunk → unspecified
The drag and drop anchor of the bookmarks article is about adding bookmarks. The entire article is about accessing/adding/removing bookmarks. This should probably be part of bug 411977.
Depends on: 411977

Comment 7

9 years ago
I think this is fixed by the fix for Bug 411977.

Please re-open if you disagree.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
But you have fixed Bug 411977 with a KB article on Mozillazine, didn't you? Comment 5 suggested to add the help to support.mozilla.com

Can you provide us the link of KB article?

Comment 9

9 years ago
> But you have fixed Bug 411977 with a KB article on Mozillazine, didn't you?
No, this is about the knowledge base on http://support.mozilla.com/.

> Can you provide us the link of KB article?
http://support.mozilla.com/en-US/kb/Organizing+Bookmarks#Re_arranging_the_Bookmarks_Toolbar
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.