Open / Import calendar file

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: kbovi, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

1) If I try to open an calendar-file (CTRL+O), nothing happens.

2) I have downloaded several *.ics files. Trying to import such a file, an error occurs (x items failed to imort. The last error was: 2147500037)

Reproducible: Always

Steps to Reproduce:
1. import a ics-file

Comment 1

13 years ago
1) has been fixed.  (2) is often caused by trying to import items that have previously been imported.  More information would be needed about your calendar+events to diagnose that properly.  Try using a nightly build with a clean profile and I bet you'll have much more success.
(Reporter)

Comment 2

13 years ago
I tried to open two of the files with holidays 

http://www.mozilla.org/projects/calendar/caldata/BelgianHolidays.ics

and

http://www.mozilla.org/projects/calendar/caldata/GermanHolidays.ics

The second one cannot be imported

Comment 3

13 years ago
(In reply to comment #2)
> http://www.mozilla.org/projects/calendar/caldata/GermanHolidays.ics
> 
> The second one cannot be imported
> 

There are some events in there that also have a problem (no end date) that has since been fixed, which is why it'd be much more helpful if you could try a nightly build.

It's not a problem with Sunbird; the problem is that you have events with the same UID in both files. But the UID has to be unique. Example:

BelgianHolidays.ics:
  BEGIN:VEVENT
  UID:906774672    <-- here
  SUMMARY:Pasen

GermanHolidays.ics:
  BEGIN:VEVENT
  UID:906774672    <-- here
  SUMMARY:Ostersonntag

Comment 5

13 years ago
It might be worth filing another bug to add some UI to allow the user to choose how to deal with events with conflicting UUIDs.
(In reply to comment #4)
> It's not a problem with Sunbird; the problem is that you have events with the
> same UID in both files.

Marking WORKSFORME.

(In reply to comment #5)
> It might be worth filing another bug to add some UI to allow the user to choose
> how to deal with events with conflicting UUIDs.

Bug 325449 was filed for this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.