If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

rephrase "Select new tabs opened from links"

VERIFIED DUPLICATE of bug 340677

Status

()

Firefox
Tabbed Browser
--
trivial
VERIFIED DUPLICATE of bug 340677
12 years ago
5 years ago

People

(Reporter: Steffen Wilberg, Assigned: beltzner)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 2 beta1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
The preference "Select new tabs opened from links" from the Tabs Options panel should be rephrased.

From http://wiki.mozilla.org/Link_Targeting#Options:
"Rewording this preference should be done, the current text: "Select new tabs opened from links" is awful, has confused pretty much everyone I've seen read it and does nothing to advertise its association with a very specific mode of tabbed browsing usage - the background queue."

One suggestion is "Always bring new tabs to the front".
"Always give focus to new tabs"

Comment 2

12 years ago
This is pretty much a continuation of bug 111842, which had many suggestions.
Flags: blocking-firefox2+

Comment 3

12 years ago
(In reply to comment #1)
> "Always give focus to new tabs"
> 

Does your grandma know what "focus" means?

For Reference, 
See: Bugzilla Bug 112848 Does your grandmother know what POSTDATA is?
A lot of the confusion around this option seems to come from the fact that what the pref actually does is set the default behaviour for "Open in New Tab" actions, not for all actions that open a new tab (ie: tabs opened by New Tab, target="_blank" or window.open() links, tabs opened by links from other applications). So when someone selects

 [x] Select new tabs opened from links

it turns out to mean all actions that spawn new tabs give that tab focus. But, when that option isn't selected, it means *some* actions that spawn new tabs give that tab focus.

I'm not suggesting that the default behaviour of always giving focus to tabs spawned from New Tab, target="_blank", window.open() or other applications; I think that's the right default. But, this option clearly needs to make the distinction somehow.

And now, suggestions off the top of my head with no filtering as to quality nor quantity!

 [ ] Always select new tabs when they open

 [ ] New tabs are always selected

 [ ] "Open in New Tab" also selects the new tab

Comment 5

12 years ago
How about removing this option from the preferences entirely and using two menu entries instead: "Open Link in New Tab", and "Open Link in Background"/"Background Tab".

Not only would this ace the confusion, it also provides an on-the-fly decision depending upon the circumstance.

If that's not an option, then:

I think there's a problem with the word "select" in there. At first I surmised by looking at the option that it meant to replace existing tabs with those opened from an Open in Tabs bookmarks folder. Possible label is, "Always open new tabs in front".

Updated

12 years ago
Assignee: nobody → beltzner
Target Milestone: --- → Firefox 2 beta1
It seems to me that the problem is the underlying pref, 'browser.tabs.loadInBackground', applies to too many different things.

Perhaps it would be easier to examine the possibility of a decoupling of the various tab behaviours affected by this pref into separate prefs. Off the top of my head, I can think of several things affected by this pref:

- tab focus of external links
- tab focus of clicked links
- tab focus of window.open() calls

Given that bug 324604 advocates greater consistency in foreground-versus-background, perhaps it would be better to mark this bug dependent on 324604 and investigate changes to the backend in the latter bug.

Updated

12 years ago
Blocks: 333520
Whiteboard: [swag: 0.5d]
"I think there's a problem with the word "select" in there."

Agreed.  "Select" isn't as much UI-jargon as talking about what gets focus, but it's still overused and meaning-light.

As another alternative to "Always open new tabs in front", how about:

[x] Always jump to new tabs
or
[x] Always jump to newly opened tabs

which, I think, describes the user-experience behaviour, and so meets that baseline criterion of being recognizable for a novice user hunting for a way to turn it off.
This will be addressed in the pref-rewrite (bug 340677) where the current proposal is:

  [ ] When I open a link in a new tab, switch to it immediately
Depends on: 340677
Keywords: uiwanted
Whiteboard: [swag: 0.5d] → [swag: done]

*** This bug has been marked as a duplicate of 340677 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: [swag: done]
Status: RESOLVED → VERIFIED
Flags: blocking-firefox2+

Updated

11 years ago
No longer depends on: 340677
You need to log in before you can comment on or make changes to this bug.