Closed Bug 324335 Opened 16 years ago Closed 16 years ago

Dragging link to a tab loads in a new tab instead of replacing

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: aguertin+bugzilla, Assigned: martijn.martijn)

References

Details

(Keywords: verified1.8.1)

Attachments

(1 file)

Before checkin of bug 308396, dragging a link to a tab would replace the contents of that tab. Now it opens a new tab. It should be changed back.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060122 Firefox/1.6a1
It does. Only in a active tab.
Your mouse needs to touch the orange line :)
Flags: blocking1.9a1?
Flags: blocking-firefox2?
Assignee: nobody → mconnor
Flags: blocking1.9a1?
Flags: blocking-firefox2?
Flags: blocking-firefox2+
Attached patch patchSplinter Review
This fixes it, but there are more ways to fix it (and all of them not ideal, probably).
Attachment #210524 - Flags: review?(mconnor)
OS: Linux → All
Hardware: PC → All
*** Bug 327882 has been marked as a duplicate of this bug. ***
Comment on attachment 210524 [details] [diff] [review]
patch

There's a great deal of not-idealness in tabbrowser.  Please get this in ASAP so as to not bitrot me!
Attachment #210524 - Flags: review?(mconnor)
Attachment #210524 - Flags: review+
Attachment #210524 - Flags: approval-branch-1.8.1+
Assignee: mconnor → martijn.martijn
Landed on the trunk, but not branch, since bug 308396 hasn't landed on the branch yet.

mozilla/toolkit/content/widgets/tabbrowser.xml; new revision: 1.132;
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
fixed on the branch by bug 329054
Keywords: fixed1.8.1
Depends on: 330013
No longer depends on: 330013
Verified fixed with Windows, Mac and Linux with 2.0.b1rc3 builds
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.