Allow the use of relative dates in charts

RESOLVED FIXED

Status

()

enhancement
RESOLVED FIXED
13 years ago
5 months ago

People

(Reporter: dfc, Assigned: kohei)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Relative dates do not work in charts. If you enter in the following values for the date:
Range: "7d" to "Now"

Bugzilla reports " '7d' is not a legal date."

This is with  Bugzilla  Version 2.21.1  

Reproducible: Always
It would be nice if somebody could confirm this on the current tip and track down the cause.

dfc: I trust you mean that they don't work in fields where they normally work, for searches? Because we know that they don't work otherwise--they're a Search-specific feature.

If you want the Charts to support relative dates everywhere, that would be an enhancement.
Keywords: qawanted
Version: unspecified → 2.21

Comment 2

13 years ago
Bugzilla::Chart::init() expects "absolute" dates:

    foreach my $date ('datefrom', 'dateto') {
        if ($self->{$date}) {
            $self->{$date} = str2time($self->{$date}) 
              || ThrowUserError("illegal_date", { date => $self->{$date}});
        }
    }

So this bug is now a request to allow relative dates to be specified.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
OS: Windows XP → All
Hardware: PC → All
Summary: Relative dates do not work with charts → Allow the use of relative dates in charts

Updated

11 years ago
Assignee: gerv → charting
I just tried to file this bug and it pointed me at this one.  Wow, an 11 year old feature request. :-)
Grr, I hit Enter somewhere I shouldn't have and it submitted before I was ready.

But yeah, my use case here is I want a chart that shows me the last 90 or 180 days of tracking on a set of queries, and want to be able to bookmark it to repeatly use it in the future without having to go adjust the dates every time.
Posted file GitHub Pull Request
Assignee: charting → kohei.yoshino
Status: NEW → ASSIGNED
The PR goes to BMO first then shipping as part of Bugzilla 6.0.
Component: Reporting/Charting → General
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: 2.21 → Production
Merged to master.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.