opacity doesn't work (background tab close buttons not showing up)

RESOLVED DUPLICATE of bug 324892

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 324892
12 years ago
12 years ago

People

(Reporter: ted, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
The tabbed browsing changes from bug 308396 put a close button on each tab.  In trunk win32 cairo builds, the background close icons are not showing up.  The culprit is a css rule setting opacity: 0.7 on them here:
http://lxr.mozilla.org/mozilla/source/toolkit/themes/winstripe/global/browser.css#116

Overriding this to opacity 1.0 in userChrome.css fixes the problem.

Comment 1

12 years ago
*** Bug 324782 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

12 years ago
Created attachment 209703 [details]
Simplified testcase

It would appear that opacity is broken in general.
(Reporter)

Updated

12 years ago
Summary: background tab close buttons not showing up in Firefox → opacity doesn't work (background tab close buttons not showing up)

Comment 3

12 years ago
(In reply to comment #2)
na-ah. This works4me!
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> (In reply to comment #2)
> na-ah. This works4me!

What platform?  This doesn't work on my
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060123 Firefox/1.6a1
cairo build.

Comment 5

12 years ago
I see broken opacity in Camino and Firefox on OS X (both trunk) also.

Hardware/OS -> All/All
OS: Windows XP → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 324892 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.