PAC: document proxy auto-configuration files

RESOLVED DUPLICATE of bug 213699

Status

--
enhancement
RESOLVED DUPLICATE of bug 213699
13 years ago
4 years ago

People

(Reporter: bmo, Assigned: sheppy)

Tracking

Details

(Whiteboard: u=webdev p=0 c=Platform)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

there is currently no help topic that describes how to write and use a proxy
configuration file (aka PAC file).  this is the firefox version of bug 269919.

good info at http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

13 years ago
Depends on: 269919

Comment 1

12 years ago
We might consider linking to http://www.mozilla.org/catalog/end-user/customizing/enduserPAC.html
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.0 Branch → unspecified

Comment 2

10 years ago
Moving to sumo.
Component: Help Documentation → Knowledge Base Articles
Product: Firefox → Sumo
QA Contact: help.documentation → kb-articles

Comment 3

10 years ago
As I mentioned in Bug 244640, I'd like to move the content to SMO and mothball the old article...

Comment 4

10 years ago
I'm taking this bug as FF-help specific. The current instructions are wrong. I have smo submission access, so I'll do a short, help-file version.
Assignee: nobody → benc

Comment 5

10 years ago
Here's the current text:

http://support.mozilla.com/en-US/kb/Options+window?style_mode=inproduct#connection_settings

"Automatic proxy configuration URL: If your workplace has a proxy configuration file, ask the system administrator for its URL and enter it here. Click Reload to load the settings."

I finally got my test server running, so I served out a sample PAC file and looked at the logs...

This needs several changes:

1- Reload is greyed out when you enter new pac. when you hit okay, it saves and loads right away.

2- The relaod button has a specfic context/behavior that should be documented.

I do plan to clean up the enduserPAC.html file and move it to MDC, but I don't think we should link to it in FF (vs. Seamonkey) because it has a strong end-user orientation.

Comment 6

10 years ago
Here's my proposed new text:

Choose this if you have a proxy configuration (.pac) file.

Enter the URL and click okay to save changes and load the proxy configuration.

Reload button: The reload button will load the currently available proxy configuration.

---

Probably needs polish, but improves in the following way:

1- Consistent "choose" language for describing the proxy mode choices.
2- Corrects steps so they work for the UI that is actually in FF.
3- Adds documentation for reload button as related UI to this mode.

I'm not sure we would want to provide more text in the help file.

There are design limitations in FF to supporting PAC that changes->refreshing, but they are not inconsistent with the "simple UI for most things, no UI for rare things" design of FF. I don't want to mess w/ that here.

I'll post a chagne to smo in a day or two...
Status: NEW → ASSIGNED

Comment 7

10 years ago
Ben, is this meant to replace text on the Options/Preferences spec, or are you planning to create a new KB article?

Comment 8

10 years ago
In this bug, I am trying to replace the current options text to make it correct.'

If you think we should make more articles on PAC, I'd be happy to try to write them as well... I already have a couple other articles in the pipeline for PAC...

Comment 9

10 years ago
Checked in changes to stage copy.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Sorry for the delay. I was in the middle of applying the style guide to the Options window article. All of that, as well as the changes in this bug are now approved to the KB.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

10 years ago
ben: thanks for documenting the option, but this bug is about the format of PAC files (see comment #0)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 12

10 years ago
Okay, you are right. I don't know why I drifted so much.

So the question is, would you really want to document this in the online help?
To be more specific, is this something helpful to the typical end-user and is this explaining how to use an out-of-the-box feature of Firefox.

We know using a PAC file is covered by this criteria. If PAC files need to be formatted a specific way to work with Firefox (and if it's not a standard file) then I think knowing how we require PACs to be written is key to being able to use an out-of-the-box in-the-UI feature.
(Reporter)

Comment 14

10 years ago
the format of PAC files and how they work needs to be documented somewhere by us, even if we just have a pointer to some other authoritative document...
chofmann suggested wiki.m.o for another request that's out of SUMO scope. This might be an option for here as well.
Who typically creates PAC files, for users to use? If not the user, than this does not belong on support.mozilla.com.
I haven't received a reply to comment 16, so I'm closing this as incomplete.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INCOMPLETE

Comment 18

9 years ago
I think usually it's by IT departments (like universities or companies).  So probably better for dev/wiki-mo.

Comment 19

9 years ago
Moving to devmo.

Related docs are
https://developer.mozilla.org/en/Proxies_in_Necko
https://developer.mozilla.org/en/Proxy_UI
https://developer.mozilla.org/en/No_Proxy_For_configuration
http://www-archive.mozilla.org/docs/netlib/pac.html
http://www-archive.mozilla.org/catalog/end-user/customizing/enduserPAC.html
Assignee: benc → nobody
Status: RESOLVED → REOPENED
Component: Knowledge Base Articles → Documentation Requests
Product: support.mozilla.com → Mozilla Developer Center
QA Contact: kb-articles → doc-request
Resolution: INCOMPLETE → ---
Summary: PAC: firefox help needs to document proxy auto-configuration files → PAC: document proxy auto-configuration files
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Automatically closing all bugs that have not been updated in a while. Please reopen if this is still important to you and has not yet been corrected.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago6 years ago
Resolution: --- → INVALID
Reopening for review by Sheppy.
Assignee: nobody → eshepherd
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 22

6 years ago
This work does need to be done, but is very low priority compared to other things, so it won't be done anytime soon unless someone volunteers.
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
(Assignee)

Updated

5 years ago
Whiteboard: u=webdev p=0
(Assignee)

Updated

5 years ago
Component: General → Mozilla Platform
Whiteboard: u=webdev p=0 → u=webdev p=0 c=Platform
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213699
You need to log in before you can comment on or make changes to this bug.