Closed Bug 324676 Opened 18 years ago Closed 18 years ago

day/week view don't refresh correctly when start/end time changed via preferences (no events displayed)

Categories

(Calendar :: Preferences, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dmosedale, Assigned: jminta)

References

Details

Attachments

(1 file)

Once the fix for bug 321769 lands, editing the default start or end hour via the preference dialog in Lightning will dynamically reset that value on the view.  The view will then refresh itself according to the value, but the refreshed version has no events.  The user needs to manually do something that forces another refresh to see the events again.
Turns out this issue applies to Sunbird also.
Component: Lightning → Base
Did the landing of bug 324665 help with this?
(In reply to comment #2)
> Did the landing of bug 324665 help with this?

The problem is still present in Sunbird win32 hourly build 2006-02-06-22.
*** Bug 329759 has been marked as a duplicate of this bug. ***
Summary: views don't refresh correctly when start/end times edited via preferences → day/week view don't refresh correctly when start/end time changed via preferences (no events displayed)
refresh the view, to get the items again, don't just relayout.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #216297 - Flags: first-review?(mvl)
Comment on attachment 216297 [details] [diff] [review]
refresh not relayout

r=mvl
Attachment #216297 - Flags: first-review?(mvl) → first-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: lightning → base
Component: Internal Components → Preferences
QA Contact: base → preferences
You need to log in before you can comment on or make changes to this bug.