Closed Bug 324710 Opened 18 years ago Closed 2 years ago

Consider fetching IMAP message flags in the background

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1747311

People

(Reporter: mscott, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

For servers that have a hard time fetching the flags for the messages in a folder, we could look into fetching the flags in the background and fetching them in smaller chunks.

Could be a perceived performance win for users using IMAP servers which don't handle this operation very well.
Keywords: perf
Assignee: mscott → nobody
David was this implemented in auto-synch ?
No, this bug is about the flag synching we do when we open a folder; autosync is about syncing the message bodies. Right now, when you open a folder that doesn't support condstore (see bug 336151), we do a fetch 1:* FLAGS to see if any of the flags have changed before we fetch any new message headers - this bug is proposing fetching the flags in chunks in the background.
Severity: normal → minor
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: 1.5 → unspecified
(In reply to David :Bienvenu from comment #2)
> No, this bug is about the flag synching we do when we open a folder;
> autosync is about syncing the message bodies. Right now, when you open a
> folder that doesn't support condstore (see bug 336151), we do a fetch 1:*
> FLAGS to see if any of the flags have changed before we fetch any new
> message headers - this bug is proposing fetching the flags in chunks in the
> background.

this would help gmail, which currently doesn't support condstore.

however, it looks like gmail might support it in the not too distant future http://comments.gmane.org/gmane.mail.imap.general/3199
Blocks: tb-gmailWIP
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
See Also: → 46503
See Also: → 163964

Gene, do you think this still has practical value? But only or mainly for very large folders?

Flags: needinfo?(gds)

This is probably covered by condstore (but disable by default) and what I did to improve condstore and add qresync here (but on back burner): bug 1747311.
Maybe close as a duplicate of bug 1747311?

Flags: needinfo?(gds)
See Also: → 1747311
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.