Bug 402793 (tb-gmailWIP)

[Meta] Gmail IMAP is still under construction

NEW
Assigned to

Status

defect
12 years ago
4 months ago

People

(Reporter: World, Assigned: World)

Tracking

(Depends on 44 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

User Story

See Comment #28 for NSPR logging.
(Assignee)

Description

12 years ago
After official release of Gmail IMAP, some bugs are opened because Gmail IMAP is not usual IMAP server, "Web Mail accessible via protocol of IMAP" instead, even though Google says "Gmail IMAP is a fairly complete implementation of IMAP".
And Gmail IMAP still has problems(real bugs) in his implementation.
This meta bug's purpose is to close such INVALID bugs relate to Gmail IMAP.

When Gmail IMAP, please read and understand followings before open bug at bugzilla.mozilla.org saying "Tb's fault/flaw/bug".

(1) Read at least RFC 3501
    http://www.faqs.org/rfcs/rfc3501.html
(2) See Gmail IMAP Help articles
> Google Help >  Gmail Help > IMAP Access
>   http://mail.google.com/support/bin/topic.py?topic=12760
(3) Understand at least next article
>   How do actions sync in IMAP?
>    http://mail.google.com/support/bin/answer.py?answer=77657&topic=12762

Please note that Gmail IMAP is still under construction even after official release, as written in following articles. 
> Does Gmail support all IMAP features?
>  http://mail.google.com/support/bin/answer.py?answer=78761&topic=12762
>    Gmail IMAP is a fairly complete implementation of IMAP,
>    but the following features are currently unsupported: (snip)
> Why don't all my views and labels appear?
>  http://mail.google.com/support/bin/answer.py?answer=78772&topic=12763
>    We’re working on making Gmail for IMAP as much like
>    the web interface as we can, (snip)
(Assignee)

Updated

12 years ago
(Assignee)

Comment 1

12 years ago
When you encountered problem with Gmail IMAP, get IMAP protocol log first, in order to see real protocol level flow.
> http://kb.mozillazine.org/Session_logging_for_mail/news
> http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
> http://www.mozilla.org/projects/netlib/http/http-debugging.html
> http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Deployment_Guide-en-US/sso-ov.html#sso-config-firefox-troubleshoot

Following parameter is sufficient usually.
 setenv NSPR_LOG_MODULES imap:5
 SET    NSPR_LOG_MODULES=imap:5
Following parameter is probably required when Sent folder is involved.
 setenv NSPR_LOG_MODULES imap:5,smtp:5
 SET    NSPR_LOG_MODULES=imap:5,smtp:5
Enabling of next option is useful when Drafts folder has relation.
> Account Settings/Copies&Folders
>   Show confirmation dialog when message are saved

If Tb's fault is involved then log analysis by developer is required, attach
log file to bug (text/plain; if file size is accepted).
Never paste long log data to a bug.
Depends on: 402560
(Assignee)

Updated

12 years ago
Depends on: 403039
(Assignee)

Updated

12 years ago
Depends on: 403032
(Assignee)

Comment 2

12 years ago
Unfortunately, it is found that Gmail IMAP has problem of Bug 390795.
> Bug 390795 attachments corruption for IMAP account (truncated due to estmated/incorrect RFC822.SIZE)
Then "incorrect RFC822.SIZE" bug of Gmail IMAP has produced two INVALID bugs.
  Bug 403032 & Bug 403039 which have been closed as DUP of Bug 390795.
I hope no flood of DUP bugs by Gmail IMAP...
Blocks: 400931
(Assignee)

Comment 3

12 years ago
Phil Ringnalda pointed important artcle for Thunderbird/Gmail IMAP users in Bug 400931 Comment #8. Read this articles also before open Gmail IMAP related bug, please.
> http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php
(Assignee)

Updated

12 years ago
Depends on: 404217
(Assignee)

Updated

12 years ago
Depends on: 404264
(Assignee)

Updated

12 years ago
No longer depends on: 404264
(Assignee)

Updated

12 years ago
Depends on: 408506
No longer depends on: 408506
Depends on: 408506
(Assignee)

Updated

11 years ago
Depends on: 413254
(Assignee)

Updated

11 years ago
Depends on: 417167
(Assignee)

Updated

11 years ago
Depends on: 427007
(Assignee)

Updated

11 years ago
No longer depends on: 402759
(Assignee)

Comment 4

11 years ago
A part of document pointed in Comment #3 : About [Gmail]/Trash.

>(snip)
> The problem is that gmail only keeps a single copy of a message with multiple labels.
> If you apply the Trash label by placing the message in the [Gmail]/Trash folder,
> you are telling GMail to remove the message from all labels,
> and GMail will also delete the message in 30 days.
>(snip)
> Or maybe you think you are relying on the automatic "second copy" that
> Gmail has in the "[Gmail]/All Mail" folder:
> again, moving a message to the Trash(==[Gmail]/Trash) will remove it from there as well.

Further, once label of "[Gmail]/All Mail" is removed by move of a mail to [Gmail]/Trash folder, it seems that "copy back of a mail to [Gmail]/All Mail folder==label the mail [Gmail]/All Mail again" is impossible. I tried it, but nothing was copied to "[Gmail]/All Mail". Copy/move to other mail folder(==put a label other than "[Gmail]/All Mail") was required to avoid delete of the mail in 30 days.
(Assignee)

Comment 5

11 years ago
Note:

Recovery from problem such as Bug 417167(Undo delete), Bug 427007(Undo move) is always possible via Gmail Web Interface, by re-labeling mail in "All Mail" or "Trash", unless "permanent remove of mail in 30 days" is executed after copy/move to "[Gmail]/Trash" folder. This recovery by re-labeling is always possible via Gmail IMAP too(by copy/move back of mail), except when copy/move back from "[Gmail]/Trash" to "[Gmail]/All Mail". 

Call "Other than [Gmail]/All Mail & [Gmail]/Trash" Usual_folder here.
Standard IMAP Trash(shown as [IMAP]/Trash in Gmail Web Interface) is also an Usual_folder.  

  ---   -------------------   -------------------  --------------------------
        Source of copy/move   Target of copy/move  Recovery by this operation
  ---   -------------------   -------------------  --------------------------
  (1)   Usual_folder          Usual_folder         Possible
  (2)   [Gmail]/All Mail      Usual_folder         Possible
  (3)   [Gmail]/Trash         Usual_folder         Possible
  (4)   [Gmail]/Trash         [Gmail]/All Mail     Impossible
  ---   -------------------   -------------------  --------------------------

Unless copy/move to [Gmail]/Trash is executed, the mail is always held in "[Gmail]/All Mail", so (1) or (2) is always possible.
Even when a mail was copied or moved to [Gmail]/Trash, (3), copy/move back to Usual_folder is possible via Gmail IMAP(re-labeled by Gmail IMAP) unless "permanent remove in 30 days" is invoked, and the copied back/moved back mail can bee seen in the Usual_folder via Gmail IMAP.
However, when (4), Gmail IMAP re-labels the mail as "All Mail"(it can be seen via Gmail Web Interface), but Gmail IMAP won't show the re-labeled mail in "[Gmail]/All Mail" folder via Gmail IMAP Interface (this is phenomenon I wrote in Comment #4. Gmail IMAP bug, basically.)
Because of problem in (4), mismatch occurs after operation of (4), between "All Mail" via Gmail Web Interface and "[Gmail]/All Mail" via Gmail IMAP.
It may cause user's confusion in some situations.
(Assignee)

Comment 6

11 years ago
FYI. Getting timestamp of NSPR log with DebugView on MS Windows.

When POP3/SMTP, conversation is very simple. But when IMAP, multiple connections can be used & cached, and when IDLE is supported, asynchronous notification can arrive from server. And, NSPR logging doesn't have timestamp capability. These make IMAP related problem analysis difficult sometimes. 

When MS Win, timestamp can be obtained by NSPR logging with DebugView.
See Bug 86396 Comment #15 to get DebugView, and see Bug 86396 Comment #7 for getting NSPR log with DebugView.
See attached log file to Bug 425897 Comment #13 for example.
 (1) Start DebugView(as admin user), stop capture
 (2) SET NSPR_LOG_MODULES=all:5
     SET NSPR_LOG_FILE=WinDebug
     thunderbird.exe -P
 (3) Enable capture at DebugView
 (4) Execute required test
 (5) Confirm that problem occurs
 (6) Stop capture at DebugView, and save log data to a file
 (7) Shutdown Thunderbird
 (8) Teminate DebugView
You can get NSPR log data for step (3) thru (6) only, with timestamp.
(Assignee)

Updated

11 years ago
Depends on: 431680
(Assignee)

Updated

11 years ago
Depends on: 428947
(Assignee)

Updated

11 years ago
Depends on: 432060
(Assignee)

Comment 7

11 years ago
FYI.
Following is explanation on "Delete" by Brian Kennelly (Bug 428947 Comment #6).

> If you mark a message deleted in a user-label folder, Gmail simply removes
> the label, and reports it as expunged as soon as possible.
> Issuing an EXPUNGE command simply returns OK.
>
> In All Mail, Trash and Spam, messages marked deleted actually pick up
> the \Deleted flag.  An EXPUNGE command will then delete them.
> (They are, in effect, the only "real" folders.)
(Assignee)

Updated

11 years ago
Depends on: 423354
(Assignee)

Updated

11 years ago
Depends on: 440951
(Assignee)

Updated

11 years ago
Depends on: 445066
(Assignee)

Updated

11 years ago
Depends on: 448951
(Assignee)

Updated

11 years ago
No longer depends on: 448951
(Assignee)

Updated

11 years ago
Depends on: 449088
(Assignee)

Updated

11 years ago
Depends on: 439216
(Assignee)

Comment 8

11 years ago
FYI.
Following is comment by Brian Kennelly on 2008-07-13 to Bug 428947 Comment #8. 
> Just a quick update.
> Gmail no longer stores the \Deleted flag on messages in "All Mail", although it indicates success.
> Because of that, EXPUNGE is now meaningless in that folder. 
> Trash and Spam still behave normally.

It seems to be the reason why "move back from [Gmail]/Trash to other folder(except [Gmail]/Spam)" recently/currently recovered all normal Gmail's labels(including label of "All Mail"==[Gmail]/All Mail folder of Gmail IMAP).
(Assignee)

Updated

11 years ago
Depends on: 450227
(Assignee)

Comment 9

11 years ago
To all readers of this bug:

Many of "funny phenomena with Gmail IMAP" is due to special design/spec of Gmail/"Gmail IMAP"(never be caused by Tb's fault). So many bug reports for such funny phenomena are closed as INVALID. Please see/read such reports via. "Dependency tree for this bug" with "Show Resolved" option.
(Assignee)

Updated

11 years ago
Depends on: 428316
(Assignee)

Updated

11 years ago
Depends on: 425927
(Assignee)

Updated

11 years ago
Depends on: 450368
(Assignee)

Updated

11 years ago
Depends on: 450376
(Assignee)

Comment 10

11 years ago
Following good document was introduced in Bug 455564 Comment #c1.
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite
(Assignee)

Updated

11 years ago
Depends on: 447960
(Assignee)

Updated

11 years ago
Depends on: 467841
(Assignee)

Updated

11 years ago
Depends on: 467860
(Assignee)

Comment 11

11 years ago
FYI.
When Gmail is localized(Gmail Display Languge: is set to other than English), and if "account wizard for Gmail IMAP" is used to define Gmail IMAP account, very confusing phenomenon can very easily occur.
And, if localized version of Tb is used in conjunction with Gmail Display Languge: setting, situation becomes worse. Further, when localized folder name of Gmail(Gmail label)==localized Tb's folder name for UI, situation becomes worst.
See Bug 467860 for our many confusions. See Bug 467860 Comment #23 for reasons caused our many confusions.
Product: Core → MailNews Core
(Assignee)

Updated

10 years ago
Depends on: 478996
(Assignee)

Updated

10 years ago
Depends on: 481845
(Assignee)

Updated

10 years ago
Depends on: 453907
(Assignee)

Comment 12

10 years ago
FYI.
Gmail IMAP currently has following issue in sharing of Gmail account by multiple Gmail IMAP clients.
> http://mail.google.com/support/bin/answer.py?answer=96926&topic=12922
> Updates not reflected in multiple clients
Please be careful in test for Gmail IMAP related issues such as Bug 450246.
(Assignee)

Updated

10 years ago
Depends on: 482337
(Assignee)

Updated

10 years ago
Depends on: 475852
Depends on: 482946

Updated

10 years ago
Depends on: 482951
(Assignee)

Updated

10 years ago
No longer depends on: 482946
(Assignee)

Updated

10 years ago
No longer depends on: 482951
Depends on: 484376
(Assignee)

Updated

10 years ago
Depends on: 488097
Depends on: 489221

Updated

10 years ago
No longer depends on: 489221
(Assignee)

Comment 13

10 years ago
(memo for me)
As of today, following can be said.
(a) Account definition
> If you want to use Gmail IMAP,
> you are better to define account via "Account Wizard for Gmail IMAP"(Tb3 or later)
> instead of ordinal "Account Wizard for POP3/IMAP".
(b) Domain name
> If domain name in your country is other than gmail.com(e.g. googlemail.com),
> you need to change server name and domain name in mail address manually after account definition. 
(c) Display Language of Gmail(country/language dependent folder name)
> If you use Gmail's Display Language other than English(US),
> you need to change folder choice for Drafts, Sent, Trash, Junk etc. manually.
> (See bug 476260 for improvement of it).
> If you want to use option other than preset option(such as "delete model") by Tb3's "Account Wizard for Gmail IMAP",
> you should use it with your own risk after reading Gmail Help documents well.
(Assignee)

Comment 14

10 years ago
Woops! pressed enter too early.

(d) Delete model
> If you want to use "delete model" other than preset one(Remove it immediately) by Tb3's "Account Wizard for Gmail IMAP",
> you should use it with your own risk after reading Gmail Help documents well.
> - If you move a mail to [Gmail]/Trash, the mail is automatically removed permanently after 30 days.
(e) Gmail IMAP particularity.
> User should read Gmail Help documents before start to use Gmail IMAP for;
> - Special characteritics of [Gmail]/All Mail, [Gmail]/Trash, [Gmail]/Spam.
>   - Copy to these folder == Move to these folder.
>   - Move to these folder == Move of mail among Gmail's *FOLDER*
>                             named All Mail, Trash, Spam.
>                             => All other Gmail Label is removed
>                             => Copy in other IMAP fodler automatically deleted
> - Difference between "*FOLDER* name at Gmail Web Interface" and "IMAP folder name via Gmail IMAP".
>   (Gmail's FOLDER)
>    All Mail<->[Gmail]/All Mail, Trash<->[Gmail]/Trash, Spam<->[Gmail]/Spam,
>    Drafts<->[Gmail]/Drafts, Sent Items<->[Gmail]/Sent Items
>   (Standard IMAP folders)
>    [Imap]/Drafts<->Drafts, [Imap]/Sent<->Sent, [Imap]/Trash<->Trash
> - Special treatment on [Gmail]/Drafts by Gmail IMAP/Gmail.
(f) User should aware of next;
> "Gmail IMAP" is never oridinal/usual/traditional IMAP server.
> "Gmail IMAP" simply provides an easy-to-use/easy-to-understand way for viewing "Gmail Label".
> (Gmal Label hierarchy is presented by Gmail IMAP folder structure)
> "Gmail IMAP" merely provides a way to manage "Gmail Label" of mail of Gmail,
> via protocol named IMAP, using IMAP compliant mail client.
(Assignee)

Comment 15

10 years ago
(g) Gmail's SMTP server.
> - If mail is sent via Gmail's SMTP server, copy of sent mail is automatically
>   placed in "Sent Mail" *FOLDER* of Gmail(== [Gmail]/Sent Mail via Gmail IMAP).
> - Unless you register mail address other than one for the Gmail's SMTP username,
>   (other Gmail account's one, other ISP's one)
>   Gmail replaces From: header of sent mail by mail address assignd to
>   the Gmail's account. (It's not IMAP related. Same since initial.)
(Assignee)

Updated

10 years ago
Depends on: 462880
(Assignee)

Comment 16

10 years ago
(In addition to comment #1. About NSPR logging for mail&news)

FYI.
www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap looks to be deleted and transfered to next page, with many improvements.
> https://wiki.mozilla.org/MailNews:Logging
(Assignee)

Updated

10 years ago
Depends on: 490556

Updated

10 years ago
Depends on: 484380
Blocks: 489791
(Assignee)

Updated

10 years ago
No longer blocks: 489791
Depends on: 489791
Depends on: 492517
Depends on: 493455
(Assignee)

Updated

10 years ago
Depends on: 493893
(Assignee)

Comment 17

10 years ago
FYI.
Bug 86396 has been fixed, and NSPR 4.8 has been landed on mozilla-central in addition to mozilla-1.9.1 (bug 492464)/ So timestamp of NSPR log is now available in Tb trunk.
See next document for timestap of NSPR log.
> http://www.mozilla.org/projects/nspr/reference/html/prlog.html#25328
Currently, SET NSPR_LOG_MODULES=xxx:5,yyy:5,timestamp is parameter for it.
(Assignee)

Updated

10 years ago
Depends on: 465670
(Assignee)

Updated

10 years ago
Depends on: 494784
(Assignee)

Updated

10 years ago
Depends on: 499630
Depends on: 499450
(Assignee)

Updated

10 years ago
Depends on: 500272
(Assignee)

Updated

10 years ago
Depends on: 502370
(Assignee)

Updated

10 years ago
Depends on: 503035
(Assignee)

Updated

10 years ago
Depends on: 507553
Depends on: 508836
Depends on: 508841
Depends on: 508838
(Assignee)

Updated

10 years ago
Depends on: 509334
(Assignee)

Updated

10 years ago
Depends on: 508753
Depends on: 511073
(Assignee)

Updated

10 years ago
Depends on: 511331
Depends on: 512745
Depends on: 515031
(Assignee)

Updated

10 years ago
Depends on: 512278
Depends on: 510318
(Assignee)

Updated

10 years ago
Depends on: 516325

Comment 18

10 years ago
(In reply to comment #17)
> FYI.
> Bug 86396 has been fixed, and NSPR 4.8 has been landed on mozilla-central in
> addition to mozilla-1.9.1 (bug 492464)/ So timestamp of NSPR log is now
> available in Tb trunk.
So timestamp for log files of POP3, IMAP etc. is now available both in TB trunk (3.1x) and TB3 branch (1.9.1/3.0x).
Depends on: 517466
(Assignee)

Updated

10 years ago
Depends on: 517629

Updated

10 years ago
Depends on: 519797
Depends on: 520403
Depends on: 431440
Depends on: 521294
(Assignee)

Updated

10 years ago
Depends on: 512432
Depends on: 527708
good morning.

http://tinyurl.com/yzfeqg2 are bugs that currently don't block this bug. May I suggest additional triage as a continuation of the excellent work being done, such that one of the following occurs to http://tinyurl.com/yzfeqg2:
a) remove gmail from summary if bug is not gmail related 
b) bug is made to block this meta
c) add a whiteboard notation if bug is gmail related, but for some reason not worthy of blocking this meta
better query is http://tinyurl.com/ygf6no7
(33 bugs instead of 45)
misc for consideration:
 bug 519387 Bin and Trash confused with Google IMAP support; ditto Bin and Drafts confusion
 bug 507412  Google IMAP Outgoing Server (SMTP) created by Account Wizard does not disappear from SMTP list when removed 
 bug 505807 Google Mail accounts are duplicated and mirrored when using the Account wizard to create them.

Comment 22

10 years ago
It would be less imprecise to refer to "gmail IMAP" as: gmail's emulation of IMAP.  The former errantly implies that gmail has correctly implemented IMAP.

Updated

10 years ago
Depends on: 532415
(Assignee)

Updated

10 years ago
Depends on: 533140
Depends on: 534610
(Assignee)

Updated

10 years ago
Depends on: 516222
Depends on: 536545
Depends on: 540424

Updated

9 years ago
Depends on: 517727

Comment 23

9 years ago
Sorry for adding bug 517727 here. I does not depends on. Hope, somebody can remove my mistaken from the dependency list.

Updated

9 years ago
No longer depends on: 517727
Please use instructions at
> https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
to get a msgdb log for analysis of MsgDB(.msf) related issues.
(Assignee)

Updated

9 years ago
Depends on: 535523
(In addition to comment #15)
Gmail's setting to avoid replace of From: addr by mail address assigned to the Gmail account.
> Gmail's Settings/Accounts and Import, Sending mail as:, Learn more
> http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=22370
See bug 546479 for replace of From: by Gmail.
(Assignee)

Updated

9 years ago
Depends on: 548885
(Assignee)

Updated

9 years ago
Depends on: 550407
(Assignee)

Updated

9 years ago
Depends on: 518581
FYI. Newer description about HTTP_Logging.
> https://developer.mozilla.org/en/HTTP_Logging
(Assignee)

Updated

9 years ago
Depends on: 562767
(Assignee)

Updated

9 years ago
Depends on: 562748
(Assignee)

Updated

9 years ago
Depends on: 507200
(Assignee)

Updated

9 years ago
Depends on: 566248
(Assignee)

Updated

9 years ago
Depends on: 573987
(Assignee)

Updated

9 years ago
Depends on: 573985
Depends on: 574521
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

I added links to important Gmail Help articles in next document. (many are pointed in this bug at splitted comments). 
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite#External_links
> External links
>   * Gmail Help articles you have to read before you start using Gmail IMAP.
Please read and understand at least the Gmail Help articles and next section in the document before open Gmail IMAP related bug at B.M.O, please.
> http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite#IMAP

Updated

9 years ago
Alias: tb-gmailWIP
Depends on: 475857
Depends on: 557434
(Assignee)

Updated

9 years ago
Depends on: 589303
Depends on: 593726
(Assignee)

Updated

9 years ago
No longer depends on: 533140
Depends on: 610667
Depends on: 614913
Depends on: 613145
(Assignee)

Updated

9 years ago
No longer depends on: 613145
(Assignee)

Updated

9 years ago
Depends on: 620323
(Assignee)

Updated

8 years ago
Depends on: 533140
(Assignee)

Updated

8 years ago
Depends on: 618553
Depends on: 641553
Depends on: 650103
Depends on: 651945
Depends on: 668759
Depends on: 670939
Depends on: 673400
(Assignee)

Updated

8 years ago
Depends on: 679619

Updated

8 years ago
Depends on: 682903
Depends on: 697409
(Assignee)

Updated

8 years ago
Depends on: 705491
(Assignee)

Updated

8 years ago
Depends on: 624486
Summary of useful Tb's logging.
(1) network
> https://wiki.mozilla.org/MailNews:Logging
> Win example : SET NSPR_LOG_MODULES=timestamp,imap:5,pop3:5,nntp:5,smtp:5
>               SET NSPR_LOG_MODULES=timestamp,imap:5,pop3:5,nntp:5,smtp:5,sync
>               (sync:no buffering. you can check log without termination of Tb)
> IMAP command/response : http://tools.ietf.org/html/rfc3501
(2) POP3/SMTP/NNTP connection states in network log
> http://kb.mozillazine.org/Session_logging_for_mail/news
(3) http, socket, hostresolver
> https://developer.mozilla.org/en/HTTP_Logging
> Win example : SET NSPR_LOG_MODULES=timestamp,nsHttp:5,nsSocketTransport:5,nsHostResolver:5
(Assignee)

Updated

7 years ago
Depends on: 693495
(Assignee)

Updated

7 years ago
Depends on: 721316
(Assignee)

Updated

7 years ago
Depends on: 532159
(Assignee)

Updated

7 years ago
Depends on: 724418
FYI.

(1) Limitation of "Max Gmail Label length=40 bytes" has been relaxed, and it's now "Max Gmail Label length=225 bytes".
> http://news.softpedia.com/news/Gmail-Labels-Can-Be-225-Character-Long-Now-196454.shtml

(2) Single byte characters usable in Gmail Label
> http://www.google.com/support/forum/p/gmail/thread?tid=28c3c3a4bd27a4e8&hl=en
> ! ? * : # § @ & | ¤ @ \ / _ ' " < > + - . , [ ] ( ) Æ Ø Å æ ø å
Any modified-utf-7 can be used as IMAP Mbox name, as far as Gmail/Gmail Imap supports.

(3) Sort order of Gmail Label
> http://www.liamdelahunty.com/tips/gmail_label_sorting.php
> Gmail Label Sorting Order
>     ! Exclamtion mark / Bang
>     ~ Tilde
>     ' Single Quote
>     " Double Quote
>     @ At sign
>     $ Dollar
>     £ Pound (British Currency)
>     * Asterisk
>     & Ampersand
>     # Hash / Pound Sign
>     + Plus sign
>     0-9
>     A-Z
>     The minus '-' symbol gets sorted as per it's folowing Alpha Numeric. - M would be sorted uner M 
> The ^ carat symbol could not be used
Depends on: 730745
(Assignee)

Updated

7 years ago
Depends on: 739110
Depends on: 738718
Depends on: 791497
(Assignee)

Updated

7 years ago
Depends on: 791467
Depends on: 798145
Depends on: 598626
Depends on: 809990
Depends on: 526359
(Assignee)

Updated

7 years ago
Depends on: 815087
No longer depends on: 815087
Depends on: 815087
Depends on: 810632
Depends on: 816327
Depends on: 824972
> David Lechner (:dlech) 2013-01-01 22:05:48 PST
> Depends on: 810632
> David Lechner (:dlech) 2013-01-01 22:13:39 PST
> Depends on: 816327
> David Lechner (:dlech) 2013-01-01 22:40:32 PST
> Depends on: 824972

David Lechner, what kind of "Gmail IMAP's particularity" is relevant to problem of these bugs? What is evidence that these bugs are Gmail IMAP specific problem?
Please note that this meta bug is never a simple collection of user's reports on any problem which user exprienced while he is using Gmail IMAP.
(In reply to WADA from comment #30)
> > David Lechner (:dlech) 2013-01-01 22:05:48 PST
> > Depends on: 810632
> > David Lechner (:dlech) 2013-01-01 22:13:39 PST
> > Depends on: 816327
> > David Lechner (:dlech) 2013-01-01 22:40:32 PST
> > Depends on: 824972
> 
> David Lechner, what kind of "Gmail IMAP's particularity" is relevant to
> problem of these bugs? What is evidence that these bugs are Gmail IMAP
> specific problem?
> Please note that this meta bug is never a simple collection of user's
> reports on any problem which user experienced while he is using Gmail IMAP.

I should have explained in a comment. I was trying to help clean up the Thunderbird-Untriaged category a bit. I put them here so that people who are are knowledgeable of gmail would notice them and help file them correctly if they do not belong here.

If there is a better way to do this, please tell me.
(Assignee)

Updated

6 years ago
Depends on: 844494

Updated

6 years ago
Depends on: 324710
(Assignee)

Updated

6 years ago
Depends on: 854161

Updated

6 years ago
Depends on: 861911

Updated

6 years ago
Depends on: 727790
(Assignee)

Updated

6 years ago
Depends on: 901287

Updated

6 years ago
Depends on: 887613

Updated

5 years ago
Depends on: 494857

Updated

5 years ago
Depends on: 797735

Updated

5 years ago
Depends on: 971656
Depends on: 693204

Updated

4 years ago
Depends on: 1098069
See Comment #28 for NSPR logging.
Whiteboard: ]
(Assignee)

Updated

4 years ago
User Story: (updated)
Whiteboard: ]
(Assignee)

Updated

4 years ago
Depends on: 1129870
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
(Assignee)

Updated

4 years ago
Depends on: 550573
(Assignee)

Updated

4 years ago
Depends on: 557560

Comment 34

3 years ago
I have been using Gmail through Thunderbird for years, with quite some pain. I was surprised to learn that there is such a long list of outstanding issues, and that the problems I experienced would also be experienced by any other user.

There are several important issues. Issue #651945 can even be considered as a confidentiality threat. I learned about it in October and had already forgotten I needed to keep cleaning [Gmail]/Trash.

There are enough problems for users who would want to start using Gmail through Thunderbird to reconsider their choice and perhaps opt for a different MUA or a different provider. I think the current situation warrants warning users - giving them tips, listing problems, linking to this ticket, linking to Gmail's Recommended IMAP client settings and/or linking to https://support.mozilla.org/en-US/kb/thunderbird-and-gmail
In fact, since Thunderbird automatically configures gmail.com adresses for IMAP, there is an implication that Gmail is an IMAP server. If that is not quite correct, then Thunderbird itself can be blamed if it fails to workaround issues and/or to warn users.

If we go for a warning message, then it will be quite delicate to choose language which is either vague, or which blames properly. I do not know IMAP and Gmail well enough to propose or approve of any wording.

Comment 35

3 years ago
I realized a few months ago that my All Mail folder contained spam not because of my conservative technique to deleting my presumed spams, as I had thought for years, but because the way I had been managing the presumed spam folder on Gmail for years was counter-productive (due to issue #651945). Instead of deleting mails from that folder, I was effectively moving them to the All Mail folder.

I then proceeded to clean my mailbox from all of that junk, bringing about a hundred thousand messages down to a mere 23301. Although I made use of several techniques to optimize the process, that process took numerous tens of hours, over the course of numerous weeks, if I count everything. A large part of that time was wasted due to search bugs and spent reporting those of these bugs which had not been reported yet (see ticket #519202). Only half of what I re-deleted was spam. A large part of that time was also spent reading old mails and satisfying my curiosity, but even a quick spam cleanup without bugs would have taken an incredible amount of time. And such a quick cleanup would have kept numerous mails which contained confidential credentials for customer servers which I had ordered deleted years ago.

Issue #651945 may be Google's fault. Since I chose Gmail 10 years ago, I can probably not blame Mozilla for making me go through that awfully painful process. However, my mother has managed to configure Thunderbird to use a Gmail account without even asking for help just last week. The current automatic configuration for Gmail without warning is not just sub-optimal, but irresponsible.

I urge Mozilla to stop facilitating Gmail usage through Thunderbird until at least issue #651945 is solved or a warning as discussed in Comment #34 is added.

Updated

3 years ago
Depends on: 1228251

Updated

3 years ago
Depends on: 1213021
(Assignee)

Updated

2 years ago
Depends on: 885262
(Assignee)

Updated

2 years ago
No longer depends on: 885262
(Assignee)

Updated

2 years ago
Depends on: 744562
(Assignee)

Updated

2 years ago
Depends on: 764663

Comment 36

2 years ago
Fix is Tool > Account setting>outgoing

IMAP.gmail.com for Thunderbird on Gmail

Comment 37

2 years ago
I'm trying to buckup my email "google apps" in new thunderbird 52.1, I setup the account and let thunderbird download when size became 3+GB I looked at the folder and found massive size at some folders which is equal to gmail lable and should have headers only all bodies should be in allmail folder.
I stopped the download as it will be huge size duplicates.
I looked at my account setting and couldn't find anything wrong as mentioned at support article
https://support.mozilla.org/en-US/kb/thunderbird-and-gmail

Comment 38

2 years ago
There seems to be a new sign in to Gmail for a new or setting up an account at least where the password was recently changed. I get a window to pop up requesting me to enter my my credentials "Sign in to continue to Mozilla Thunderbird Email"  The only thing I can do on this page (that has any affect) is change my email address. I am using Thunderbird 45.8.0 for Linux.

Comment 39

2 years ago
(In reply to Jim Castle from comment #38)
> There seems to be a new sign in to Gmail for a new or setting up an account
> at least where the password was recently changed. I get a window to pop up
> requesting me to enter my my credentials "Sign in to continue to Mozilla
> Thunderbird Email"  The only thing I can do on this page (that has any
> affect) is change my email address. I am using Thunderbird 45.8.0 for Linux.
I have been having a similar problem for about 1-2 weeks now. The problem, I think, is Google's new sign-in UI. I enter my e-mail address, hit the "Next" button, and the button does nothing. I have used Thunderbird on both Windows and Ubuntu Linux; neither one works.
"Next" login problems for gmail are handled in newer versions of 52.x, for example 52.1.0 and 52.1.1

Comment 41

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #40)
> "Next" login problems for gmail are handled in newer versions of 52.x, for
> example 52.1.0 and 52.1.1

I guess that's the problem right there: My current computer can't run anything newer than Windows 7. Its current OS is Windows XP, which is what it shipped with. I don't have a disc to upgrade the OS, so it's stuck at Windows XP. As such, I can't run the latest version of Thunderbird on it - I think the latest version for XP is 38.5.0. Now that I think about it, that's obviously my problem.
TL;DR thread 
I have issue with signing with Oauth2 with version 45.8.0 
Once I turn on 2-step authentication for one account it opens 0auth2 prompt and it do not pass next you can click that button 20  times no matter it doesn't connect to server.
If I switch to normal password and enter app password it works.
My concern is that with other of my accounts it works with 0auth2 and I have password generated only for smtp for that account.
Is there a bug with 0auth2 or I should use normal password I mean application password created in google settings?
The OAuth2 problem was resolved for 52.1.0 in bug 1359297 (or rather worked around, it was a server bug).
Depends on: 1427619
Depends on: 1323855

Updated

4 months ago
Depends on: 1511991
You need to log in before you can comment on or make changes to this bug.