Tree Widgets Are Not Painting Correctly (Fx and Tb)

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mscott, Assigned: roc)

Tracking

({regression})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

14 years ago
Regression that happened sometime yesterday. In the 01/26 builds, the thunderbird tree widgets are no longer painting there contents correctly.

Could it be related to Bug 317375 which did touch the tree frame code yesterday?

Screen shot coming up
Reporter

Updated

14 years ago
Blocks: 317375
No longer blocks: 317375
duplicate of bug 324836 (which has just been fixed on trunk)?
hmm, no, probably not. What's the simplest place this appears? anywhere in Firefox? Guess I'll spin up a Thunderbird build
Reporter

Comment 4

14 years ago
I just updated layout\generic\nsFrame.cpp and rebuilt layout, but the problem appears to still be there. Shucks.
Reporter

Comment 5

14 years ago
This might just be noise, but if I drag the columns somewhere else (like over to the left near the subject, they start painting fine. But anything after the sender column fails to paint.
Reporter

Comment 6

14 years ago
Hey Roc, I can reproduce this in todays Firefox build too.

Just got to the bookmark manager.

You might need to add some extra tree columns to the bookmarks tree. I see lots of blank columns on the right most tree cols. 

And I just noticed that if I move the vertical splitter to the left and to the right in this window, I see some of the items get painted. I tried this in Thunderbird and saw the same thing. Resizing the splitter, triggered some level of painting to happen on these tree columns.

I hope that helps.

Reporter

Comment 7

14 years ago
Its even easier now. Just take the bookmarks manager as is, and move the splitter to the right, you should see the bookmarks tree stop getting painted.
Reporter

Comment 8

14 years ago
adjusting the summary since this applies to Firefox and Thunderbird.

And moving the component.
Component: Mail Window Front End → Layout
Product: Thunderbird → Core
Summary: Thunderbird's Tree Widgets Are Not Painting Correctly → Tree Widgets Are Not Painting Correctly (Fx and Tb)
(In reply to comment #5)
> This might just be noise, but if I drag the columns somewhere else (like over
> to the left near the subject, they start painting fine. But anything after the
> sender column fails to paint.

I experienced this behaviour two years ago in AddressBook - bug 251079. It looks like you summoned it back ;)
No longer blocks: 317375
Component: Layout → Mail Window Front End
Product: Core → Thunderbird
Summary: Tree Widgets Are Not Painting Correctly (Fx and Tb) → Thunderbird's Tree Widgets Are Not Painting Correctly
Posted patch fixSplinter Review
This fixes it for me. OffsetForHorzScroll expects cellrect to be in frame coordinates. We need to adjust the x coordinate to rendering coordinates after OffsetForHorzScroll but before PaintCell. This is now consistent with the code around the PaintCell call earlier in the code.
Assignee: mscott → roc
Status: NEW → ASSIGNED
Attachment #209766 - Flags: superreview?(dbaron)
Attachment #209766 - Flags: review?(dbaron)
Reporter

Comment 11

14 years ago
restoring fields lost due to bug stompage.
Blocks: 317375
Component: Mail Window Front End → Layout
Flags: review?(dbaron)
Keywords: regression
Product: Thunderbird → Core
Summary: Thunderbird's Tree Widgets Are Not Painting Correctly → Tree Widgets Are Not Painting Correctly (Fx and Tb)
Reporter

Comment 12

14 years ago
This patch does indeed fix the problem for me in thunderbird. I didn't test it in Firefox. Thanks roc!
Attachment #209766 - Flags: superreview?(dbaron) → superreview+

Comment 13

14 years ago
*** Bug 324873 has been marked as a duplicate of this bug. ***
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 15

14 years ago
*** Bug 324881 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
*** Bug 324905 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
*** Bug 324930 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.