Listboxes are broken because they're not treated as pseudo-stacking-contexts

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: roc, Assigned: roc)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

My patch in bug 317375 broke listboxes because they're not being treated as pseudo-stacking-contexts as intended. Options don't receive events because their backgrounds are placed under the <select> background.
*** Bug 324834 has been marked as a duplicate of this bug. ***
Posted patch fixSplinter Review
I'm not aware of any internal API we have to say "this frame acts like a block internally". IsContainingBlock is close, but it doesn't include scrollframes or frames derived from scrollframes. In the absence of such an API (IsFrameOfType?) I'm going to have to hack it ... e.g., setting IsContainingBlock() for scrollframes is too risky for a quick fix, I've really tried hard not to disturb layout behaviour.

I don't think you can have inline regular scrollframes currently, so I'm not testing for those. We'll need it for overflow:auto inline-blocks but hopefully this will be replaced with a real API by then.
Attachment #209738 - Flags: superreview?(dbaron)
Attachment #209738 - Flags: review?(dbaron)
*** Bug 324812 has been marked as a duplicate of this bug. ***
Attachment #209738 - Flags: superreview?(dbaron)
Attachment #209738 - Flags: superreview+
Attachment #209738 - Flags: review?(dbaron)
Attachment #209738 - Flags: review+
*** Bug 324806 has been marked as a duplicate of this bug. ***
fix checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613

verified on windows
/layout/generic/nsIFrame.h, line 1147 -- virtual PRBool IsFrameOfType(PRUint32 aFlags) const

does that comment need an update? :)
Not sure what you mean.
*** Bug 324908 has been marked as a duplicate of this bug. ***
*** Bug 324932 has been marked as a duplicate of this bug. ***
your comment in the patch says that IsFrameOfType would be nice, I'm saying it exists.
It's not really implemented yet.
Blocks: 332082
You need to log in before you can comment on or make changes to this bug.