Close buttons and site icons (favicons) no longer appear in backgrounded tabs unless hovered over

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: waynegwoods, Unassigned)

Tracking

({regression, testcase})

Trunk
PowerPC
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
Only seems to have broken in the latest Deer Park trunk nightly (20060126).

As the Summary says, site icons and the tab close button no longer appear in background tabs, unless you hover over them with the mouse. The tab close won't appear unless you hover directly over it, but the favicon will appear if you hover anywhere over the tab. They disappear again as soon as you stop hovering over them.

Worked fine in the 20050125 nightly.
It is an opacity issue. 
Anything with an opacity less than 1 disappears (that affects the tabs, except the active one) and anything that has opacity set in an html document. I'll attach an html document in a moment.
Posted file test case 1
There should be two identical boxes on the page. In the second one, the span(s) have the opacity set 0.8. They disappeared. Hover over the empty area and they are back.
Regression from bug 317375
Are the people seeing this using cairo nightlies? Note bug 324561.
Reporter

Comment 5

14 years ago
I don't know. Is Cairo now used by default in trunk nightlies?

One thing to note, however, is that bug 324561 seems to have cropped up at least 2 days before this bug did.
I'm seeing this opacity problem both in the latest Firefox trunk and Camino trunk builds (obviously Camino is not affected by the opacity setting on the close button). None of them are Cairo enabled, as far as I know. 
about:buildconfig does not mention --enable-cairo.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060128 Firefox/1.6a1 ID:2006012804
Keywords: testcase
this is a highly visible user experience bug - raising severity

just to mention; the favicon shows if any part of the background tab is hovered over.  But the close button of the same tab only appears if it is directly hovered over.
Severity: normal → critical
Status: NEW → ASSIGNED

Updated

14 years ago
Keywords: regression
Is opacity involved somehow?  Note bug 325296 (mac-only).
(In reply to comment #8)
> Is opacity involved somehow?  Note bug 325296 (mac-only).
> 

Yes, as I mentioned in comment 1. 
for the globe icons, you have these rules:
tab:not([selected="true"]) > .tab-image-middle > .tab-icon {
   opacity: 0.5;
}
tab:not([selected="true"]):hover > .tab-image-middle > .tab-icon {
   opacity: 1.0;
}
(in global/browser.css).
Similar rules for the close button

Comment 10

13 years ago
*** Bug 327665 has been marked as a duplicate of this bug. ***
Guessing mconnor meant to assign
Assignee: nobody → mconnor
Status: ASSIGNED → NEW
Bah, meant to unassign it from nobody, not to assign it to mconnor, since he doesn't remember why he was assigning it at all, now.
Assignee: mconnor → nobody
this is now WFM on Mac Trunk build from 2006-03-07
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.