HTML Reply to .EML/rfc822 attachment without Message-ID results in HTML source within compose body

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
13 years ago
a year ago

People

(Reporter: Mike Cowperthwaite, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Following up on the fix for bug 314349.  Testing TB 1.6a1-0127 (latest-trunk).

If I open a .EML or message/rfc822 attachment into a standalone window, and that message does not have a Message-ID header, and I click Reply, the compose window opens showing the reply text embedded within a bunch of HTML tags -- in other words, it appears the source is being double-nested within the HTML.

In the simple case, a one-line plain-text message, replied-to as HTML, yields:

blah@blah.tld wrote:
| <pre wrap>text
|
| </pre></body>
| </html>
| </html>

This only occurs with "Start my reply below the quote".  No similar issue when forwarding inline, and no obvious problem when replying as plain text.  It occurs whether the original message is plain or HTML.
(Reporter)

Comment 1

13 years ago
Created attachment 209862 [details]
test case message without Message-Id

Steps to reproduce:
1) Set up default identity with Compose as HTML, Reply Below Quote
2) Open this .EML file using   File|Open
3) Click the Reply button; observe

Actual results:
3) tags!

Expected results:
3) no tags visible
Testing on a message of mines, it showed as a one-liner:
{{
Serge GAUTHERIE wrote:
> <div class="moz-text-flowed" style="font-family: -moz-fixed">
> Thanks. Appreciated.
}}

[Mozilla Thunderbird, version 3 alpha 1 (20060403)] (nightly) (W98SE)

Confirming, on W98SE.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20060406 SeaMonkey/1.1a] (nightly) (W98SE)

SMv1.1a branch has it too.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.2) Gecko/20060407 SeaMonkey/1.0.1] (nightly) (W98SE)

As with bug 333074,
this bug cannot be tested because Reply/... do no work:
{{
Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMessenger.msgHdrFromURI]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/mailCommands.js :: ComposeMessage :: line 245"  data: no]
}}
SMv1.0.x branch must be missing some patchs: but which ones ?
Component: Message Compose Window → MailNews: Attachments
Depends on: 314349
Product: Thunderbird → Core
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> SMv1.0.x branch must be missing some patchs: but which ones ?

Bug 314349 -- the one that you, for some unknown reason, set as a dependency to this bug.  Further, you're mistaken in changing the component here -- it's possible this should be MIME rather than Composition, but it's decidedly not an attachment problem; the symptom happens with .EML files as well as RFC822 attachments.
Assignee: mscott → nobody
Component: MailNews: Attachments → MailNews: Composition
(In reply to comment #3)
> (In reply to comment #2)
> > SMv1.0.x branch must be missing some patchs: but which ones ?
> 
> Bug 314349 -- the one that you, for some unknown reason, set as a dependency to

It seems unlikely: while bug 314349 patch was not checked in MOZILLA_1_8_0_BRANCH, it has nothing to do with SeaMonkey.
When reporting bug 333074, I guessed it was more like missing bug 204350 patch !?

I set the dependence based on your comment 0.

> this bug.  Further, you're mistaken in changing the component here -- it's
> possible this should be MIME rather than Composition, but it's decidedly not an
> attachment problem; the symptom happens with .EML files as well as RFC822
> attachments.

I stand corrected: what I did want to do was to set Product to Core...

Updated

12 years ago
OS: Windows 2000 → All
Hardware: PC → All

Updated

10 years ago
QA Contact: composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 5

a year ago
I do not see the HTML elements testing reply to attachment 209862 [details]. I went to Account Settings - Composition and chose to start reply below quote.

Closing as WFM.

Thunderbird 52.0.1 (32-bit)
Windows 7 64-bit
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.