[RFE] Option to prevent file:// urls from being translated to mailbox:// urls and attachments

RESOLVED DUPLICATE of bug 132257

Status

--
enhancement
RESOLVED DUPLICATE of bug 132257
13 years ago
13 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: 

File URLs are automatically attached to the email. I would prefer to have the option to include a literal File URL, when I am certain it would be valid on the recipient's computer.

Reproducible: Always

Steps to Reproduce:
1. Create a new message in HTML mode.
2. Type some text.
3. Select the text and insert a link to a file:// URL (either using the Choose File button, or typing the link manually).
4. Send the email.
Actual Results:  
The file is attached to the email and the link is modified to point to the attached file.

Expected Results:  
The file URL is sent literally, the recipient receives the file URL and can click on it to access the network location.

File URLs can be effective in a corporate situation, where network shares are available for all users. There is unfortunately no way to provide a link to network locations or files through email when using Thunderbird, as it will automatically attach any files linked.

This is ineffective because most items where I would like to use a File URL to direct the recipient to them, are either very large files, or are blocked by the mailserver, or simply something that is intended to be centralized and modifiable directly by anyone.

Comment 1

13 years ago
This is a duplicate, see bug 315868 and bug 132257.

*** This bug has been marked as a duplicate of 132257 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.