Extensions and Themes stopped working after downgrading to Firefox 1.5

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: 4paul3, Assigned: rstrong)

Tracking

({fixed1.8.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

After installing Firefox(DeerPark) v1.6 for OS X.3.9 certain components of your profile are modified such that reversion to v1.5 will no longer recognize some themes and extensions that were previously installed. By going into User>Library>Application Support>Firefox>Profiles>Weirdfilename.default and removing extensions.ini and extensions.rdf you can regain the use of your old themes and extensions with v1.5. Firefox cannot be running when you remove those files, and when you restart FF those files will be recreated without the modifications introduced by v1.6 and your old themes and extensions will work again.

Reproducible: Always
Chances are you are experiencing one of the install bugs for the Extension Manager (e.g. bug 315245, bug 324314, and several others) which can prevent normal operations such as you describe. Can you zip up your profile's extensions directory along with the extensions.rdf, extensions.cache, and extensions.ini files that are located inside your profile's directory and either email the zip file to me or attach it to this bug? I suspect the resulting zip file will be larger than the maximum allowed for attachments so you will probably have to email them to me.
http://www.mozilla.org/support/firefox/profile
BTW: If you are no longer able to reproduce this bug then the files won't be of any help and diagnosing why this occurred will probably not be possible.
Also,
* did the compatibility check wizard run after installing the old version of the app?
* did you let the wizard finish if it ran?
* were you connected to the internet when the wizard ran?

The only modifications are to disable incompatible extensions and the same process should enable the extensions when downgrading the app to a version the extensions are compatible with. This won't occur if the compatibility check wizard does not run, you aren't connected to the internet when it runs, etc.
No response, resolving WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
I responded. In fact I sent you all the files you requested via e-mail if you recall. I just didn't do that here because I got your e-mail address and wrote to you directly.
I apologize... I receive numerous emails and I go by the responses in the bugs themselves. I reopened this bug and please post your response here.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Created attachment 213011 [details]
files received

Relevant part of the email in regards to answering comment #3

Yes the Compatibility Wizard ran when I restarted v1.5, and yes I let it finish while connected to the Internet. I did not install the old version of the app because I left it in the Applications folder. I did quit DeerPark before starting v1.5.
Note: there are no modifications made to the profile that will cause this when downgrading to 1.5... there are cases where the extension manager code might have an unhandled error or there may be a bad assumption in the code either of which could cause an extension or theme not to be compatible.
Summary: Repair themes after v1.6 installation OS X.3.9 when reverting back to v1.5 → Themes stopped working after downgrading to Firefox 1.5
There is an inconsistency in checkForMismatches where on downgrade we don't remove appDisabled from items that are compatible with the version of the application that has been downgraded to. This will be fixed by bug 271166.
Assignee: nobody → robert.bugzilla
Status: UNCONFIRMED → NEW
Depends on: 271166
Ever confirmed: true
(Reporter)

Comment 10

13 years ago
I found the way to resolve the problem, although it is only applicapable to Apple's OS X. I don't know, nor do I care, how to fix the problem in Windoze systems. Two files have to be trashed from the folder located in: User>Application Support>Firefox>Profiles>bizarrename.default. Inside this folder are two files that need to be trashed. I believe they are extensions.cache and extensions.ini. It's been a while since I did this but I'm 99% sure. Just pull those files out and don't trash them until you are sure this works. Restart Firefox and they are recreated, and all your extensions should work again. You can't just toss one file for some reason. I hope that helps any of my fellow Mac users with this problem.
Actually, deleting the extensions.rdf in your profile is all you have to do (it will be rebuilt automatically though any user disabled extensions will be re-enabled) until this bug is fixed by the patch in bug 271166. After that patch has landed extensions that were marked as incompatible and disabled after upgrading will be re-enabled when downgrading. And yes, it does affect all platforms and OS's.
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Comment 12

13 years ago
I didn't get that far when I was deleting files. I just started jerking them out of the folder from the top down until something worked. Then I went back and put the files that didn't seem to have any effect back, restarted, and looked at the effect. I don't write code, I don't think down those lines. No pun intended. I just wanted my version of Firefox to work the way I had it before installing v1.6. I didn't mean to stir up any fuss, I just wanted to report something so someone with fewer skills than I could fix their problem. I did help one Mac user when I first reported this with a problem they were having, and that was very rewarding. That's all I wanted to do was help a user that was lost. People on these sites can be very abusive sometimes which is unfortunate. These things can be very confusing to a great many people.

OS: All → MacOS X
Hardware: All → Macintosh
There is no fuss but please don't change bug fields. I changed this to All / All because it affects all platforms and OS's. Thanks
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Comment 14

13 years ago
I never changed the bug field. I originally may have set it as OS X, but I haven't touched it since. It may change when I post, but I didn't change anything. All I did was respond when I was accused of not responding. Which I had directly to you. Well no harm, no foul. Maybe someone should look into whether the field changes when someone posts for OS X, the field is changed by the respondent, and the OS X person responds. I could care less if the field is changed to All so it may be a bug in the Bug Reports. 
OS: All → MacOS X
Hardware: All → Macintosh
OS: MacOS X → All
Hardware: Macintosh → All
Fixed on trunk by the checkin for bug 271166
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Summary: Themes stopped working after downgrading to Firefox 1.5 → Extensions and Themes stopped working after downgrading to Firefox 1.5
Created attachment 214585 [details]
testcase (xpi to test with)

When this is fixed on MOZILLA_1_8_BRANCH the fix for this bug can be tested as follows:
1. Install the attached xpi using a MOZILLA_1_8_BRANCH build with the fix and restart to complete install
2. Launch a trunk build, open the Extension Manager, and note that the extension is disabled / marked as incompatible
3. Launch a MOZILLA_1_8_BRANCH build and note that the extension is enabled
Fixed on MOZILLA_1_8_BRANCH by the checkin for bug 271166
Keywords: fixed1.8.1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.