OPTS UTF8 is not issued although UTF8-encoded URLs used

RESOLVED DUPLICATE of bug 26767

Status

()

Core
Networking: FTP
--
major
RESOLVED DUPLICATE of bug 26767
12 years ago
10 years ago

People

(Reporter: SamePaul, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

According to standard FTP client should issue OPTS UTF8 command, but FireFox does not it. Thus it is impossible to download files with mixed international characters in filename

Reproducible: Always

Steps to Reproduce:
1. click on link ftp://samepaul.myftp.org/music/Sovok/АукцЫон/Анабэна/02%20-%20Анабэна.mp3
2. file is supposed to start download


Actual Results:  
In FTP server log you can see that UTF8 encoded URL is used, but since OPTS UTF8 command was not used the server can't find actual file.

Expected Results:  
Either do not use UTF8-encoded file name or issue OPTS UTF8 before download
(Reporter)

Comment 2

12 years ago
Unfortunately URL is not shown correctly in the bug submission :(
Assignee: nobody → dougt
Component: General → Networking: FTP
Product: Firefox → Core
QA Contact: general → benc
Version: 1.5 Branch → 1.8 Branch
> According to standard FTP

that's not part of FTP itself.

it's not part of rfc 2640 either. is this part of any standard?

(might be a duplicate of bug 26767)

Comment 5

10 years ago
mass reassigning to nobody.
Assignee: dougt → nobody

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 26767
You need to log in before you can comment on or make changes to this bug.