Last Comment Bug 297395 - ftp : cannot open a folder with Cyrillic letters in its name on an IIS server
: ftp : cannot open a folder with Cyrillic letters in its name on an IIS server
Status: RESOLVED FIXED
: intl
Product: Core
Classification: Components
Component: Networking: FTP (show other bugs)
: Trunk
: All All
-- major with 5 votes (vote)
: mozilla29
Assigned To: Masatoshi Kimura [:emk]
: benc
: Patrick McManus [:mcmanus]
Mentors:
: 416519 430960 431977 435437 440092 491807 (view as bug list)
Depends on: 26767 942791
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 23:34 PDT by Denri
Modified: 2016-12-20 13:30 PST (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot with this bug. (36.11 KB, image/png)
2005-10-02 01:26 PDT, b.o.a
no flags Details
error screen (open file with russian name "ABe"-"ÀÁ") (10.73 KB, image/png)
2005-10-02 05:36 PDT, b.o.a
no flags Details
don't encode FTP URIs to UTF-8 (3.09 KB, patch)
2008-06-18 13:46 PDT, Jan Darmochwal
no flags Details | Diff | Splinter Review

Description User image Denri 2005-06-10 23:34:27 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050610
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050610

I have a russian-named folder on ftp server on my computer. I see it correctly,
but when i want to open it, Mozilla say: 
IIS 6.0 - 550 /"some anprinable chars": The system cannot find the file specified
Serv-U 6.002 - 550 /"some anprinable chars": No such file or directory
IE 6.0 sp1 open fine.
I use XP sp2 with all latest updates.

Reproducible: Always

Steps to Reproduce:
1.Install ftp-server
2.In home directory create russian-named folder 
3.In Mozilla open URL and see it correct, but when clik to open erorr displays

Actual Results:  
IIS 6.0 - 550 /"some anprinable chars": The system cannot find the file specified
Serv-U 6.002 - 550 /"some anprinable chars": No such file or directory

Expected Results:  
Mozilla must open this folder
Comment 1 User image Gervase Markham [:gerv] 2005-09-27 02:05:03 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 2 User image b.o.a 2005-10-02 01:26:36 PDT
Created attachment 198201 [details]
Screenshot with this bug.

Firefox 1.5 beta1
Comment 3 User image Jungshik Shin 2005-10-02 04:04:15 PDT
Can you make an file named 'АБ' (Cyrillic capital letter A and Cyrillic capital
letter Be)on your server and see what you get when you try to open it? I want to
know what you get in the alert box including 4 digit numbers inside boxes. 
Comment 4 User image b.o.a 2005-10-02 05:36:22 PDT
Created attachment 198218 [details]
error screen (open file with russian name "ABe"-"ÀÁ")

Firefox 1.5 beta1
ftp server - proftpd.

Mozilla 1.6 (Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.6) Gecko/20040115)
open this file.
Comment 5 User image Jungshik Shin 2005-10-02 06:10:41 PDT
Thanks for the screenshot, but I need to know two numbers inside boxes (next to
what appears to be Latin letter ETH : U+00D0). Can you tell me what they are? 
I guess they're '008?' or '009x', but can't tell from the screenshot.

Btw, it's likely that this is a dupe. 
Comment 6 User image b.o.a 2005-10-02 06:29:04 PDT
(In reply to comment #5)
> Thanks for the screenshot, but I need to know two numbers inside boxes (next to

I do not understand about what two numbers there is a speech...

> what appears to be Latin letter ETH : U+00D0). Can you tell me what they are? 
> I guess they're '008?' or '009x', but can't tell from the screenshot.
> 
> Btw, it's likely that this is a dupe. 
> 

Can be it will help? In an Mozilla address line at opening such file it is
displayed "ftp://127.0.0.1/pub/test/%E1%E2"
Comment 7 User image Jungshik Shin 2005-10-02 07:38:54 PDT
The alert message in your screenshot reads '550 /pub/test/D[####]D[####] : No
such file or directory' where I'm using 'D' in place of U+00D0 (Latin Capitale
Letter Eth)and [####] in place of the box with a 4 digit number inside. Just
help me  be sure of  what's going on, let me know what those two numbers are.
Comment 8 User image b.o.a 2005-10-02 08:46:46 PDT
Has understood :)
Unfortunately, I as do not see these figures. Too small font. How to increase a
font in alert message I don't know. Most likely there 0090 and 0091.

Comment 9 User image b.o.a 2005-10-02 08:56:16 PDT
And if file name is 'пя' (small russian 'abe'), alert string -- 'аб'
Comment 10 User image Jungshik Shin 2005-10-02 09:40:25 PDT
Thank you. Testing with Russian small letter 'a' and 'be' was a very good idea.
It confirmed my guess.  There appear to be two issues here. Do you have this
same problem with firefox 1.0.x (rather than firefox 1.5beta or mozilla 1.8b?)? 
Comment 11 User image b.o.a 2005-10-02 11:05:02 PDT
> Do you have this
> same problem with firefox 1.0.x (rather than firefox 1.5beta or mozilla 1.8b?)? 

No.
Mozilla 1.6 & Firefox 1.02 successfully open such files and directories.
Comment 12 User image Jungshik Shin 2005-10-03 02:43:31 PDT
Thanks again. That probably means you can avoid the problem by setting
'network.standard-url.encode-utf8' to 'false'. Can you check that out? 

We should make ftp work regardless of that pref. entry (RFC 2640 :
http://www.faqs.org/rfcs/rfc2640.html )
Comment 13 User image b.o.a 2005-10-03 08:07:32 PDT
(In reply to comment #12)
> Thanks again. That probably means you can avoid the problem by setting
> 'network.standard-url.encode-utf8' to 'false'. Can you check that out? 

Yes, after setting 'network.standard-url.encode-utf8' to 'false', Firefox
succesfully open this file.

Comment 14 User image Jungshik Shin 2005-10-03 08:54:28 PDT
Thanks again for testing. Bug 26767 is about RFC 2640. It's a long standing bug !!  
Bug 284474 is about the pref entry I asked you to check. Perhaps I have to give
in in bug 284474 (at least for now...) because it's very unlikely that we can
fix bug 26767 in time for firefox 1.5
Comment 15 User image Doug Turner (:dougt) 2007-10-08 16:08:18 PDT
mass reassigning to nobody.
Comment 16 User image Alexander L. Slovesnik 2008-02-09 06:42:12 PST
*** Bug 416519 has been marked as a duplicate of this bug. ***
Comment 17 User image Jan Darmochwal 2008-05-04 17:30:19 PDT
*** Bug 431977 has been marked as a duplicate of this bug. ***
Comment 18 User image Jan Darmochwal 2008-05-04 18:53:58 PDT
*** Bug 430960 has been marked as a duplicate of this bug. ***
Comment 19 User image Jan Darmochwal 2008-06-18 13:10:00 PDT
*** Bug 440092 has been marked as a duplicate of this bug. ***
Comment 20 User image Jan Darmochwal 2008-06-18 13:46:41 PDT
Created attachment 325624 [details] [diff] [review]
don't encode FTP URIs to UTF-8

The patch is similar to bug 311387 attachment 198798 [details] [diff] [review]. It might not be needed, because bug 26767 has a patch waiting for review.

Since Firefox 3 has network.standard-url.encode-utf8 == true by default, this bug is probably about to get some more dupes. I propose changing the summary to something easier findable like: "non-ASCII special characters in URIs don't work with FTP (error code 550, umlauts, accents, cyrillic)", any objections?
Comment 21 User image Jan Darmochwal 2008-06-18 13:49:26 PDT
*** Bug 435437 has been marked as a duplicate of this bug. ***
Comment 22 User image Alexander L. Slovesnik 2008-07-04 14:58:37 PDT
(In reply to comment #20)
> Created an attachment (id=325624) [details]
> don't encode FTP URIs to UTF-8
Jan, are you going to ask review for your patch?
Comment 23 User image Christian :Biesinger (don't email me, ping me on IRC) 2008-07-25 13:19:50 PDT
I prefer bug 427089's solution which doesn't require hardcoding protocol names in nsStandardURL.
Comment 24 User image Maniiak 2009-02-04 00:44:53 PST
firefox v 3.0.6 ftp url not supporting Cyrillic. Testing on 14 Russian ftp servers. fix it pls (:
Comment 25 User image Yuri G 2010-05-20 23:19:33 PDT
firefox 3.6.3: still has the same issue with Cyrillic names in ftp urls - Opera, Ie8, Chrome all work fine with those urls, but firefox seems to be missing that functionality since 2005.
Comment 26 User image Yuri G 2010-05-21 00:13:57 PDT
Found the solution:
Change Edit - Preferences - Content - Fonts & Colors - Advanced - Character encoding - change it to UTF-8

I wander why FF doesn't have it set to UTF-8 by default.
Comment 27 User image Igor 2013-11-17 11:42:25 PST
Just ran into same behavior on FF 25.0.1 . 

- Yuri's suggestion works. If "fallback encoding" is set to UTF-8, folders are displayed as they should. 
  I agree UTF-8 should be default there. Also, UTF-8 is, most probably, only default for ftp.

- If "fallback encoding" is different from "UTF-8", switching page's encoding to UTF-8 via 

"View->Character Encoding" still results in described bug. So, bug is still there.
Comment 28 User image Masatoshi Kimura [:emk] 2013-12-06 00:02:04 PST
Bug 942791 should have fixed this.
Comment 29 User image Masatoshi Kimura [:emk] 2014-03-29 02:30:20 PDT
Actually comment #25 and following is the different problem from the original issue. Bug 427089 "fixed" the original issue and introduced the new issue. I backed out bug 427089 and landed bug 942791 to fix both problems.
Comment 30 User image buovjaga 2016-12-20 13:28:28 PST
*** Bug 491807 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.