empty trash should issue a compact folders as well (netscape4)

RESOLVED DUPLICATE of bug 61960

Status

RESOLVED DUPLICATE of bug 61960
13 years ago
13 years ago

People

(Reporter: andrixnet, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

A very healthy behaviour in the Netscape4 days (mail component) : 

when one says "empty trash", after trash folder is emptied, the program also performed "compact folders" on all folders. No confirmation required. 

coupled with "empty trash on exit" option, this is by far the healthiest way to maintain your mailfoders in good shape. 

Reproducible: Always

Steps to Reproduce:
1. configure "empty trash on exit" per account
2. configure "compact folders when saving more then xxKB"
Actual Results:  
a. not sure when step 1. happenes, but trash gets cleared. 
b. apparently 2. is associated with TB startup? because having both 1. and 2. set, I exit TB and nothing happens, then I start TB and i get the annoying confirmation request described in bug #115499 


Expected Results:  
I. empty trash should empty trash folder _and_ compact all folders by default. (either by menu->file, or by "empty trash on exit" per account pref)
II. compact folder should exist in context menu for each folder as is.
III. compact folders (all) should exist in menu->file as is. 
IV. bug #115499
V. "compact folders when saving more then xxKB" should operate globally on all accounts, all folders, on exit, except for the accounts with "empty trash on exit" (it would be a waste of time to apply the same operation twice)

Comment 1

13 years ago
actually, Netscape 4 only did it on *local* mail.

*** This bug has been marked as a duplicate of 61960 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
well, in NS4 you could only have 1 (one) POP account per profile. More only for IMAP. 

TB can configure N POP accounts. aren't they local as well ? (regarding storage, right?)
You need to log in before you can comment on or make changes to this bug.