On Linux, backspace should be page up, not history back (platform convention)

RESOLVED FIXED in Firefox 2 alpha2

Status

()

Firefox
Keyboard Navigation
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

({fixed1.8.1})

unspecified
Firefox 2 alpha2
All
Linux
fixed1.8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

See bug 262905 for details. This bug should handle the default behavior for GNOME.
No longer depends on: 262905
Depends on: 262905
Flags: blocking-firefox2?
If this behaviour matches platform standards, then I'm fine with making this change on FFx-Linux. Unsetting the uiwanted flag, though, since really the UI is clear: a patch that IFDEFs this behaviour change for Gnome ...
Keywords: uiwanted
Assignee: beltzner → bugs.mano
Target Milestone: --- → Firefox 2 alpha2
Status: NEW → ASSIGNED
I'd be ok with taking this change in the next little while and getting enough early feedback from Linux users.  If it misses a2, it falls off radar again.
Flags: blocking-firefox2? → blocking-firefox2+
Created attachment 215219 [details] [diff] [review]
patch
Attachment #215219 - Flags: review?(mconnor)
Attachment #215219 - Flags: approval-branch-1.8.1?(mconnor)

Comment 4

11 years ago
I'm not convinced that a dozen people are not going to file a bug to reverse this immediately and that we'll be swimming in trolls like we always do when there's a change here. I suggest leave it alone. See the dozens of dupes on this issue. Every time someone felt like it they've filed a bug to change this. That's why I had created a bug "World War III: What should backspace do or not". The purpose of that bug was to finally lay this to rest and have a stable binding for backspace which does not change. Everyone had their chance to air their opinion, a decision was made, and we stuck with it. Why reopen a can of worms? Oy.

Comment 5

11 years ago
I really wished this wouldnt happen, the behaviour in gnome is to make backspace go up but that only makes sense when you are browsing a filesystem and almost zero context in browsing the web. The back behaviour of gnome (alt+left) already works with firefox so no inconsistency there.
Comment on attachment 215219 [details] [diff] [review]
patch

I think this is worth trying in a2 and b1, and see how it pans out.
Attachment #215219 - Flags: review?(mconnor)
Attachment #215219 - Flags: review+
Attachment #215219 - Flags: approval-branch-1.8.1?(mconnor)
Attachment #215219 - Flags: approval-branch-1.8.1+
1.8 branch:
Checking in browser/app/profile/firefox.js;
/cvsroot/mozilla/browser/app/profile/firefox.js,v  <--  firefox.js
new revision: 1.71.2.27; previous revision: 1.71.2.26
done

trunk:
Checking in browser/app/profile/firefox.js;
/cvsroot/mozilla/browser/app/profile/firefox.js,v  <--  firefox.js
new revision: 1.104; previous revision: 1.103
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 8

11 years ago
I personally think this(the patch) should be reverted. Having the ability to go back with just one keypress is very useful. Everyone knows that going back is one of the most used functions of a browser.

Also, although Epiphany doesn't use Backspace to go back, Opera for Linux does.

Another point: With caret navigation turned on, and backspace set to "Page Up", the backspace key doesn't do anything.

Another point: Epiphany doesn't use Backspace for Page Up, so where exactly is this 'tradition' coming from? (OK, never mind I've just read bug 262905 comment 0, which doesn't include any native GNOME browsers mind...).

I think the main point (for me) is that the Page Up key exists for paging up, but no other key exists for navigating back in a single keypress. IMO Firefox should go with usability over tradition (and it's not even a strong tradition really, more of a trend).

P.S. Is the caret browsing issue a bug or not?

Updated

11 years ago
Blocks: 336462
This bit me as soon as I upgraded to beta 2. Should I file a new bug/rfe asking for backspace to be switch back, or is this enough?

Comment 10

11 years ago
*** Bug 351218 has been marked as a duplicate of this bug. ***

Comment 11

11 years ago
I would like to know just where the hell this person who made this bug report came up with this ? Just where in _ANY_ linux platform is the backspace mapped to page up?

That is insane. ALL keyboards have a page up/down and is mapped according to that. I have never once used a linux distro that used the backspace for page up and I am asking the developers to revert this back to its original design to go back in history.

Comment 12

11 years ago
Also I see that a person here has said that GNOME uses the backspace for a page up mapping.

Well I got 2 things about that.

First off the GNOME developers don't use common sense anymore and 2nd KDE which is the most popular desktop manager maps the backspace to web browser history in ALL of its web app's.

What will we map the bloody up key to next? A shift+backspace ?

Come on FF developer's !! Please use common sense here and don't bend at the very first complaint which is obviously wrong.

Updated

11 years ago
Flags: blocking-firefox2+ → blocking-firefox2?

Comment 13

11 years ago
Hi,
seems like I am the first real user to complain because of this.
It makes me go nuts. Really.
Please revert this. Just because Firefox uses GTK doesn't mean
that it must adhere to Gnome standards.

Nicholas Fechner

PS: Should I get all the other FF linux users to complain too?
Would that help fix the problem faster?

Comment 14

11 years ago
Please revert this change.  It is _very_ common to go to the previous page and Backspace is an established way to do that.  One key (Backspace) versus two (Alt+Left) is an important gain.  On the other hand, one key (Backspace) versus a different, close one key (Page Up) is _not_ an important gain.

You have already received many complaints because of this change, both here and in Bug 321218 and its numerous duplicates.  Is that not a sign of what users want?

Comment 15

11 years ago
In Firefox 2, you can change the backspace action by setting the browser.backspace_action pref to the value of your choice in about:config :
  0 goes Back/Forward
  1 act like PgUp/PgDown
  2 and other values, nothing
Flags: blocking-firefox2?

Comment 16

11 years ago
That's good and I have already changed it locally, but I believe you have a wrong default.

Comment 17

11 years ago
(In reply to comment #15)
> In Firefox 2, you can change the backspace action by setting the
> browser.backspace_action pref to the value of your choice in about:config :
>   0 goes Back/Forward
>   1 act like PgUp/PgDown
>   2 and other values, nothing
> 

This bug stems from a mental block of common reasoning here. All of which is normal for gnome people. You get a thought and you stick with it even when common sense says it's a mistake and when numerous people try to correct you.

You don't code for mozilla, you code for users or have you forgotten that?

How disappointing.

Comment 18

11 years ago
And I'll add one more thing about this and after that I am done trying to fix the broken common sense here.


What is the "PAGE UP" key for on my keyboard? I'll be sure to email all the keyboard manufactures that they have gotten the layout wrong according to the Firefox developers who say that the backspace is suppose to be PAGE UP and point them to this bug to read.

Comment 19

11 years ago
Backspace shares an image and most of the word with the same browser functionality - go back. The arrow pointing left on the browser toolbar: same on the key in most cases.

Usability would tend to support a bigger key gets a popular action, and going back a page is one of the commonest navigation requirements.

Page up is in many layouts very close to backspace - on my keyboard they touch on the diagonal - so why have two keys with the same function so close together??

I'd like to vote for the pre-firefox2 behavior, default action 0 (history back) for backspace. But I'd also like to thank the developers for making this behaviour a customisable option, no matter whether the default is ever changed or not.

Actually, for people upgrading from <2.0, why not keep previous behaviour, and only default to pageup for new installs?

Comment 20

11 years ago
Having a different behavior on different platforms and different from most other browsers just creates confusion.

If I want to scroll up on a webpage I just press page up, not backspace. Why would backspace scroll up when there is already a button for that?

Besides I use gnome and I don´t know any application that scrolls up when pressing backspace. Nautilus for example, with the browser interface, takes you back one level when pressing backspace.

So please revert this change! This is just stupid.

Comment 21

11 years ago
If you are upset by this change and want Firefox to revert to the previous behavior, please vote for bug #358764.

Comment 22

10 years ago
What if Volvo changed their car design so that you would switch gears with the steering wheel? Sorry, but that's how #&)#"/¤&/#¤ this is. Shortcut keys like this one is a de facto standard.

Arguments about old time unix users is void because, as an example consider ubuntu; A) on ubuntu there is a lot more "new linux users" these days compared to the number of "old time unix users", and consider also B) in some ancient time some people used CTRL-Y and CTRL-V for page down/up. But guess what? More or less every single keyboard ships with a dedicated button that is labeled "PAGE UP", maybe it's time to evolve and start to use it? For the ultra hardcore people, I suggest "apt-get install old_unix_style_keybinding".

Arguments about "data loss" is void because: A) surf to google.com, B) type in some query, C) press the normal GUI back button in the toolbar, D) data lost. E) big deal get over it.

Arguments about "platform consistency" is void because: A) start the GNOME filemanager, B) scroll down to the last item and select it, C) press BACKSPACE and notice that it does not mean page up.

On a personal level; for now I'll go with the about:config hack, but give me more of these kinds of bugs and then it's bye bye new distro or OS for me. I mean a missing sound driver is one thing because I know everyone *wants* to fix it (albeit it might take a long time). But with bugs like this one are big time showstoppers.

I hope that people can agree on a sensible fix to this bug so that firefox on linux can continue to grow.

Comment 23

8 years ago
I would argue that  Comment #5 uses incorrect analogy.

If the default behavior in gnome driving this change is the file manager (nautilus or its equivalent), then backspace should not cause page up, but *directory* up. This is much more analogous to the default behavior, no?
You need to log in before you can comment on or make changes to this bug.