Last Comment Bug 358764 - On Linux, backspace should do nothing
: On Linux, backspace should do nothing
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: unspecified
: All Linux
: -- trivial with 17 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 09:09 PST by Ryan Hayle
Modified: 2010-10-13 03:09 PDT (History)
22 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
make backspace do nothing (1.29 KB, patch)
2006-11-29 13:57 PST, Robert O'Callahan (:roc) (email my personal email if necessary)
caillon: review+
mconnor: ui‑review+
Details | Diff | Splinter Review
ditto for SeaMonkey (873 bytes, patch)
2007-01-05 19:15 PST, Mats Palmgren (:mats)
roc: review+
roc: superreview+
Details | Diff | Splinter Review
Sync suiterunner to xpfe (606 bytes, patch)
2007-05-11 11:17 PDT, Mark Banner (:standard8)
neil: review+
neil: superreview+
Details | Diff | Splinter Review

Description Ryan Hayle 2006-10-30 09:09:50 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

This is a request to reverse Bug #325541

On Linux, as with all other platforms, the backspace key should map to "Go back one page", NOT Page Up, as there is already a "Page Up" key not more than 4 cm away from it.  

It makes no sense to change a key-mapping so that there are two keys on the keyboard with the same function.  It's not intuitive and makes no sense.

Now that the browser.backspace_action pref exists, any Linux vendors that wish to customise their Firefox packages to change the default behavior are free to do so.

Linux users please vote for this bug if you agree.

Reproducible: Always

Steps to Reproduce:
1. Press backspace key
Actual Results:  
Browser pages up one screen

Expected Results:  
Browser navigates to previous page in browser history
Comment 1 Scott Grayban 2006-10-30 11:14:49 PST
I support this reversal.
Comment 2 peter.waller 2006-11-01 02:45:15 PST
I also support this reversal. Why on earth has this been changed?
Comment 3 Karl Palsson 2006-11-02 17:24:00 PST
I am HUGELY in favour of this.  The two buttons are right beside each other!  I already had a pageup key.  Why on earth would I want another!

Comment 4 Scott Grayban 2006-11-10 02:08:32 PST
If anyone hasn't noticed...... This has bug isn't assigned by anyone anymore.
It was removed some time back.

The developers here simply don't give a flippin f**k what anyone thinks here.
They are typical GNOME people and they do what they want when they want. They
don't ask anyone for their opinions. They simply just do it and god forbid you
disagree with them, they only ignore you then.

Linus Torvalds once called the GNOME people nazi's on the GNOME mailing list
after a huge fight over developing the settings/preferences for users. I refer
you to read
http://mail.gnome.org/archives/usability/2005-December/msg00022.html

The same mentality is here as well and common sense is flushed each morning
when the FF developers wake-up and take the first **** of the day.
Comment 5 Paul van Erk 2006-11-10 04:53:41 PST
This 'feature' _really_ shouldn't be here. I keep on hitting backspace and nothing or the wrong thing happens. BACKSPACE = PAGE BACK . Please, revert this regression.
Comment 6 Aleksey Lazar 2006-11-11 22:03:59 PST
This is very annoying indeed. I am using Gentoo/KDE (gave up on gnome some time ago) and ran into this stupidity after upgrading to FF2.0. What the heck? Backspace to go BACK is intuitive, backspace to go PAGE UP is.. what moron thought of this? There is a PAGE UP button on the keyboard for this SPECIFICALLY.
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-28 20:17:13 PST
I had a discussion about this with caillon and some GNOME people and we decided that the best option is to make backspace do *nothing*. Page-up is a bit silly and "backwards in history" invites dataloss.
Comment 8 Scott Grayban 2006-11-28 21:10:43 PST
(In reply to comment #7)
> I had a discussion about this with caillon and some GNOME people and we decided
> that the best option is to make backspace do *nothing*. Page-up is a bit silly
> and "backwards in history" invites dataloss.
> 

What data loss ? I never had any data loss... here again we have a failure of communication.... How is it that making it do "nothing" and "back" have to do with any of that? You gonna remove the back button in the menu now? Good grief... You guys need to go back to coding school and retrieve the common sense.

Comment 9 Simon Strandman 2006-11-29 01:06:40 PST
While I agree that having the backspace button do nothing makes more sense than having it do page up I still don�t think it�s good enough.

I've been using backspace to go back on webpages for years in various browsers and I can�t remember ever loosing any data because of it. If data loss was common, me and other wouldn't use it of course. And even if you go back by misstake when editing something it should still be there when you click forward again.

I don't see the problem here. Why not just leave the keybinding as it always have been? You�re not enhancing the browser in any way by remvoing functionality that people use. Especially not when the new behaviour differs from other browsers.
Comment 10 Paul van Erk 2006-11-29 01:19:04 PST
Seriously, I have been using backspace since, let me think... I can't remember! And I have good memory! For years and years backspace has been _the_ way of going back in history. Please, please, please, changing the behavior of backspace has, in my opinion, crippled the browser. Besides, in Windows, 'data loss' is okay? Because there, backspace still works. Data loss is a non-argument. Backspace = back in history, period. 
Comment 11 Ryan Hayle 2006-11-29 07:32:59 PST
Hmm, hopefully I'm not being too much of a hypocrite for saying this, but please only comment on this bug if you have something meaningful to add.  The name calling and "me too" posts aren't entirely helpful.  If you agree, then the best way to show it is by voting for the bug.

Now, in response to Robert O'Callahan, I too must wonder what kind of data loss is possible when using the backspace key to go back, and why this is acceptable for Windows or Mac users.  I'm not so afraid of change to suggest that keyboard shortcuts should *never* change--if there is a reasonable argument for changing them--however I do think that consistency across platforms is important.

I realise this shouldn't be a political discussion, but I must say that I don't think Firefox should be directed by GNOME at all, since it is a GTK application, not GNOME, and many people run it under KDE, XFCE, etc.  My understanding is that GNOME adopted the Backspace-as-PageUp stance from the EMACS people who were used to this, and this is great, and it makes sense for them.  The problem is that most Firefox users, even on Linux, aren't EMACS users any more.  Also, is there not a GTK setting to switch all the key-bindings over to EMACS-emulation mode?  And thirdly, there is a Firefox config setting to change the behaviour of the backspace key.  So with all these things, the minority of users who want to change the backspace functionality can easily do so, and like I said, a particular Linux distribution is free to ship that as the default as well.

Also, for anyone reading this who hasn't found the interim solution to this problem, just set browser.backspace_action=1 in your about:config or user.js, and backspace will navigate back as always.
Comment 12 Scott Grayban 2006-11-29 07:46:08 PST
(In reply to comment #11)
> Hmm, hopefully I'm not being too much of a hypocrite for saying this, but
> please only comment on this bug if you have something meaningful to add.  The
> name calling and "me too" posts aren't entirely helpful.  If you agree, then
> the best way to show it is by voting for the bug.
> 
> Now, in response to Robert O'Callahan, I too must wonder what kind of data loss
> is possible when using the backspace key to go back, and why this is acceptable
> for Windows or Mac users.  I'm not so afraid of change to suggest that keyboard
> shortcuts should *never* change--if there is a reasonable argument for changing
> them--however I do think that consistency across platforms is important.
> 
> I realise this shouldn't be a political discussion, but I must say that I don't
> think Firefox should be directed by GNOME at all, since it is a GTK
> application, not GNOME, and many people run it under KDE, XFCE, etc.  My
> understanding is that GNOME adopted the Backspace-as-PageUp stance from the
> EMACS people who were used to this, and this is great, and it makes sense for
> them.  The problem is that most Firefox users, even on Linux, aren't EMACS
> users any more.  Also, is there not a GTK setting to switch all the
> key-bindings over to EMACS-emulation mode?  And thirdly, there is a Firefox
> config setting to change the behaviour of the backspace key.  So with all these
> things, the minority of users who want to change the backspace functionality
> can easily do so, and like I said, a particular Linux distribution is free to
> ship that as the default as well.
> 
> Also, for anyone reading this who hasn't found the interim solution to this
> problem, just set browser.backspace_action=1 in your about:config or user.js,
> and backspace will navigate back as always.
> 

This isn't about manually changing it back. This about the developers doing it because they "felt it was the way to do it" after years of firefox and other browsers doing the same thing with the backspace. The correct way to fix this is to revert the change back to its original function and *if* anyone wants to change it they can.

I still do not see why this is a difficult issue to understand. I honestly think it's a pride issue now. The developers see the mistake and instead of saying "ok you are right and we made a mistake" it's now a defiance with a lame response that makes zero sense.
Comment 13 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-29 12:11:23 PST
I have not been involved in this issue at all up till now, so you can please throw away your theories about "developer pride".

Dataloss can occur when you navigate away from certain pages; for example, the contents of form fields or script state may be lost. It's relatively easy to press backspace accidentally, e.g. when you think an edit field is focused, but it isn't (possibly because script changed the focus). So please throw away the straw-man argument about removing menu items or buttons.

Mozilla on Linux is a lot more of a GNOME app than anything else. Many of the Mozilla-on-Linux developers are also involved with GNOME; none are involved with KDE. If KDE developers want to step up and produce more KDE-friendly Firefox variants, they're welcome to do so.

This is one of those decisions where no matter what decision is made there will be many angry people jumping up and down. All we can do is make a principled decision, and that decision has been made. If you can come up with a new argument that hasn't been raised yet in this bug or any of the related bugs, please mention it, otherwise, leave it alone.
Comment 14 Scott Grayban 2006-11-29 12:57:29 PST
(In reply to comment #13)
> I have not been involved in this issue at all up till now, so you can please
> throw away your theories about "developer pride".
> 
> Dataloss can occur when you navigate away from certain pages; for example, the
> contents of form fields or script state may be lost. It's relatively easy to
> press backspace accidentally, e.g. when you think an edit field is focused, but
> it isn't (possibly because script changed the focus). So please throw away the
> straw-man argument about removing menu items or buttons.
> 
> Mozilla on Linux is a lot more of a GNOME app than anything else. Many of the
> Mozilla-on-Linux developers are also involved with GNOME; none are involved
> with KDE. If KDE developers want to step up and produce more KDE-friendly
> Firefox variants, they're welcome to do so.
> 
> This is one of those decisions where no matter what decision is made there will
> be many angry people jumping up and down. All we can do is make a principled
> decision, and that decision has been made. If you can come up with a new
> argument that hasn't been raised yet in this bug or any of the related bugs,
> please mention it, otherwise, leave it alone.
> 

I have made my argument -- you are ignoring it. Revert the change back to its original function of "back in history". It has been there as long as I can remember.

Now that so called data loss isn't anything what you are trying to claim here. I have done that before and its called "opps damn" and I think I did that twice in the 2 years I have used Firefox. And second I have never seen that as a argument here at all, not even as a bug report. So try again.

Yes I am arrogant but I am right about it too.
Comment 15 Scott Grayban 2006-11-29 13:06:28 PST
And personally I don't care if it's a GNOME app or not. That is irrelevant here.

You code this program for users and no place do I see on the FF sites -- "ONLY FOR GNOME". If you don't want anyone to use it that doesn't use GNOME then go put this on the GNOME website as a addon. Now keep your wiseass comments like that to your self.

I wonder why you even bother with coding here with that attitude. What do you tell windows users ?
Comment 16 Ryan Hayle 2006-11-29 13:18:17 PST
*sigh* I really hate the attitude of this bug report-turned-discussion-thread.  For people (including myself) who don't contribute a damn thing to the project, you have no right to be disrespectful, let's all act like adults.

Robert, what about the issue of platform consistency?  And the fact that this keyboard shortcut has been in use since early Netscape days, along with IE, Opera, and most other browsers?  The fact is, GNOME already has its own browser--it's called Epiphany.  I've never heard of anybody actually using it, but they have it, and that is where they can set GNOME-specific key bindings.  Whether any of the Firefox developers are also GNOME developers is irrelevant, because Firefox is not branded as a GNOME browser.  If the Mozilla Foundation wishes to change this stance, then fine, I'm sure someone will fork the codebase, but until then, everything should remain platform-neutral.  I'm a GNOME user myself, and I imagine many of the people who voted for this bug are as well.

You also seem to be missing part of my point.  This isn't at all a GNOME-vs-KDE-vs-Windows issue, it's a basic usability issue, and it's the GNOME users themselves who are upset by it.  The majority of GNOME users (let alone users of other desktop environments) don't want this.  That's the bottom line.

I've yet to hear of anyone who would be upset by reverting to the standard, default behaviour.  You say that "no matter what decision is made there will be many angry people jumping up and down," but I have not found that to be the case.  I have not heard of ANYONE who thinks this makes sense, actually.

If this was a principled decision, then what were those principals, because I have yet to hear them.  Those principals must clearly explain why this protection is necessary on Linux, but not on Windows, where there are likely to be many much less technically inclined users who might accidentally hit the backspace key and cause data loss.

And please respond to the arguments that have been presented before dismissing them.  I don't feel any additional arguments in favour of reverting to the standard behaviour need be made.  It seems like a no-brainer.
Comment 17 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-29 13:53:51 PST
The people who complain about backspace == back in history can be found here:
https://bugzilla.mozilla.org/show_bug.cgi?id=262905
I did ask people to look in related bugs before commenting.

Making Firefox consistent across platforms has always been secondary to making it consistent with per-platform guidelines. We don't always do a good job of this, but that's how it is, and rightly so. Consistency across browsers is also secondary.

> This isn't at all a GNOME-vs-KDE-vs-Windows issue, it's
> a basic usability issue

Indeed, and the issue is that "backspace == back in history" can lead to irreversible data loss and is relatively easy to trigger by mistake. These are the principles behind the decision.

> The majority of GNOME users (let alone users of other
> desktop environments) don't want this.  That's the
> bottom line.

You have no way of knowing this, since you have not surveyed them in a statistically valid way.
Comment 18 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-29 13:57:36 PST
Created attachment 246984 [details] [diff] [review]
make backspace do nothing

Chris, Mike, can you sign off on this?
Comment 19 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-29 14:04:31 PST
Oh, you deserve a response to this:

> Those principals must clearly explain why this
> protection is necessary on Linux, but not on Windows,
> where there are likely to be many much less technically
> inclined users who might accidentally hit the backspace
> key and cause data loss.

Two reasons really. One, since IE and the Explorer Shell use backspace == back in history (I believe), you could argue that Microsoft has established that as the platform default, so platform consistence favours "back in history" on Windows but not on Linux.

Two, maybe we should in fact change the default on Windows also, but that is a separate issue and one that I (and other Linux/GNOME people) am not interested in fighting over. Feel free to file another bug on that.
Comment 20 Scott Grayban 2006-11-29 14:10:38 PST
I use both KDE and GNOME -- more GNOME then anything else. My backspace has never gone "page up" for anything as far as I can remember in GNOME. Backspace has always been "back in history" for as long as a I can remember.

So I am confused as to were this "page up" function came from. Its not in any GNOME app I use here. What common GNOME app uses the backspace for page up?
Comment 21 Mike Connor [:mconnor] 2006-11-29 14:27:39 PST
Comment on attachment 246984 [details] [diff] [review]
make backspace do nothing

I can live with this, and its probably the easiest answer on Linux.
Comment 22 Mike Beltzner [:beltzner, not reading bugmail] 2006-11-29 14:32:39 PST
Just to go on record (since Roc asked so nicely!) I actually think that this is the wrong decision. Bug 262905 lists a great set of user interfaces we probably really, really don't want to copy, and I don't really buy the dataloss case that much, as it's becoming increasingly rare (especially with fastback) that it actually hoarks things.

Historically, when there's been no clear UI guideline for a platform, we've gone with "Firefox Standard" UI across all platforms based on our beliefs about ease of use, etc.

I'm happy to roll with mconnor's call here, though, as he's been dealing with Linux issues for a lot longer than I have.
Comment 23 Karl Palsson 2006-11-29 16:21:56 PST
So, ahh, on the pending review, this doesn't eliminate being able to use the about:config setting to make it use the old behaviour does it?

after this proposed patch it would be..

default: backspace does nothing
with about:config setting modified: backspace has old/correct/expected/inconsistent/datalossy/normal behaviour

?

I sure hope so....

[Ranting ommitted, devs never listen anyway]
Comment 24 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-11-29 17:40:33 PST
> this doesn't eliminate being able to use the about:config
> setting to make it use the old behaviour does it?

Correct, you can still override via about:config.
Comment 25 Christopher Aillon (sabbatical, not receiving bugmail) 2006-11-30 12:47:11 PST
Comment on attachment 246984 [details] [diff] [review]
make backspace do nothing

This is correct after talks with Calum.  It is also what the official GNOME browser, Epiphany, does.

r=caillon
Comment 26 Ryan Hayle 2006-11-30 14:23:18 PST
Let's copy what the official GNOME browser, Epiphany, does for everything.  I'll create a new bug report to scrap all of XUL from Firefox on Linux and use GTK and GNOME libraries directly.  That way we'll also ensure users won't be able to install any existing extensions that might cause data loss, and help the GNOME developers not have to continue maintaining their own browser.

Also, I really think you should change one of the standard keybindings for Windows--I want ALT-RIGHT go to the bottom of the page (much like the End key does now).  Otherwise I might risk losing data when navigating away from a form I already filled out.  Then let's see how many users you get filing bug reports...



Sarcasm aside, please do not mark this bug as fixed when the attached patch is applied, as it does not meet the expected behaviour described in the original bug report.  Whether you agree now or not, this bug should remain so that more people can vote voice their opinion on this issue if they are bothered by it.
Comment 27 Paul Pogonyshev 2006-12-01 02:12:10 PST
What the fuss about data loss?  Let's remove shortcuts for going to home page, closing tabs (only with mouse! and with a question!) and reload page then.  It will also help to remove "delete file" command from all file browser out there, otherwise users _may_ accidentally remove files they don't want to remove.
Comment 28 Scott Grayban 2006-12-01 08:52:25 PST
The patch is NOT what this bug is about. Why the hell you even posting it? This bug is to REVERT back to the ORIGINAL function of going back in history. Good grief...

One question here.... If the backspace was never suppose to be "back in history" according to GNOME gods why was it there in the first place? After all these years you are now changing it. Real smart.....
Comment 29 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-12-07 11:48:10 PST
Checked in the patch. Changed bug summary to reflect new situation, and leaving it open.
Comment 30 Scott Grayban 2006-12-07 11:59:29 PST
(In reply to comment #29)
> Checked in the patch. Changed bug summary to reflect new situation, and leaving
> it open.
> 

I wonder why the consensus was to revert this back to the original function is yet again overridden here. Why vote when you and everyone else do what you want anyways. It shows a total lack of respect that is aligned with GNOME developers.
Comment 31 Steffen Wilberg 2006-12-07 12:39:26 PST
Changing summary to what actually happened in this bug, and marking fixed.
No offense, but I need this for bug tracking purposes.

Please file a new bug (after searching for duplicates) if you want to revert this decision.
Comment 32 Ryan Hayle 2006-12-07 12:46:08 PST
Ugh, as the author of the original bug, I must say that this is entirely UNACCEPTABLE.  You have hijacked my bug to make it serve your own ends which I don't agree with.  YOU need to make a new bug about making backspace do nothing.  This bug NEVER was about that.
Comment 33 Scott Grayban 2006-12-07 13:09:06 PST
(In reply to comment #32)
> Ugh, as the author of the original bug, I must say that this is entirely
> UNACCEPTABLE.  You have hijacked my bug to make it serve your own ends which I
> don't agree with.  YOU need to make a new bug about making backspace do
> nothing.  This bug NEVER was about that.
> 

Robert doesn't care what you or anyone else here thinks. The consensus here was to revert this back to its old function and go back in history.

Robert shows the continual lack of respect for what the majority have already voted on. He has instead implied that the consensus is entirely wrong and that he will show his dictatorship and commit his own patch backed by the spineless other FF developers.

So if anyone here still thinks that the FF developers aren't GNOME nazi's in disguise then you are blind.

It's not a _public_ program, it's theirs and screw you if you don't like it.
Comment 34 Simon Strandman 2006-12-08 01:25:06 PST
What is it with you mozilla people? Why don´t you care what your users think? Even microsoft listenes more to their users now. When people didn´t like features in vista microsoft changed them. Mozilla on the other hand just stated "This is how it's supposed to work, get used to it.". Another good example is the new crippled quicksearch in 2.0. Everybody hated it, initially thought it was a bug and all discussions where about hacks to get the old behaviour back. But mozilla stubbornly refused to change it.
Comment 35 Peter van der Woude [:Peter6] 2006-12-08 07:29:27 PST
please do not change the resolved/fixed status.
thank you.
Comment 36 Simon Strandman 2006-12-08 07:34:22 PST
(In reply to comment #35)
> please do not change the resolved/fixed status.
> thank you.
> 

Peter:
Shouldn´t a bug only be marked resolved/fixed when it´s resolved/fixed? This certanly isn´t.
Comment 37 Ryan Hayle 2006-12-08 07:40:11 PST
Peter van der Woude:
Please do not change the nature of a bug and then mark it as fixed when it's not fixed.  If you wish to fix ANOTHER bug, please do so.  This is just common decency.  You don't have to agree, but don't go messing with people you don't agree with.  THIS bug is NOT fixed.  Bug #336462 has nothing to do with this bug.

Thank you.
Comment 38 Paul Pogonyshev 2006-12-08 07:42:34 PST
Right.  If you wish, open another bug and close this as WONTFIX, as apparently you want.  But please don't pretend you have fixed it.
Comment 39 Mike Connor [:mconnor] 2006-12-08 08:35:47 PST
a couple dozne people does not make an explicit majority.  Ranting about Microsoft isn't especially useful in presenting a rational case, for that matter.  Bugzilla isn't and shouldn't be a democracy, since there is not a representative population here.

Let's look at this again:

We shipped Backspace == Back for 1.0/1.5 (and on Windows/Mac for 2.0) and while there were some instances of dataloss (just like tab closing, and any other option that navigates away from the page).

Some users don't like this, because they hit focus bugs and sometimes lose their form data.  I haven't hit this ever, that I remember.

There isn't an explicit platform convention to speak of here, but there is a browser convention driven by IE's previously massive marketshare, and our own implementation predating Firefox.

Accel+[/] do work just fine, albeit requiring a more complex keyboard action.

Based on this, I'm not opposed to either case, but I'm not asserting one is better than the other for GNOME, because I'm not a GNOME HIG author, and not in sync with the overall direction for the platform and where they want to live on the convenience vs. dataloss risk curve.  I think the dataloss risk is overblown here, given my own experience, but I'd like to see Calum's view on the issue explained here.
Comment 40 Rob Campbell [:rc] (:robcee) 2006-12-08 09:09:43 PST
I believe the history of backspace navigating back in browser history predates IE and goes all the way to NCSA Mosaic. If someone has a copy of Mosaic 1.0 kicking around and a Unix that can run it, I'd love to see confirmation (or if my memory's faulty, denial) of this.
Comment 41 Rob Campbell [:rc] (:robcee) 2006-12-08 09:13:23 PST
or maybe not, according to:

http://www.softlab.ntua.gr/facilities/documentation/www/Mosaic-Docs-2.4/d2-navigating.html
Comment 42 Scott Grayban 2006-12-08 12:07:06 PST
This is absolutely disgusting. We are fighting to get this bug reverted from #325541 and instead we get some developers that decide to take a different step to it and go from reverting it to a patch Robert O'Callahan commits that does NOTHING to revert the actual bug report here. _Idiot_ Then we got another developer, Steffen Wilberg, that says its fixed when it isn't and then even changes the original bug summary to what Robert O'Callahan did.

Now I'm no rocket scientist but do I see a pattern here that when making a bug report or a revert of a change will be overturned if any developer doesn't agree with it? And then they simply ignore us when we ask for a explanation.

Robert O'Callahan should be removed from access here and his patch removed from the SVN repo. Steffen Wilberg should have his access removed as well for his role.

Robert O'Callahan what gives you the right to change the aspect of this bug and turn it into your own version of what it should be?

Steffen Wilberg you must be stupid. I simply can't see your reason on the actions of closing this bug when it has never been fixed.
Comment 43 Simon Strandman 2006-12-10 09:35:02 PST
(In reply to comment #39)
> a couple dozne people does not make an explicit majority.  Ranting about
> Microsoft isn't especially useful in presenting a rational case, for that
> matter.  Bugzilla isn't and shouldn't be a democracy, since there is not a
> representative population here.

If a lot of people speaks up against a change and and the only ones for it are a few developers speaking about a theoretical data loss that they haven't actually experienced, I'd say that´s a majority.

But if the comments on bugzilla is not enough for you:
http://www.pthree.org/2006/11/01/firefox-2-backspace/
http://peter.hybridweb.co.uk/blog/2006/10/28/fix-for-firefox-20-backspace-action-linux/
http://www.linuxin.dk/forum/index.php?ops=linuxin&fmode=vis&visid=24700&grid=3
http://amish-geeks.de/blog/firefox-2-narf/feed/
http://www.turbokrecik.info/forum/viewtopic.php?p=11942
http://b.twidi.com/index.php/2006/10/28/70-firefox-2-touches-acceskeys-restauration-des-sessions-et-touche-backspace
http://element14.wordpress.com/2006/11/01/firefox-tweaks-revisted-for-20/
http://blog.verkoyen.eu/20061104/firefox-20-on-linux-backspace-issue/
http://helpero.com/Questions-and-answers/Computers/Linux/Where-can-I-find-a-Fix-for-Firefox-2-0-backspace-action-Linux_9622.html
http://www.chevrel.org/fr/faq/firefox/?id=15-retablir-le-comportement-de-la-touche-backspace-dans-ff2-(gnome)

And that's only from the FIRST TWO pages of a google search. The list could go on forever!
Comment 44 Simon Strandman 2006-12-10 09:55:32 PST
Btw I installed OpenSuse 10.2 with gnome 2.16 and I'm writing from it now. In gnome's file manager nautilus pressing backspace takes you one step back! So for platform consistency with the gnome desktop this change should be reverted!
Comment 45 Robert O'Callahan (:roc) (email my personal email if necessary) 2006-12-10 13:34:47 PST
> In gnome's file manager nautilus pressing backspace takes you one step back!

Wrong. It does "Up", not "Back".
Comment 46 Ryan Hayle 2006-12-10 13:56:16 PST
Robert is right.  It just seems like it's doing the same thing as back because typically you navigate from a parent folder to a child folder.  Sometimes it does not do what you would expect, however.  I remember being surprised at this behaviour several times while using Nautlius.  But that is a separate product, and perhaps I should file a separate bug report to change that behaviour making Backspace go back instead of up.

Obviously I'm not a part of the Mozilla Foundation, nor have I ever committed any actual code, I only try to help with bugs, so I don't really feel I should have much of a say in this.  Having said that, however, I think perhaps the real point of this bug should be to launch a campaign to make sure that GNOME and especially Novel corporate interests are NOT represented in any Mozilla projects, and that instead the decisions made reflect a reasonable view of the best possible choice.  As I've said, GNOME already has its own browser, called Epiphany.  I feel like they've snubbed Mozilla by even creating it and continuing to use and promote it.  Not only that, but the GNOME project is free to ship a customised GNOME-specific version of Firefox itself.  These customisations should not be in the base product, however.  And I say all this being a strong GNOME user and advocate myself!  The real issue is that this project must be free of commercial influences such as Novel.

Sorry for the spam, I know that's rather unrelated to this bug, and this is not a mailing list.
Comment 47 Karl Palsson 2006-12-11 04:10:40 PST
Ok, no problem.

On windows, backspace goes Back in time through my history.

On Gnome, backspace can go UP through my list of chronologically sorted pages.

There we go, everyone gets what they want.
Comment 48 Mats Palmgren (:mats) 2007-01-05 19:15:18 PST
Created attachment 250670 [details] [diff] [review]
ditto for SeaMonkey

Whatever the default end up being, it should be the same in Firefox and SeaMonkey.
Comment 49 Mats Palmgren (:mats) 2007-01-07 18:50:52 PST
Comment on attachment 250670 [details] [diff] [review]
ditto for SeaMonkey

Checked in to trunk at 2007-01-07 17:55 PST
Comment 50 Mats Palmgren (:mats) 2007-01-07 19:46:24 PST
FWIW, Backspace in Konqueror 3.5.5 does nothing. In Opera 9.02 it does Back.

My 2 cents: Backspace should do nothing.
Comment 51 Mark Banner (:standard8) 2007-01-08 01:27:03 PST
(In reply to comment #48)
> Created an attachment (id=250670) [details]
> ditto for SeaMonkey
> Whatever the default end up being, it should be the same in Firefox and
> SeaMonkey.

Please can you update suite/browser/browser-prefs.js as well - this is the new location of the prefs file for when SeaMonkey becomes an xul app.
Comment 52 Eric Windisch 2007-01-08 04:25:56 PST
Perhaps this should be filed as another bug, but the removal of this 'feature' has been met with extreme enthusiasm at my company. In FF 1.5, if the backspace was pressed while a <textarea> or <input type="text"> was selected, while the page was loading, after loading, the page would 'go back'.  I understand that this would be a separate bug, but if this feature would be re-instituted, avoidance of reimplementing this bug would be absolutely crucial.

This (silly) bug is significant enough to us to stick with any version that does not have this "feature".
Comment 53 Mats Palmgren (:mats) 2007-01-15 10:28:55 PST
(In reply to comment #51)
> Please can you update suite/browser/browser-prefs.js as well - this is the new
> location of the prefs file for when SeaMonkey becomes an xul app.

It would be much easier to maintain if we could share common default prefs
in ONE file that is used by all apps. I filed bug 367048 on that.
Comment 54 Mark Banner (:standard8) 2007-01-15 10:48:20 PST
(In reply to comment #53)
> (In reply to comment #51)
> > Please can you update suite/browser/browser-prefs.js as well - this is the new
> > location of the prefs file for when SeaMonkey becomes an xul app.
> 
> It would be much easier to maintain if we could share common default prefs
> in ONE file that is used by all apps. I filed bug 367048 on that.
> 
I agree. Though please note that the two versions of browser-prefs.js is a temporary arrangement which will hopefully be fixed soon.
Comment 55 Mark Banner (:standard8) 2007-05-11 11:17:15 PDT
Created attachment 264500 [details] [diff] [review]
Sync suiterunner to xpfe

suiterunner (SeaMonkey as xul app) version of attachment 250670 [details] [diff] [review].
Comment 56 Mark Banner (:standard8) 2007-05-12 00:41:49 PDT
(In reply to comment #55)
> Created an attachment (id=264500) [details]
> Sync suiterunner to xpfe
> 
> suiterunner (SeaMonkey as xul app) version of attachment 250670 [details] [diff] [review].
> 

This is now checked in. Is this bug now fixed again or is there more to do?
Comment 57 Mats Palmgren (:mats) 2007-05-12 05:24:24 PDT
Changing Summary to match what was actually fixed.

-> FIXED
Comment 58 Michael Ventnor 2007-05-12 07:20:01 PDT
While its probably too late to do anything now, one thing really confuses me:

(In reply to comment #7)
> I had a discussion about this with caillon and some GNOME people and we decided
> that the best option is to make backspace do *nothing*. Page-up is a bit silly
> and "backwards in history" invites dataloss.

If backwards in history invites dataloss then why is the backspace function still on by default in Windows? Is there something I'm missing? If not then this really isn't a good justification at all.
Comment 59 Boris Zbarsky [:bz] (TPAC) 2007-07-14 21:44:52 PDT
Backwards in history invites dataloss when the user ends up going back by accident.  In my experience, this has happened when I think have a text control focused and the browser thinks otherwise.

Usually that happens when I tab into a textfield or click on it and start typing, realize I made a typo, and hit backspace.  If I do this fast enough, in Firefox 1.5 I end up going back a page on Linux (and had I not hit backspace, I would not end up seeing the several characters I typed; there seems to be some lag focusing form inputs).  Doesn't seem to happen on Windows, the few times that I've used Firefox there.  So perhaps there's just not as much feeling that this is a problem.

It could also be that since all Windows browsers have been doing this for a long time (unlike the Linux situation), Windows users are used to this behavior.  In any case, I've not seen a Windows user complaining about the problem.

What we should really care about, perhaps, is Mac.  Given the current slew of focus bugs, about half the time clicking on a textfield doesn't focus it there, period.  Then again, I'd hope we fix that before 1.9.
Comment 60 [:Aleksej] 2007-07-15 01:26:06 PDT
I press Alt-up instead of Alt-Left often lately. :(

Actually, I have forgotten that I have backspace enabled, but that's more likely to be because it's not enabled by default, and not because it's further for me to reach for.
Comment 61 Jon B 2007-08-20 19:36:19 PDT
(In reply to comment #59)
> Backwards in history invites dataloss when the user ends up going back by
> accident.  In my experience, this has happened when I think have a text control
> focused and the browser thinks otherwise.

That's not fixed by removing the backspace functionality.  That would be fixed with a more fundamental solution, like Gmail's "Are you sure you want to navigate away from this page?" prompt.

Please restore the backspace = back default functionality that everyone wants.
Comment 62 Ryan 2007-08-21 06:19:42 PDT
Isn't the solution to the accidental data loss problem to keep form data in history? If you accidentally pressed back when filling out a form, you could press forward to return without losing form data. Actions should be reversible, regardless of whether you press backspace or the back button.

I agree that the user might be surprised after pressing the back button if focus wasn't on a text field, but the user should be able to reverse that action by pressing forward with no data loss. 
Comment 63 Jon B 2007-08-21 06:41:09 PDT
(In reply to comment #62)
> Isn't the solution to the accidental data loss problem to keep form data in
> history?

Something like that, yes.  I suspect there's a security consideration in not saving the form data for pages that aren't currently visible.  Shared computers and so on.

> If you accidentally pressed back when filling out a form, you could
> press forward to return without losing form data. Actions should be reversible,
> regardless of whether you press backspace or the back button.

Reversibility is definitely good.  I think a prompt might be a better idea, though.  "You have unsaved changes on this page.  Are you sure you want to navigate away from it?"  Then this would apply to any action that navigates away from a page, including Backspace, Ctrl+W, closing Firefox, and so on.  This is already the case in Google apps (programmed in javascript?), but should be the default behavior for any page with an edited form.
Comment 64 Jo Hermans 2007-10-20 10:00:09 PDT
*** Bug 400518 has been marked as a duplicate of this bug. ***
Comment 65 Nicolas Alvarez 2007-10-20 11:22:31 PDT
(In reply to comment #63)
> Reversibility is definitely good.  I think a prompt might be a better idea,
> though.  "You have unsaved changes on this page.  Are you sure you want to
> navigate away from it?"  Then this would apply to any action that navigates
> away from a page, including Backspace, Ctrl+W, closing Firefox, and so on. 
> This is already the case in Google apps (programmed in javascript?), but should
> be the default behavior for any page with an edited form.
> 
That is definitely the best solution.
Comment 66 Jon B 2007-11-29 12:54:09 PST
(In reply to comment #64)
> *** Bug 400518 has been marked as a duplicate of this bug. ***

Not a duplicate, since that bug is asking for the backspace to have it's normal "back" function and this bug is for it to "do nothing", which is a pointless non-solution that has been shown to confuse most users and waste their time.
Comment 67 Karsten Siegmund 2008-03-15 20:57:38 PDT
Well, it was a dup of the original bug, which has been "retargetted" without consent of the original submitter...
Overall an outrageous development - if the developer(s) are so insistent that this is not the desired behavior (which I disagree - there is wide agreement that there should be a one-button shortcut to go 'back' and, like it or not, Backspace has emerged to fill that role), then the bug should be marked WONTFIX.
Right now, the (rewritten) bug summary and status are just a lie. 

K.
Comment 68 Aleksey Lazar 2008-03-17 10:07:33 PDT
Seems like this issue is just a matter of different personal opinions. Personal opinions of those who have power to fix this prevail, by definition.

In my opinion, the "accidentally press the back button and lose form data" argument should carry very little weight for this issue. There are just too many prerequisites to trigger it:
1. One is filling out a poorly designed web form that does not save data
2. One makes a typo
3. One is not paying attention
4. One tries to correct the typo using the backspace button without focus

Q1: Out of all the browsing one does, what percentage of time does one spend filling out forms? What percentage of those forms don't save info?
Q2: Out of the above cases, how often does one make typos?
Q3: Out of the above cases, how often does one not pay attention?
Q4: Out of the above cases, how often does one try to correct the typo without first selecting the text field?

I fill out web forms often, but have never run into such a problem. 99.987654231% of the time I am just browsing, and the backspace button is a convenient shortcut to go back a page. I think the shortcut should be there by default.  Those who don't want the feature, should disable it for themselves -- as opposed to punishing everybody for someone's inability to stay focused on a web form (pun intended).
Comment 69 Jon B 2008-03-17 10:59:56 PDT
(In reply to comment #68)
> In my opinion, the "accidentally press the back button and lose form data"
> argument should carry very little weight for this issue. There are just too
> many prerequisites to trigger it:

Exactly.  And turning off the backspace button doesn't even fix the fundamental problem anyway.  This isn't the only way to lose form data because of navigation.  Disabling the backspace button is just a band-aid.  The real solution would be to prevent navigation until the user has confirmed that they want to discard what they have filled out, just like when you are composing a gmail.
Comment 70 Christopher Aillon (sabbatical, not receiving bugmail) 2008-03-17 12:42:38 PDT
Correct, the data loss is not that big of a deal anymore especially with the good work going on in session/history land.

The main points to leave the default as doing nothing are:

* No matter what the default is, there are going to be people that are unhappy with the default, so changing the default is only going to change the group of people that are unhappy with it.

* Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y and HIG fame.  Whether or not you agree, he owns keybindings for the HIG and his opinion here should weigh heavily.

* Pref locking is not uncommon, especially in corporate settings, so many times changing the pref is not even an option for users:
  + There is another keybinding for "go back a page": Alt+Left, so people can
    still use keynav to go back without tweaking prefs.  Yes, I realize it
    means pressing two keys instead of one, so it's "not exactly the same".
  + Those who don't want Backspace=GoBack have no way to get their desired
    behaviour without tweaking prefs.
Comment 71 Jon B 2008-03-17 12:52:22 PDT
(In reply to comment #70)
> * No matter what the default is, there are going to be people that are unhappy
> with the default, so changing the default is only going to change the group of
> people that are unhappy with it.

But the majority want it to go back.  So instead of **** off the minority, you just turn it completely off and **** off everyone?
 
> * Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y
> and HIG fame.  Whether or not you agree, he owns keybindings for the HIG and
> his opinion here should weigh heavily.

Firefox is a GNOME program?

Am I just imagining that Backspace = back in every other browser and browser-like file manager?

> * Pref locking is not uncommon, especially in corporate settings, so many times
> changing the pref is not even an option for users:
>   + There is another keybinding for "go back a page": Alt+Left, so people can
>     still use keynav to go back without tweaking prefs.  Yes, I realize it
>     means pressing two keys instead of one, so it's "not exactly the same".

Assuming their alt key hasn't been changed to a language key, as it is by default on some systems that i've used.

>   + Those who don't want Backspace=GoBack have no way to get their desired
>     behaviour without tweaking prefs.

Those who want Backspace=GoBack have no way to get their desired
behaviour without tweaking prefs.
Comment 72 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-03-17 12:55:45 PDT
(In reply to comment #71)
> But the majority want it to go back.

How do you know?
Comment 73 Karsten Siegmund 2008-03-17 13:12:29 PDT
My point was just that it's dishonest to mark this bug as "fixed" and I can't have a very high opinion of these people anyways. 

Thinking about it again, there is probably some truth  in it that different behavior with focus within a text field and without can be pretty annoying and therefore "backspace" might be a poor choice (although it is kind of intuitive, that backspace goes "back"). 

But it is also true, that hitting backspace after losing focus is one of the things that happen quite rarely (might be different, when you're on a modem connection and pages/forms load much slower) - quite a *lot* more often I have hit ^U to clear the line and got the source listing of the page, or ^W to erase the last word and closed the tab or window (ha - talk about data-loss there... you can re-open tabs, but a window is gone). 

It seems Bug 400518 someone made the trivial patch to change it - but I can't see if he's a dev who put it in svn/cvs/whatever they use. 

Anyways... my feeling is, that this is mainly a matter of taste - some just want to have a simple single-key shortcut to go back (how about "Del" if Backspace is a poor choice? It "does nothing" right now and is hardly used for correction during typing) so the "best" alternative would be what someone already suggested - on the first use of "Backspace" outside a text field, the user should be asked what behavior he wants (do nothing/back in history/page up). As obviously different users want different behaviors and even have a strong opinion on this, the best way would be to ask them - saving them the effort to google for a fix that leads to the behavior they want. 

(as this bug is closed, putting a copy of the suggestion to Bug 400518 would be a good idea?)

Uh - about "pref locking" - that works as much (or more) against as for you. In this context, I would like to mention, that I'm not coming from an IE (or even Windows) world, but got used to having Backspace to go back purely on Mozilla/Firefox/Iceweasel (the Debian-distributed Firefox) - so I'm kind of all for locking the prefs - of course, locking them in the behavior I got used to...

K.
Comment 74 Aleksey V. Lazar 2008-03-17 13:41:40 PDT
> * No matter what the default is, there are going to be people that are unhappy
> with the default, so changing the default is only going to change the group of
> people that are unhappy with it.
> 
Like I said in Comment #68, first two sentences.

> * Backspace=DoNothing fits best with GNOME, according to Callum of GNOME a11y
> and HIG fame.  Whether or not you agree, he owns keybindings for the HIG and
> his opinion here should weigh heavily.
> 

I am not entirely sure why GNOME key bindings are a consideration for this request (really, I don't know!)  Firefox is not a GNOME application. The majority of Firefox users don't even use Linux. I use KDE. So what? IF GNOME had it's way, all buttons would be disabled ;) Those users need to be protected from themselves.

> * Pref locking is not uncommon, especially in corporate settings, so many times
> changing the pref is not even an option for users:
>   + There is another keybinding for "go back a page": Alt+Left, so people can
>     still use keynav to go back without tweaking prefs.  Yes, I realize it
>     means pressing two keys instead of one, so it's "not exactly the same".

Definitely not the same. Not only does this shortcut consist of two buttons, but both buttons are at the bottom of the keyboard and one of them is far from where the hands usually are. It's just not as fast or ergonomic. Too much movement and effort is required.

>   + Those who don't want Backspace=GoBack have no way to get their desired
>     behaviour without tweaking prefs.
> 

Yes they do. Exactly the same way as I did the opposite. Even in locked corpolitarian environments there are system administrators.
Comment 75 Simon Strandman 2008-03-18 05:19:58 PDT
I can buy the argument that whatever you do someone will be unhappy with it. But still, backspace has meant go back in firefox for years and also in most other browsers including the dominant one on the market. So changing it now in firefox makes no sense. People who come from IE will usually not try to change keybindings, they will just be anoyed that firefox doesn't behave the way they are used to.

I haven't read the gnome HIG but I know that the gnome application with the most firefox like UI, nautilus in browser mode, takes you back one step in the filesystem when you press backspace. So for consistency with nautilus backspace should go back in firefox also.

About how many people that are disappointed by the change:
http://www.google.com/search?q=firefox2+backspace+linux

Comment 76 Jon B 2008-03-18 06:11:42 PDT
Just look through the ~100 comments on http://ubuntu.wordpress.com/2006/12/21/fix-firefox-backspace-to-take-you-to-the-previous-page/ if you think that there are people out there who like this doing nothing.

If you want to prevent people from losing form data, prevent them from losing form data universally with a "do you want to discard this form?" dialog.  Don't cripple the key bindings as a band-aid for a problem that most users don't even have.
Comment 77 vsync 2008-09-17 14:33:40 PDT
You people are disgusting.  Lunix has always had "space forward, backspace back".  Making it go back in history is terroristic and should lead to internment at Guantanamo Bay.  Making it do nothing is just as bad.  "I'm afraid to do it right so I'll break this key".  Terrorists.
Comment 78 Mick Russom 2008-09-22 15:29:16 PDT Comment hidden (advocacy)

Note You need to log in before you can comment on or make changes to this bug.