Closed Bug 325559 Opened 14 years ago Closed 14 years ago

when no profile is accessible Firefox 1.5 gives an inappropriate error

Categories

(Firefox :: General, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: stephane.tranchemer, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

We have created in our univ a special context for our students, they have their personnal disk space on server linked to letter P: at login time (given by the PDC that authenticates the login) and a directory firefox in it.
The master of the win2000 system is replicated with the profiles.ini created as such :

c:/Documents and Settings/Default User/Application Data/Mozilla/Firefox/profiles.ini

[General]
StartWithLastProfile=1
[Profile0]
Name=default
IsRelative=0
Path=P:\Firefox\

When you start with a local login (like "guest") however, you don't have the P: letter.
Completely logically you will have an error.

-On Firefox 1.0.7, the profiles manager pops on the screen.
-On Firefox 1.5 however, you have an unfriendly message saying that firefox is already running but doesn't answer (in fact it doesn't), and you have to stop the (non-existing) running firefox process or reboot the machine.
There is no way to start firefox since pressing the OK button only exit.

Of course the basis of the error is that Firefox doesn't find the directory to place his profile, however version 1.5 should act like version 1.0.7 and give the profile manager so that we can create a new profile to start with.

Reproducible: Always

Steps to Reproduce:
1.tell in profiles.ini to use a non existent place
2.start firefox

Actual Results:  
Firefox 1.5 don't give profile manager to correct the error, but a message with no option

Expected Results:  
irefox 1.5 give profile manager to create a new valid profile
Looks like a duplicate of Bug 278860.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.