Mozilla extensions that also "support" Thunderbird overwhelm real TB extensions

VERIFIED DUPLICATE of bug 308193

Status

--
enhancement
VERIFIED DUPLICATE of bug 308193
13 years ago
3 years ago

People

(Reporter: mozilla, Assigned: morgamic)

Tracking

unspecified
x86
Windows XP

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Extensions are popularity-rated by # of downloads; unfortunately, extensions that are designed primarily for Firefox (but the developer threw in Thunderbird support as an afterthought), if they're popular for Firefox, fly to the top of the *Thunderbird* extensions list and make it difficult to find "real" Thunderbird extensions.

Reproducible: Always

Steps to Reproduce:
1. Click "Get More Extensions" in Thunderbird
2. Read the list of "Most Popular Thunderbird Extensions"
3. Wonder why so many Thunderbird users are eager for FlashGot, FoxyTunes, ImageZoom, etc., when you just want to enhance your emailing experience.
4. Click "Thunderbird Extensions" at the bottom of the page.
5. Notice how the featured Thunderbird extension "integrates the del.icio.us service with your Firefox browser".
Actual Results:  
It's possible to find real Thunderbird extensions mixed in with the Firefox ones, and the categories under "All Extensions" are more helpful, but the experience of getting Thunderbird extensions is still quite frustrating.

Expected Results:  
I expect to see extensions that were most downloaded by Thunderbird users, from the Thunderbird category.  Results should not be skewed by high downloads of an extension for Firefox.

I'm listing this as a RFE instead of bug, because it will require better data collection on downloads before it's possible to create a useful experience for this part of the site.

Currently, the "Install" URLs don't include the "&application=thunderbird" attribute, so for all downloads so far, it'll be impossible to track the application an extension was downloaded for.

But as Thunderbird gains in popularity, especially, these pages will be very confusing for a non-Firefox user, and frustrating for anyone.

Comment 1

13 years ago
AMO 2.0 has better filtering.
This ooks like a duplicate of bug 308193 to me...
(In reply to comment #2)
> This ooks like a duplicate of bug 308193 to me...
> 

I think it is. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 308193
Verified dup
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.