Closed Bug 325950 Opened 17 years ago Closed 17 years ago

inaccurate error message "Firefox is already running, but is not responding." when default profile is on a removed drive

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: firefox, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I store my Firefox profile on a removable drive. If I attempt to open Firefox without the drive plugged in, it returns the error message "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." Firefox is assuming incorrectly that since it cannot locate the default profile, the profile must already be in use. This has occurred for several past releases of Firefox, with some rewording of the error message.

Reproducible: Always

Steps to Reproduce:
1. Create default profile on removeable media
2. Remove the media which contains the profile
3. Attempt to open Firefox

Actual Results:  
Firefox returned the given error and did not open.

Expected Results:  
Firefox should return a more specific error message stating that the default profile can not be located.
Summary: inaccurate error message "Firefox is already running, but is not responding." → inaccurate error message "Firefox is already running, but is not responding." when default profile is on a removed drive

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.