inaccurate error message "Firefox is already running, but is not responding." when default profile is on a removed drive

VERIFIED DUPLICATE of bug 278860

Status

()

--
trivial
VERIFIED DUPLICATE of bug 278860
13 years ago
10 years ago

People

(Reporter: firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

I store my Firefox profile on a removable drive. If I attempt to open Firefox without the drive plugged in, it returns the error message "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." Firefox is assuming incorrectly that since it cannot locate the default profile, the profile must already be in use. This has occurred for several past releases of Firefox, with some rewording of the error message.

Reproducible: Always

Steps to Reproduce:
1. Create default profile on removeable media
2. Remove the media which contains the profile
3. Attempt to open Firefox

Actual Results:  
Firefox returned the given error and did not open.

Expected Results:  
Firefox should return a more specific error message stating that the default profile can not be located.

Updated

13 years ago
Summary: inaccurate error message "Firefox is already running, but is not responding." → inaccurate error message "Firefox is already running, but is not responding." when default profile is on a removed drive

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.