Closed Bug 326152 Opened 14 years ago Closed 13 years ago

Remove GTK1 and XLIB from the tree.

Categories

(Core :: Widget, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: pavlov, Assigned: mats)

References

Details

Attachments

(4 files, 1 obsolete file)

The time has come to say goodbye to our old friend gtk1.
As we move in to the world of thebes, keeping GTK1 working is becoming more and more work and we believe it is time for it to go.  It will stop functioning in a couple months when we switch over to thebes completely anyways, so this is just a few months ahead of schedule.

After speaking with bz the other day, he said to go ahead and kill gtk1 if it got in the way and not to spend any time trying to keep it going.
One thing we _do_ need to do before we do this is sort out tinderbox.  In particular, luna, comet, and btek all build GTK1.  Luna is the only tinderbox running Tdhtml and codesize tests on trunk.  luna and btek are running the closest thing we have to reliable pageload performance tests.  comet and luna are running Txul (though they're Seamonkey, so it won't catch improvements due to front-end changes, or regressions that are Firefox-specific); again, none of the Firefox tinderboxen run a useful Txul test (the only one that does, on Windows, is too fast).

So it sounds to me like we want to switch these machines to building GTK2 and record the effect on the performance tests (so that we can compare to historical data later) before we start ripping out GTK1.
/me waves goodbye to xmlterm too (it requires GTK1...)
What about Xlib? It wouldn't work either so that there seems to be no point in keeping it. The only thing I'm not sure of is what would happen to ports on commercial unix. 
 
note that it shouldn't be hard to port xlib and/or gtk to cairo.
Summary: Remove GTK1 from the tree. → Remove GTK1 and XLIB from the tree.
Attachment #263217 - Flags: superreview?(roc)
Attachment #263217 - Flags: review?(roc)
Attached file List of removed files
Attachment #263218 - Flags: superreview?(roc)
Attachment #263218 - Flags: review?(roc)
Attachment #263217 - Flags: superreview?(roc)
Attachment #263217 - Flags: superreview+
Attachment #263217 - Flags: review?(roc)
Attachment #263217 - Flags: review+
Attachment #263218 - Flags: superreview?(roc)
Attachment #263218 - Flags: superreview+
Attachment #263218 - Flags: review?(roc)
Attachment #263218 - Flags: review+
Assignee: general → mats.palmgren
Comment on attachment 263217 [details] [diff] [review]
Patch rev. 1 (this is without removed files)

This part was checked in 2007-04-30 16:52 PDT.
With a bustage fix at 2007-04-30 17:13 PDT.

I'll land the file removals tomorrow.
Attached patch Patch rev. 2 (obsolete) — Splinter Review
I found a couple of spots I missed.
Attachment #263318 - Flags: superreview?(roc)
Attachment #263318 - Flags: review?(roc)
Attached patch Patch 2, rev. 1Splinter Review
A few more spots ;-)
Attachment #263318 - Attachment is obsolete: true
Attachment #263320 - Flags: superreview?(roc)
Attachment #263320 - Flags: review?(roc)
Attachment #263318 - Flags: superreview?(roc)
Attachment #263318 - Flags: review?(roc)
Attachment #263320 - Flags: superreview?(roc)
Attachment #263320 - Flags: superreview+
Attachment #263320 - Flags: review?(roc)
Attachment #263320 - Flags: review+
Comment on attachment 263218 [details]
List of removed files

These files were removed on trunk at 2007-05-02 17:10 PDT.
Comment on attachment 263320 [details] [diff] [review]
Patch 2, rev. 1

Checked in to trunk at 2007-05-02 17:52 PDT.
I missed the .cvsignore files, these should be removed too...
Attachment #263556 - Flags: superreview?(roc)
Attachment #263556 - Flags: review?(roc)
Comment on attachment 263556 [details]
A few more files to remove...

r+sr=dbaron.  And no need to ask for review for removing .cvsignore files from otherwise empty directories.
Attachment #263556 - Flags: superreview?(roc)
Attachment #263556 - Flags: superreview+
Attachment #263556 - Flags: review?(roc)
Attachment #263556 - Flags: review+
-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
QA Contact: general
You need to log in before you can comment on or make changes to this bug.