[RFE] Support for POP STLS command

RESOLVED DUPLICATE of bug 218902

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 218902
12 years ago
12 years ago

People

(Reporter: Andrew C. Oliver, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

It would be chill if Thunderbird supported the POP3 STLS extension.  Not all mail servers support his but some do.  You can download an open source one for testing purposes here: http://wiki.jboss.org/wiki/Wiki.jsp?page=HowToInstallJBossMailServer1.0M4.  

STLS is the POP3 cousin to STARTTLS in SMTP and allows you to use the standard POP3 port and get SSL based encryption too which is really nifty if you don't want the world to sniff your password but don't want to open up extra ports or run extra instances on your server just for SSL.

Reproducible: Always

Steps to Reproduce:
1.add one of them nifty check boxes to the POP3 config saying "Use TLS if allowed"
2.add protocol support for issuing STLS command and switching the stream over to SSL

Actual Results:  
must presnetly use POP/SSL or loose your happy encryption

Expected Results:  
Get to use POP3 and port 110 but yet swap in that happy SSL stuff

Comment 1

12 years ago
I think STLS is already supported, and this is a duplicate of bug 218902...
(Reporter)

Comment 2

12 years ago
I haven't upgraded to 1.5 yet (partly because I'm having a heck of the time with the mozilla build on OS X and apple's **** website to get their freakish recompiles to get the latest source to build...), but in 1.0.x you could have (POP/SSL) SSL or no SSL but no STLS (ala port 110).

Comment 3

12 years ago
Yep, you need tb 1.5... Duping.

*** This bug has been marked as a duplicate of 218902 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

12 years ago
thanks...sorry for the hassle...I did do a search first...but somehow missed it...
You need to log in before you can comment on or make changes to this bug.