Closed Bug 326562 Opened 14 years ago Closed 14 years ago

No 'Visit URL' button in the new event dialog

Categories

(Calendar :: Internal Components, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jminta, Assigned: jminta)

References

Details

(Keywords: regression)

Attachments

(3 files)

The old Sunbird event-dialog had a 'Visit URL' button right next to the url field.  This has since been lost.

Patch to follow.
There isn't much use in having a 'URL' field if you can't easily visit that url.  launchBrowser() is defined in applicationUtil.js, so that needs to get included in lightning for it to work there.
Attachment #211283 - Flags: first-review?(dmose)
Comment on attachment 211283 [details] [diff] [review]
bring back button

This will produce browser errors if the url field is empty and you press the button. The browser tries to load 'http://' and fails.

There should be either a check for url not empty after pressing the button or the button should be disabled if no url is entered in field.
Comment on attachment 211283 [details] [diff] [review]
bring back button

minused, given Stefan's comment.  Also, can you attach a screenshot?
Attachment #211283 - Flags: first-review?(dmose) → first-review-
version 2 includes error checking for blank URLs.  The Visit URL button will be disabled in that case.  The requested screenshot can be found here: http://www.nd.edu/~jminta/mozilla/Screenshot-1.png
Attachment #212382 - Flags: first-review?(dmose)
Significant regression in the event-dialog's capabilities.  Blocks 0.3a2
Comment on attachment 212382 [details] [diff] [review]
bring back button v2

r=dmose if you add |return|s to the end of the functions that you touched.  That makes it clear that the end of the function is intentional, and not that someone was inadvertantly distracted while writing the code.
Attachment #212382 - Flags: first-review?(dmose) → first-review+
Patch checked in, with returns
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Comment on attachment 212382 [details] [diff] [review]
bring back button v2

>@@ -810,16 +810,18 @@ function loadDetails() {
>     updateTaskAlarmWarnings();
>+
>+    updateURL();
> }
> 
...
>+
>+function updateURL(aValue) 
>+{
>+    var button = document.getElementById("load-url-button");
>+    button.setAttribute("disabled", true)
>+
>+    if (!aValue) {
>+        return;
>+    }

I did not notice until now: Because the call to updateURL() in loadDetails() does not pass in a url the button will be always disabled (even if the existing url is valid) when opening the dialog until you type something into the url field.
Fix for ssitter's comment.
Attachment #216870 - Flags: first-review?(dmose)
Comment on attachment 216870 [details] [diff] [review]
fix for ssitter's comment

r=dmose
Attachment #216870 - Flags: first-review?(dmose) → first-review+
followup patch checked in.
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060909 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.