Partialy downloaded image replaced with error message.

RESOLVED DUPLICATE of bug 58880

Status

RESOLVED DUPLICATE of bug 58880
13 years ago
13 years ago

People

(Reporter: jlayoj3121968, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0

When the download of any image not embedded in a page is interrupted for any reason the partially rendered image is replaced by the message: The image “[image URL]” cannot be displayed, because it contains errors.

Reproducible: Always

Steps to Reproduce:
1. Browse to example URL or any direct URL to a large image.
2. Click the Stop button before the image finishes downloading.

Actual Results:  
Partial image is replaced by error message as described above.

Expected Results:  
Partial image should remain. If the download is interrupted by an error, it should be displayed in an error dialog rather than replacing the image. If it is stopped by the user there should be no error displayed at all.

This bug can and does prevent users from viewing some mostly complete images. I can't confirm at this time, but I think it also happens if the source image file is incomplete.

(I could have sworn I had reported this before, but could not find it with either a search for the error text or my own email.)
The error message displayed is completely correct, so this should at least be labelled as an enhancement. I do agree with you though: it would be nice if this behaviour was improved somewhat, although I would think that displaying a half-downloaded image wasn't a good idea.

Comment 2

13 years ago
Duplicate of Core bug 150611 -> Core bug 58880.

*** This bug has been marked as a duplicate of 58880 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.