Closed Bug 326813 Opened 14 years ago Closed 14 years ago

Day/week view: left click on event does not selects day too

Categories

(Calendar :: Internal Components, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: jminta)

Details

Attachments

(1 file)

Day/week view: left click on event does not selects day too

If you select an event by left click the corresponding day is not selected too. It works if you select the event by middle or right mouse button click.

In multi-week/month view the day is always selected too when selecting an event.

I'm not sure if this is a regression. At leaast it is inconsistence and should be fixed.
Attached patch set selected daySplinter Review
The columns do have listeners for onmousedown to set the selected day, however, since we stopPropagation() on the events when an item is selected, these don't get called.  Therefore, this patch sets the selected day within the event-box itself.  This patch also wires up an onmousedown listener to the header box to fix the behavior there as well.
Assignee: base → jminta
Status: NEW → ASSIGNED
Attachment #216328 - Flags: first-review?(mvl)
Comment on attachment 216328 [details] [diff] [review]
set selected day

r=mvl
Attachment #216328 - Flags: first-review?(mvl) → first-review+
Patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060909 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.