Linkify and onhover references in HTML bugmail

RESOLVED FIXED in Bugzilla 4.2

Status

()

--
enhancement
RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: bugreport, Assigned: guy.pyrzak)

Tracking

2.21
Bugzilla 4.2
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Once bugmail is available in HTML format, When a bugmail contains a reference to another bug or a comment, the HTML-coded bugmail should auto-linkify the reference AND provide the same onhover feature for bugs as we have in show_bug AND comments should be displayed when hovered on.

This way, when an email references comment XYZ, (expecially in replies) the reader can hover on XYZ to see that comment.

This depends on HTML mail being s userpref controlled item, of course.

Comment 1

13 years ago
Note that currently hovering over bug numbers shows their status/resolution and summary, however if these change after the email has been sent but before it's read, it won't update = ugly.

Comment 2

12 years ago
Note also bug 113688 about a similar request, but for plain text emails.
(Assignee)

Comment 3

8 years ago
this bug might now be a dup for bug 65477 since bug 65477 will implement this.
(Assignee)

Updated

8 years ago
Assignee: email-notifications → guy.pyrzak
(Assignee)

Comment 4

8 years ago
Created attachment 480523 [details] [diff] [review]
v1

lol, this was EASY
Attachment #480523 - Flags: review?(mkanat)
Attachment #480523 - Flags: review?(LpSolit)

Comment 5

8 years ago
Comment on attachment 480523 [details] [diff] [review]
v1

Looks good to me! Of course, we'll have to get some feedback and make sure that this works in all the common MTAs.

This means that you can also remove full_url, right?
Attachment #480523 - Flags: review?(mkanat)
Attachment #480523 - Flags: review?(LpSolit)
Attachment #480523 - Flags: review+

Updated

8 years ago
Flags: approval+
Target Milestone: --- → Bugzilla 4.2
(Assignee)

Comment 6

8 years ago
(In reply to comment #5)
> 
> This means that you can also remove full_url, right?

It does.

Updated

8 years ago
Duplicate of this bug: 603681

Comment 8

8 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified template/en/default/email/bugmail.html.tmpl
Committed revision 7539.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

6 years ago
Blocks: 777398
You need to log in before you can comment on or make changes to this bug.