Open Bug 113688 Opened 18 years ago Updated 5 years ago

Include summaries of and link URLs to bug ### or other quoteUrls phrases in email

Categories

(Bugzilla :: Email Notifications, enhancement, P1)

enhancement

Tracking

()

REOPENED

People

(Reporter: tpowellmoz, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

If you're used to using the web interface of bugzilla, you know that phrases 
like "bug 106405" get turned into links. It'd be nice to run a similar process 
and create URLs in the email notifications. Since bugzilla is sending text 
email, it seems like it would make most sense to just break at the first 
whitespace following the bug phrase and add the URL on the next line below.

For example, if the bug says, "see bug 106405 for more information." the email 
notification could say:

see bug 106405
http://bugzilla.mozilla.org/show_bug.cgi?id=106405
for more information.

Or if the bug says, "additional comments in bug 14887, or perhaps this is a 
duplicate" the email could say:

additional comments in bug 14887,
http://bugzilla.mozilla.org/show_bug.cgi?id=14887
or perhaps this is a duplicate

This change would just make it convenient to link directly to the referenced 
bug from the email.
I like the idea, but I think that a list of URLS at the end of the mail, after
the comment would be better.
Priority: -- → P4
Target Milestone: --- → Future
*** Bug 125905 has been marked as a duplicate of this bug. ***
It would be nice to have the summaries listed in the mail as well as the URLs.
Summary: Include link URLs to bug ### phrases in email → Include summaries of and link URLs to bug ### phrases in email
Agree with both comment 1 and comment 3.  Here's what I'd like to see:

See also bug 123456 [1].  I think that one and comment 5 [2] sums things up nicely.

---- [1] http://bugzilla.mozilla.org/show_bug.cgi?id=123456 ----
Foo bars render weirdly

---- [2] http://bugzilla.mozilla.org/show_bug.cgi?id=100000#comment2 ----

Comment 2 text goes here
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Assignee: jake → preed
I'll think the list should also included bugs added and removed from dependency 
(bug 97956) and duplicate bugs (bug 125888).
*** Bug 284046 has been marked as a duplicate of this bug. ***
I'll probably look at this in the next week or so and try and get it done... 
certainly will have a look before March 8th so that it may get in for the 2.20 
freeze.
Kick all my Bugzilla bugs back to the component default owner.
Assignee: preed → email-notifications
QA Contact: mattyt-bugzilla → default-qa
*** Bug 355825 has been marked as a duplicate of this bug. ***
I like the suggestion comment #4. See yet another possibility in the dupe bug 355825.
Target Milestone: Future → ---
Duplicate of this bug: 386762
(In reply to comment #11)
> I like the suggestion comment #4. See yet another possibility in the dupe bug
> 355825.

eyal: If bugs are listed as added/removed from dependencies, would you really want footnote markers there too? that seems fairly risky.
Well, first of all, maybe for removed dependencies we don't want a footnote link (for added dependencies we should want such a link). Still, why do you think it's risky? It's just a link to a bug page.
Priority: P4 → P1
  The best solution here might be to modify quoteUrls itself and give it a "text" version, so that everything that gets linkified would show up as a footnote at the end of the comment. Pretty easy to do, actually, I'd imagine.
Summary: Include summaries of and link URLs to bug ### phrases in email → Include summaries of and link URLs to bug ### or other quoteUrls phrases in email
Duplicate of this bug: 547105
fwiw, i'd like to see keyword descriptions included in footnotes when keywords are added. that'd enable me to add keyword: stackwanted and not have to include a url in the comment.
Attached patch WIP Patch (obsolete) — Splinter Review
This is working but I should probably clean that a little bit.
Assignee: email-notifications → mounir.lamouri
Status: NEW → ASSIGNED
Mounir: By chance might portions of your patch be applicable toward bug 97956 or bug 125888?
Attached patch Patch v1Splinter Review
I think this patch is ready to be reviewed.
Attachment #507911 - Attachment is obsolete: true
(In reply to comment #19)
> Mounir: By chance might portions of your patch be applicable toward bug 97956
> or bug 125888?

This patch should fix bug 125888. I'm planning to work on bug 97956 if I have some time next week.
Version: 2.15 → unspecified
Attachment #508108 - Flags: review?(mkanat)
Target Milestone: --- → Bugzilla 4.2
Blocks: 125888
Comment on attachment 508108 [details] [diff] [review]
Patch v1

Hey volkmar. First off, thank you for this patch, and I am really sorry that it has taken me so long to get to it.

In general, right now, the implementation seems too complex. Having all of the $text_only ? this : that is too much. Having separate blocks for $text_only is too much. I'm not quite sure what to do about it (I may be able to come up with something if I think about it a bit more). Do you have any ideas on how this could be simplified?
Attachment #508108 - Flags: review?(mkanat) → review-
Target Milestone: Bugzilla 4.2 → Bugzilla 5.0
We are going to branch for Bugzilla 4.4 next week and this bug is either too invasive to be accepted for 4.4 at this point or shows no recent activity. The target milestone is reset and will be set again *only* when a patch is attached and approved.

I ask the assignee to reassign the bug to the default assignee if you don't plan to work on this bug in the near future, to make it clearer which bugs should be fixed by someone else.
Target Milestone: Bugzilla 4.4 → ---
Assignee: mounir → email-notifications
Status: ASSIGNED → NEW
Duplicate of this bug: 956456
This is all handled by HTML email these days; I don't think it's worth complicating/uglifying the text-only emails.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Admittedly HTML mail doesn't handle all linkifications you see in comments, but it does handle the most common one referenced in comment #0, that is, bug <id>.
Strongly disagree with Comment 25:
- The HTML email linkification is partial, as noted in Comment 26.
- A large fraction of people, especially developers, use plain text email and will not switching to HTML for various reasons.
- Using markdown-style links, as in Comment 4, does not complicate the text-only emails. It's like footnotes or endnotes, a common custom which doesn't hamper reading except very slightly.

Please consider re-opening.
Fair enough.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Duplicate of this bug: 1109581
You need to log in before you can comment on or make changes to this bug.