If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Always add "-CCK" to user agent string.

VERIFIED FIXED in M20

Status

CCK
CCK-Wizard
P1
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: bmartin, Assigned: varada)

Tracking

other
x86
Windows NT

Details

(Whiteboard: [Candidacy Approved] - 2 hours, URL)

(Reporter)

Description

18 years ago
Latest CCK build dated: 03-21-00

O/S: WinNT4.0

Steps to Reproduce:
1. Install cck
2. launch cck
3. create a "default" configuration build without entering a value for the 
user-agent string.
4. Install build
5. View the user-agent string

Results:

The User-agent string should contain "-CCK".

If user adds their own custom User agent text, it should be appended to the user 
agent string.

This is a Beta2 requirement per Client Product Marketing
(Reporter)

Comment 1

18 years ago
updating to P1 per marketing's beta2criteria document
Priority: P3 → P1
Target Milestone: ---
(Assignee)

Comment 2

18 years ago
this is dependant on bug #6117 - the user agent string has to be implemented for 
this to work.
Status: NEW → ASSIGNED
Depends on: 6117
Priority: P1 → P2
Whiteboard: [Candidacy Approved] - 2 hours
Target Milestone: --- → M16
(Reporter)

Comment 3

18 years ago
Per 04-24-00 cck team meeting:

If user doesn't specify a User Agent String, grab the homepage URL
(Reporter)

Comment 4

18 years ago
*** Bug 37092 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

18 years ago
*** Bug 37092 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

18 years ago
This is dependant on 6117. Moving to M17
Target Milestone: M16 → M17
(Reporter)

Comment 7

17 years ago
Updating P2 to P1 (there is no P0) and M17 to M18
Priority: P2 → P1
Target Milestone: M17 → M18

Comment 8

17 years ago
Varada, can you please provide examples in this bug of a customized user agent 
string as follows:

*customized user agent string with CCK user's custom string (i.e. "MyIsp")
*customized user agent string with home page URL (no custom string specified)

Thanks.
(Reporter)

Comment 9

17 years ago
The User Agent string is getting customized with the -CCK and 10 character 
string

If users don't specify a 10 character user agent string, CCK Tool should append 
the home page URL.  Currently this is not working.

Comment 10

17 years ago
Um, user agent and URL are completely different things.  This bug should be
about what the summary says and shouldn't have anything to do with URLs...

CCK should append -CCK to the user agent string ALL THE TIME.  Updating summary.
Summary: Add "-CCK" to user agent string, by default, if not specified. → Always add "-CCK" to user agent string.
(Reporter)

Comment 11

17 years ago
As discussed and requested by Bijal, in a previous CCK team meeting dated: 
04-24-00 (commented above), there are two expected behaviors that need to occur 
with regards to customizing the user agent string:

1. Always add -CCK and user's specified 10 character user agent string

2. If user doesn't specify a string, the CCK Tool should automatically append 
the home page URL to the -CCK.

Number two was added to this bug to keep all expected user agent behavior 
together.

Comment 12

17 years ago
Adding Bij to CC.

Bij, there is _no_ circumstance under which adding an URL to the user agent
string is correct.  Perhaps you had something else in mind?
(Reporter)

Comment 13

17 years ago
updating to critical for RTM
Severity: major → critical

Comment 14

17 years ago
Agree.  Plan to address this with Daniel Hill and the distribution folks in our 
weekly meeting this week.
Severity: critical → major
(Reporter)

Comment 15

17 years ago
M18 to M20
Target Milestone: M18 → M20
(Assignee)

Comment 16

17 years ago
Marking Fixed.
The "CCK-" tag is always added to the user agent string in the vendor.comment
portion.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

17 years ago
Marking Verified Fixed on Win95,98,NT4.0,2000
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.