If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Live bookmark icon not displayed in places toolbar (livemarkItem.png corrupt)

RESOLVED FIXED in Firefox 2 alpha2

Status

()

Firefox
Bookmarks & History
P1
normal
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Doug Shelton, Assigned: Annie Sullivan)

Tracking

({fixed1.8.1})

Trunk
Firefox 2 alpha2
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060206 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.9a1) Gecko/20060206 Firefox/1.6a1

if a livemark/rss feed is on the places toolbar, the "livemark" icon is not displayed.

Reproducible: Always

Steps to Reproduce:
1.build Firefox with places enabled
2.run Firefox
3.place RSS/livemark bookmark on places toolbar (or use headlines from default profile)
4.observe livemark button

Actual Results:  
no icon is displayed

Expected Results:  
livemark icon should be displayed as it is on traditional bookmarks toolbar

tested with default theme from 2006-02-16 trunk.
(Reporter)

Comment 1

12 years ago
Created attachment 212157 [details]
screenshot of places toolbar with missing icon
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: BeOS → All
Hardware: PC → All
Version: unspecified → Trunk
Summary: Livemark icon not displayed in places toolbar → Live bookmark icon not displayed in places toolbar
Assignee: nobody → annie.sullivan
Priority: -- → P1
Target Milestone: --- → Firefox 2 alpha2
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

12 years ago
I'm not certain why this was changed to "fixed"  problem still exists.  Moreover, bug 329120 appears to be a duplicate of this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 3

12 years ago
Created attachment 214065 [details]
screenshot after 2006-03-04 trunk build
(Reporter)

Comment 4

12 years ago
This is definitely due to a corrupt livemarkItem.png file in browser/places folder.  I suggest eliminating this icon completely and changing the .css to point to /browser/page livemarks.png 

This would eliminate an icon file and keep livemark icons consistent across contexts.
(In reply to comment #4)
> This is definitely due to a corrupt livemarkItem.png file in browser/places
> folder.  I suggest eliminating this icon completely and changing the .css to
> point to /browser/page livemarks.png 
> 
> This would eliminate an icon file and keep livemark icons consistent across
> contexts.
> 

Indeed corrupted image
I copied skin\classic\browser\page-livemarks.png to
skin\classic\browser\places\livemarkItem.png

and the icon is displayed fine in all bookmarks and places menus
Summary: Live bookmark icon not displayed in places toolbar → Live bookmark icon not displayed in places toolbar (livemarkItem.png corrupt)
*** Bug 329120 has been marked as a duplicate of this bug. ***
Blocks: 327563
Fixing livemarkItem.png also fixes bug 327563
(Assignee)

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.