Labelled link associated with checkbox

RESOLVED DUPLICATE of bug 163912

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 163912
12 years ago
12 years ago

People

(Reporter: Thierry Danard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

In a HTML code where a link is a label of a checkbox, clicking that link automatically checks/unchecks that checkbox. This is not the expected behavior, the checkbox should not be affected. It should only be affected when the label is a text or an image, not a link. In Internet Explorer, it works as expected.

Reproducible: Always

Steps to Reproduce:
The HTML code looks like this:

<input type="checkbox" name="field0" id="field0">
<label for="field0"><a href="test.html">test</a></label>

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 163912 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.