Views don't display events that start and end at 00:00 on the same day

VERIFIED FIXED

Status

VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: ssitter, Assigned: jminta)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Views don't display events that start and end at 00:00 on the same day.

If an event (not all-day) lasts from 00:00 to 00:00 on the same day the event is not displayed in any of the view.

Expected Results: Display the event somehow to the user.

Note:
If the event lasts from 00:00 to 00:01 at the same day the event is displayed.

If the event starts at 00:00 but ends at 00:00 on another day we display the event on all days except the last day. (I have been told that's a feature).

With the old views this zero-length event was displayed as a small line in day view and as a normal box in multiweek/month view.
(Reporter)

Comment 1

13 years ago
*** Bug 331240 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

13 years ago
Created attachment 216294 [details] [diff] [review]
special case for zero-length events

yada yada yada... Adds special casing to return at least one box/column when it's a zero length event.
Assignee: base → jminta
Status: NEW → ASSIGNED
Attachment #216294 - Flags: first-review?(dmose)
r=dmose.  Can you file a new bug on deciding what we think the semantics of a "zero-length" event really ought to be, and adjusting the UI in any appropriate?
Attachment #216294 - Flags: first-review?(dmose) → first-review+
(Assignee)

Comment 4

13 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 5

12 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060830 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.