Plugin performed an illegal operation (Shockwave Flash) [Fixed by Windows Update Trojan removal]

RESOLVED INVALID

Status

()

defect
--
critical
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: mblazevi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: If you still see this after the windows update with trojan removal, please file a new bug, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Once i visit a page as one above (www.americasarmy.com) window pops out and says "Shockwave Flash, the plug-in performed an illegal operation. You are strongly advised to restart Firefox".
Once i click OK and check "Do not show this warning again" i can continue browsing but animations made in Shockwave just wont be shown.
I've tried to play some games made in Shockwave and i CAN. It's just animations on web pages then.
I've already reinstalled Firefox 1.5 and Shockwave 10 and it's still there. I've also installed ActiveX plugin.



Reproducible: Always

Comment 1

13 years ago
See also bug 156493.

This site wfm with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060217 Firefox/1.6a1

Which version of the flash plugin are you using? Type 
 about:plugins 
in the address bar to find the answer.
(Reporter)

Comment 2

13 years ago
Mozilla ActiveX control and plugin support
    File name: npmozax.dll

Adobe Acrobat
    File name: nppdf32.dll
    Adobe Acrobat Plug-In Version 7.00 for Netscape

Shockwave for Director
    File name: np32dsw.dll
    Macromedia Shockwave for Director Netscape plug-in, version 10.1

Shockwave Flash
    File name: NPSWF32.dll
    Shockwave Flash 8.0 r22

QuickTime Plug-in 7.0.3
    File name: npqtplugin.dll
    File name: npqtplugin2.dll
    File name: npqtplugin3.dll

and few more...
(Reporter)

Comment 3

13 years ago
It's fixed now. I just made a new profile and the "bug" is gone.
My profile was "default" so i created a new one and it seems that was enough to fix the problem. Thanks anyway.

Comment 4

13 years ago
wfm per reporter's comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
(In reply to comment #3)
> It's fixed now. I just made a new profile and the "bug" is gone.
> My profile was "default" so i created a new one and it seems that was enough to
> fix the problem. Thanks anyway.
> 

Well i spoke too soon. It was gone, for about 15 minutes. I still have it.
Reopening as per comment 5
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
*** Bug 332460 has been marked as a duplicate of this bug. ***
I recently tried solving this for someone on irc and was unable to.  Here's what we were able to establish. 

-Problem still existed on a new profile
-Still existed on a new profile and an installation in a different location
-Still existed after deleting ALL copies of NPSWF32.dll off the hard drive and reinstalling plugin
-Problem did NOT exist in a fresh 1.0.7 install, but came back when that install was upgraded to 1.5 (although user believes they didn't encounter the error message originally until 1.5.0.1)
-Randomly but frequently enough it causes firefox to crash
-Norton firewall installed (don't know if this is significant, would need to compare with other reporters of this problem)
Severity: normal → critical
Summary: Plugin performed an illegal operation (Shockwave) → Plugin performed an illegal operation (Shockwave Flash)

Comment 9

13 years ago
*** Bug 333203 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
This is a consistant problem.  i'm thiking of never using firefox again if this continues.

Comment 11

13 years ago
The page you list wfm without problems.

Shockwave for Director
    File name: NP-PPC-Dir-Shockwave
    Macromedia Shockwave for Director Netscape plug-in, version 10.1.0
Shockwave Flash
    File name: Flash Player Enabler.plugin
    Shockwave Flash 8.0 r24

I cannot reproduce your problem. Moreover, Flash is so ubiqutious, that if there was a real problem with Firefox, we'd be swamped with feedback of it crashing.

Please have a look at
http://plugindoc.mozdev.org/windows.html

Also, when Mozilla crashes, please submit a Talkback to Mozilla, so we can analyze the crash. See http://wiki.mozilla.org/Mozilla_QA_Community:Talkback for more info..
Reporter - can you link us to some of the pages that did work for testing and comparison?
Ahh, nevermind my previous comment, I reread the original post.  Yes shockwave games will work as they are using the macromedia shockwave plugin.  The problem here is the Shockwave Flash plugin.  Confusing.

Anyway, I have another user who has duplicated the steps I reported earlier.

1. uninstall flash (using macromedia's uninstaller http://www.adobe.com/go/tn_14157)

2. uninstall 1.5.0.x

3. delete C:/Program Files/Mozilla Firefox folder

4. install 1.0.7 (or 1.0.8)

5. install flash
- note that it works

6. install 1.5
- note that it breaks

Same as the last user, it didn't break until one of the 1.5.0.x builds initially, but on working back up it's broken on 1.5 immediately.  This user has no firewalls installed.
I helped someone who was having this message (didn't get a chance to confirm if it worked in an older version or not) but they found the problem was fixed when they installed the flash 9 beta.

If those of you still having the problem could test and see if it works with the new flash, that would be awesome.

http://www.adobe.com/products/flashplayer/public_beta/

Comment 15

13 years ago
I have this problem too. For some reason recently it seems to happen much more frequently. I have installed the Flash 9 release as of a few days ago to no avail.

Also, my room-mate has experienced this problem as well.

In response to comment #11, I suggest that this is a real problem and that possible reasons that complaints are not more widespread include the following:

1) The problem is a nuisance but may not annoy most people enough to come to bugzilla and submit a bug report.

2) Most people figure the "talkback" is enough of bug submittal.

3) Most people would rather just use a built-in browser to browse the sites that are making firefox crash than try to mess around with bug-reports. 

4) Personally, for the most part I cannot find a website which consistantly makes firefox crash. I usually have many tabs open and any one of them may have had flash content that would crash the program. Since there's not a really solid lead to give to the devs on where to start one might assume that it isn't worth bothering them about it yet.

5) People often times assume that in a program that is still under major developement that it is expected to have such major bugs and that the bug is probably widespread and there are plenty of people that have already submitted a bug report.

I suggest these reasons because I have had random shockwave crashes for many many months and have, for one or more of the above reasons at different times, decided against going to the trouble of adding my name to a bug-report. Only since the problem has become so much more frequent have I finally decided to go to the trouble of reporting this.
thegsusfreak - are you seeing a crash or just this dialog?

if you're seeing a crash can you link to some talkback ids?  Also if you're experiencing a crash, it's probably not this bug.

What os and firefox version are you using?

Do my steps for installing an older version "fix" the problem for you?

Comment 17

13 years ago
Well, as I said there isn't any particular site that it happens on consistantly. It just happens seemingly randomly as I'm browsing.

Come to think of it, you're right about the crash vs. this bug. I do have firefox crash every now and then, but this bug doesn't crash it. However, when this bug does occur all flash content, of course, is completely broken but many times it also breaks my ability to click on anything at all. So usually when flash performs an illegal operation I have to shut it down and restart. I've kind of gotten in the habit of just doing that by default. :)

I tried very quickly installing v. 1.0.8 from scratch and installing flash. I surfed the usual sites I go to and didn't get this bug. I reinstalled the latest version from scratch and just restored my profile that I had backed up and went to the same sites without this bug. So I really didn't prove a whole lot, I guess. 

Comment 18

13 years ago
If the plugin performed an illegal operation, the bug is in the plugin.  Can anyone provide a talkback ID or other evidence of a bug in Firefox itself?  Otherwise I'm going to mark this INVALID. 

Comment 19

13 years ago
(In reply to comment #18)
> If the plugin performed an illegal operation, the bug is in the plugin.  Can
> anyone provide a talkback ID or other evidence of a bug in Firefox itself? 
> Otherwise I'm going to mark this INVALID. 
> 

Hello, please don't mark it invalid yet. More and more users related us on the french forum Geckozone this issue (http://www.geckozone.org/forum/viewtopic.php?t=38618 [sorry, it's french]). Some users says this issue could be cause after installing a soft called "Internet-GameBox". I don't really know if it's confirmed. However, no solution has been found yet.
This hasn't been marked invalid as of yet because there are people reporting it works in older versions of firefox, and something in an update breaks it.  We're waiting for confirmation that something in flash 9 fixes the problem, in which case I'd say it should probably be resolved as worksforme since we're not sure who's working around who.

chbok- the same error message isn't necessarily the same problem.  Can you describe exactly what is being reported in the french forum?

Comment 21

13 years ago
(In reply to comment #20)
> This hasn't been marked invalid as of yet because there are people reporting it
> works in older versions of firefox, and something in an update breaks it. 
> We're waiting for confirmation that something in flash 9 fixes the problem, in
> which case I'd say it should probably be resolved as worksforme since we're not
> sure who's working around who.
> 
> chbok- the same error message isn't necessarily the same problem.  Can you
> describe exactly what is being reported in the french forum?
> 

I'm having the same problem.  I am using firefox 1.5.0.5 and Shockwave Flash 9.0 r16.  I get the illegal operation message and sporadic browser closings most frequently when I visit ESPN's website at espn.go.com.

Comment 22

13 years ago
(In reply to comment #20)
> This hasn't been marked invalid as of yet because there are people reporting it
> works in older versions of firefox, and something in an update breaks it. 
> We're waiting for confirmation that something in flash 9 fixes the problem, in
> which case I'd say it should probably be resolved as worksforme since we're not
> sure who's working around who.
> 

I will add my voice as another user who would like this resolved.  I used Firefox for several years without this problem and it started spontaneously a couple of months ago I assume after an update of Firefox or Flash.  

It's bad enough that I'll end up ditching Firefox for another browser if I don't find a fix soon.  I assume there are a lot of other users in the same situation.  We don't care whether it's Firefox or Flash that's ultimately responsible for the error, we just want it fixed.  And if it doesn't get fixed we'll end up ditching Firefox, even if it was a problem in Flash's interaction with Firefox that was actually causing the error.

Here's one site that I can count on to cause a complete crash of Firefox fairly quickly:
http://www.collegefootballnews.com .  Yes, the site has a lot of invalid html but it used to run fine in Firefox for me and still does run fine in IE.

Comment 23

13 years ago
"Shockwave plugin a effectué une opération illégale. Il est fortement conseillé de relancer firefox"
I got an email from someone who had this problem and solved it by creating a new windows profile.  Can I get those of you still following this to give it a shot and report back?

Comment 25

13 years ago
I have investigated this as well.
Its a bit confusing.
Im talking about Shockwave Player version 10.1.1.016
Flash player 9,0,16,0
And Firefox 1.5.0.4
on WinXp SP2 (Swedish and English version)

Some computers have difficulties playing shockwave content (not all).
Randomly the shockwave content freezes (Works fine in IE)
The tricky thing is that some computers with the same setups (Firefox, shockwave, Flash, WinXpSP2) doesnt freeze at all.
The shockwave have imported flash in it. And sound.

All sound stop and the shockwave stops to render graphics.

I have also discovered that if you have a input field and mark it and enter chars into it the shockwave will roll temporarly until you stop entering chars.

The site is gamarena.com but they have stoped the use of Firefox.
You can also test it on www.shockplay.com and play some Couronne.
It works on some computers all the time and anly sometimes on others. 
(play 5-10 times and if the bug havent accured you have a good computer)

Please remember that *Macromedia Shockwave* is different from *Shockwave Flash.*  This bug has nothing to do with Shockwave content.

Nisse - you seem to be reporting a different issue based on your comments.  Please clarify that you do or do not get the "Shockwave Flash has performed an illegal operation" error message.

Comment 27

13 years ago
(In reply to comment #26)
> Please remember that *Macromedia Shockwave* is different from *Shockwave
> Flash.*  This bug has nothing to do with Shockwave content.
> 
> Nisse - you seem to be reporting a different issue based on your comments. 
> Please clarify that you do or do not get the "Shockwave Flash has performed an
> illegal operation" error message.
> 

Hi...
I want to reinforce comments #22 and #8...
I had everything working fine for years... and on one day I started to receive this error and I can't say why it happens.

I also found that when I open severall tabs at the same time with some pages, the risk of getting the error and sometimes having the firefox stop rendering, not responding to most mouse events or even crashing... increases a lot...

I don't know if they are all related to this problem... but I think they might be... Reports TB22247028Y, TB22042042W, TB22034921G, TB21997379Z, TB21931242Y were sent by me... (and I have one more on queue to send)
(I've just recently have started to send reports and I've been avoiding the crashes...)


Hope you can find a solution quickly... I've been reading a lot of foruns about this and I've yet to see a solution...

Thanks

Comment 28

13 years ago
I am also experiencing this same problem since upgrading to Firefox 1.5.0.6

Have uninstalled and reinstalled latest Flash (9,0,16,0), searched for multiple copies of npswf32.dll and made sure they are all of same version. Firefox still randomly brings up error but seems to normally continue after clicking OK. It also sometimes crashes completely, error report pointing to npswf32.dll.

Has any progress been made on this? I've seen a lot of reports on various forums for this particular problem but no satisfactory solutions.
Steve - have you tried to see if the problem still exists in a *new* windows user?  We're waiting on confirmation of this finding to see if we can isolate where the problem lies.

Comment 30

13 years ago
(In reply to comment #29)
> Steve - have you tried to see if the problem still exists in a *new* windows
> user?  We're waiting on confirmation of this finding to see if we can isolate
> where the problem lies.
> 

Not sure what you mean by '*new* windows user' - new to bugzilla, can you please expand? Thanks
Steve - xp has user profiles which can be managed from the control panel.  Make a new one and see if the issue still happens there.

Comment 32

13 years ago
(In reply to comment #31)
> Steve - xp has user profiles which can be managed from the control panel.  Make
> a new one and see if the issue still happens there.
> 

Apologies, I thought you meant something within Firefox not basic user profiles (feel really stupid now - I've only been an I.T. consultant for over 20 yrs!! Lol).

Any way, further tested as follows:

Using normal user account, visited www.shockwave.com and tried loading various online games. Frequently got the illegal operation error whilst advert loading prior to game.

Restarted computer and created new user account (limited not admin) then visited same site and performed same test. At first the error didn't seem to appear, then only occasionally and on further examination, always when the shockwave advert was an actual video rather than an animation.

Logged out and back in again as my normal (admin) user account and noted similar trend, although it took a little while before error message began appearing.

Will keep checking and post anymore findings but thought this enough to be going on with. Don't envy you this one!!

Comment 33

13 years ago
This message about shockwave doing illegal operation is freezing up my computer and ruining my firefox experience.  Told to restart computer and must do it repeatedly to use firefox.  help!
I don't know if I've asked this before yet, but... do you all have firewalls going?  And do you have js enabled in Firefox?

Comment 35

13 years ago
have traditional XP 
Service pack 2 firewalls.  don't know what js is.

Comment 36

13 years ago
Hi there. 
I have the same problem, I have installed both Versions: 1.5.0.7 German and 2.0 RC1 German, JS activated in both. I am using Kaspersky Anti Hacker Firewall. XP SP2 is fully patched. I think I have the problem since about two weeks, and I had a working 1.5.0.7 before. Latest official released Version of Shockwave and Flashplayer. Tell me if you need more Information.

Comment 37

13 years ago
since about 10 days i have freezing/hanging/illegal problems with firefox and flash. never had before. Seems at least two different behaviours:
- flash loading and running and suddenly freezing the flash animation (not at the same point, once even while loading...). cannot reload the page or open new pages. closing firefox windows make it disappear, but firefox.exe still running in taskmon.
- flash loading and at random time npswf32.dll error or "shockwave performed illegal... restart firefox". uninstalled all flash/shockwave stuff via adobe uninstall_flash utility and reinstalled macromedia flash plugin from firefox automatic installer and no more error message. just always hang in the previous  described way... so i don't have any log.

windows XP Home Italian sp2
firefox 1.5.0.7 english (but the same even with 2beta1 and 2RC2)
Adobe Flash Player 9,0,16,0
tried on www.miniclip.com/games/tribe/en/ or on www.frappr.com

strange: no problem with a machine
windows 2000 professional sp4 english
firefox 1.5.0.4 / 1.5.0.7 english (test before and after update)
Adobe Flash Player 9,0,16,0

Comment 38

13 years ago
This problem appear in a lot of sites !
So we still need to figure out what everyone has in common.  The fact that this is breaking on random firefox updates makes me think that this is a firewall issue, but is there even a firewall setting that would cause this issue with the plugin? Is there something in the registry or somewhere that flash tracks compatible browsers, and maybe this entry is breaking on an update?

Comment 40

13 years ago
i do not understand... today all the day without crashes... and no changes made!
really strange. I know yesturday was some win xp update, but i did not installed them.

Comment 41

13 years ago
This problem block Firefox. It is a big problem. It appends in a lot of internet pages.

Comment 42

13 years ago
This problem allready existe in the version 2.0 of Firefox ! 

Comment 43

13 years ago
I am so **** of firefox over the last number of weeks, I’m abandoning it for good, I have tried all the solutions put forward, including safe mode, purging it completely and downloading v2, downloaded all the plugins after deleting them and testing. I'm convinced the problem is in Firefox itself, not the plugins, its basically unstable, thats all.

Pity I liked it, but why feck up some thing that was working, with some thing that was not, i.e. why fix something that’s not broken.
Good Luck, back to check Netscape my first browser which I liked a lot.
If the problem were Firefox, more people would be seeing this issue, and a new profile/install would fix it. And I think its pretty clear in this thread that no, none of what's been suggested so far actually makes a difference. I completely understand, though, that flash not working can pretty much render a browser useless for most of the web.  I'm going to try and keep pushing to find the answer to this.  

What would be great is if people can stay cc'ed to this bug and when we do get more information, or need more information from people who are experiencing this, could test for us.

Which reminds me, I did get to speak to one of the devs about this at the summit, and he mentioned several unexpected places that flash will leave itself even after an uninstall, including in C:\WINDOWS\System32 .  If people could try using the flash uninstaller and then look for the flash plugin in system32 and report back that would be awesome.  I'll try and track down some exact filenames if there's anything besides NPSWF32.dll

Comment 45

13 years ago
try this!!!
http://forums.tweakguides.com/showthread.php?t=4224
it worked for me!
i had a rootkit installed, which only sophos anti-rootkit detected
It seems the main information is this:

"Basically a guy mentioned checking "msinfo32", in it's "startup programs" section, as for whatever reason, the rootkit fails to disguise itself from that (all other forms of registry viewing and/or hijackthis, etc, turned up empty).

After seeing the culprit files (dmnyc.exe), I was able to use Sophos Anti-rootkit to delete them on reboot, which then disabled the rootkit, so that the rest of the junk could be removed via standard methods (hijackthis, etc)."

Since we already know updating flash didn't always fix the problem.  Thanks so much for the tip, if everyone who's still following along could PLEASE check for this and report back, that would be awesome.

Comment 47

12 years ago
I had the same problem. Using Firefox 3.0 Alpha 2 (Gran Paradiso) and the newest Flash Plugin fixed this bug for me seemingly.

Comment 48

12 years ago
Sorry. Got to revise my last statement. Firefox just crashed again, while watching a flash-video. :-/

Comment 49

12 years ago
update as requested from vseerror@Lehigh.EDU

comment #0: I comfirm I had the same behaviour, but since my post #40, neved had the problem anymore

comment #13: I cannot see difference between shockwave and flash, but the error (as mentionned in comment #37) is "shockwave performed
illegal... restart firefox".

comment #46: as stated in comment #40 the error has gone, and I dont know why... it is possible that a virus has been cleaned in the meantime... but I do not have any report (AVG 7.1 free edition)

Right now i cannot recreate the problem, all is working fine. I'm using Firefox 2.0.0.1 [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1] and I'm really happy with it. I'm still keeping an eye on this bug to see how it is evolving...

PS: on about 45 different PC checked until now since comment #40, no one with this bug...

Comment 50

12 years ago
Okie dokie!!!!
I think that I finnaly have some new data on this...
Yesterday I run one more of the periodic MS updates; one of them uses a Malware scanning application... and this time it was detected something: a Trojan more exactly: win32/alureon.a

OK... and today... I've done all kind of experiences with the webpages I was having problems before and I still haven't got any (and I've really pushed the browser to get errors)... gathering some data on the Trojan I found that it has some age... and that only a few days ago MS got a "cure" for it. I don't know if I read it correctly but for me... I think that everything connects and makes sense now.

Just for the record, just some of the experiences I've tried to work this out before... I've tried the updating of the plugins (most of the time the installer would appear on the task manager process list but wouldn't do anything more than this)... I tried the rootkit scanner mentionend on comment #45 (and some other) and nothing came up... reinstaling FireFox... nothing had worked.
Only Yesterday/Today I think I have it running like it should when I've done that MS update I told you guys about!


I really hope it works for you all!!!
Good luck! :O)
majken in comment #20:
> This hasn't been marked invalid as of yet because there are people reporting it
> works in older versions of firefox, and something in an update breaks it. 
> We're waiting for confirmation that something in flash 9 fixes the problem, in
> which case I'd say it should probably be resolved as worksforme since we're not
> sure who's working around who.

are we still waiting for that version of flash?
Wayne - there are comments since that updating to Flash 9 didn't infact solve the problem.

Although with the two comments of this being resolved after updating windows and removing a trojan I think we can resolve invalid based on that, and ask anyone who's still seeing the problem to file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → INVALID
Summary: Plugin performed an illegal operation (Shockwave Flash) → Plugin performed an illegal operation (Shockwave Flash) [Fixed by Windows Update Trojan removal]
Whiteboard: If you still see this after the windows update with trojan removal, please file a new bug
You need to log in before you can comment on or make changes to this bug.