Date-Time-Picker broken (displayed time: Sun Dec 31 1899 1:00:00 GMT+0100)

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

Trunk
x86
Windows 2000

Details

(Reporter)

Description

13 years ago
Date-Time-Picker broken (displays time: Sun Dec 31 1899 1:00:00 GMT+0100)

Using todays trunk build I got a weired behaviour with the date-time-picker. (The time and date values might be different for you when testing)

- Open New Event Dialog, From and To field display:
  From  24.02.2006  18:00
  To    24.02.2006  19:00

- Click into From time field, From and To field display:
  From  24.02.2006  18:00
  To    24.02.2006  19:00

- Click into To time field, From and To field display:
  From  24.02.2006  Sun Dec 31 1899 18:0:00 GMT+0100
  To    24.02.2006  19:00

- Click into From date field, From and To field display:
  From  24.02.2006  Sun Dec 31 1899 18:0:00 GMT+0100
  To    24.02.2006  Sun Dec 31 1899 18:0:00 GMT+0100

- Click into To date field, From and To field display:
  From  24.02.2006  01:00
  To    24.02.2006  Sun Dec 31 1899 18:0:00 GMT+0100

Clicking into the date fields sets the time to 01:00.
Clicking into the time fields sets the time to Sun Dec 31 1899 18:0:00 GMT+0100.
Seems that the fields change when losing the focus.

Tested with Sunbird and Thunderbird + Lightning (win32-2006-02-24-trunk). 
No problems with Tb 1.5 + Lightning (win32-2006-02-24-mozilla1.8).

Comment 1

13 years ago
WFM in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060223 Mozilla Sunbird/0.3a1+

Given that trunk and branch are sync'd, I'd look for something in the bonsai range between when the Sunbird Mac build (note that latest available in 23 Feb) and the win32 build (24 Feb).  Also, Mac 23 Feb has the alarm upgrade, so that seems to rule out that possibility
(Reporter)

Comment 2

13 years ago
I also see this with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060224 Mozilla Sunbird/0.3a1+.
(Reporter)

Updated

13 years ago
Depends on: 327869
confirmed. Seeing this on linux. (not an official build, so can't give an id. But i updated about two hours ago)
The problem seems to be in jsDate.toLocaleFormat().

testcase: new Date(0, 0, 0, 13, 14, 15, 0).toLocaleFormat('%I:%M')
And old firefox gives 01:14
a recent build gives Sun Dec 31 1899 13:14:15 GMT+0100
(tested in the JS console)


Status: UNCONFIRMED → NEW
Ever confirmed: true
Fixed by back-out of bug 327869's patch.

/be
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
The bugspam monkeys have struck again. They are currently chewing on default assignees for Calendar. Be afraid for your sanity!
Assignee: base → nobody
You need to log in before you can comment on or make changes to this bug.