Add UI to select a custom alarm sound in Lightning preferences

RESOLVED FIXED in Lightning 0.5

Status

Calendar
Preferences
--
enhancement
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: ssitter, Assigned: ssitter)

Tracking

Trunk
Lightning 0.5

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

12 years ago
Add UI to select a custom alarm sound file in Lightning preferences.

This might include 
- use default sound (e.g. simple beep or a system sound)
- use custom sound (file browser)
- preview button to play the selected sound

We might consider making the UI similar to the UI that Thunderbird already uses for the new mail sound selection. (You know, that thing about familiarness)

Updated

12 years ago
Flags: blocking0.3+

Updated

12 years ago
Whiteboard: [depends on ui in bug 331323]

Updated

12 years ago
Whiteboard: [depends on ui in bug 331323] → [depends on ui in bug 331323][swag:.25d]

Comment 1

12 years ago
Created attachment 231807 [details] [diff] [review]
port sunbird filepicker

Patch ports the Sunbird sound-picker to Lightning.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #231807 - Flags: first-review?(dmose)

Updated

12 years ago
Whiteboard: [depends on ui in bug 331323][swag:.25d] → [patch in hand][swag:.25d]

Updated

12 years ago
Whiteboard: [patch in hand][swag:.25d] → [patch in hand][swag:.25d][cal-ui-review needed]
Got a screenshot?

Comment 3

12 years ago
(In reply to comment #2)
> Got a screenshot?
> 
It's identical to Sunbird's dialog.
Whiteboard: [patch in hand][swag:.25d][cal-ui-review needed] → [patch in hand][cal-ui-review needed]
Whiteboard: [patch in hand][cal-ui-review needed] → [patch in hand][cal-ui-review needed][no l10n impact]
This needs the fix from bug 344535 before landing.

Boo for code duplication
This should not block 0.3. It's at best a nice-to-have for 0.5
We can live without this for 0.3. (that doesn't mean that the patch can't get checked in, if it gets reviewed in time)
Flags: blocking0.3+ → blocking0.3-
(Assignee)

Updated

11 years ago
Duplicate of this bug: 369954
(Assignee)

Updated

11 years ago
Depends on: 372014

Updated

11 years ago
Attachment #231807 - Flags: first-review?(dmose)
Attachment #231807 - Attachment is obsolete: true
Assignee: jminta → ssitter
Status: ASSIGNED → NEW
Whiteboard: [patch in hand][cal-ui-review needed][no l10n impact]
Target Milestone: --- → Lightning 0.5
FIXED by checkin for bug 372014
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Component: Lightning Only → Preferences
QA Contact: lightning → preferences
You need to log in before you can comment on or make changes to this bug.