Firefox trunk hangs on start on win2k3 and winXP

VERIFIED DUPLICATE of bug 328676

Status

()

--
blocker
VERIFIED DUPLICATE of bug 328676
13 years ago
12 years ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Today's nightly trunk zip builds fail to start on Windows Server 2003. The build pegs the cpu and just sits there. Not sure how to diagnose.

This is not the case on winxp.
(Reporter)

Comment 1

13 years ago
Still an issue with 20060301 builds. This blocks me testing nightly builds on the trunk for windows.
(Reporter)

Comment 2

13 years ago
Created attachment 213696 [details]
nspr log

zipped nspr log for the first 18 cpu seconds.
(Reporter)

Comment 3

13 years ago
Trying to test the installer version I get a Microsoft Visual C++ Runtime Library error dialog:

Program: C:\....\setup.exe

R6034
An application has made an attempt to load the C runtime library incorrectly. 
...

methinks this is vc8 related.
(Reporter)

Comment 4

13 years ago
finally got my debug builds working. The hang appeared right after these assertions.

###!!! ASSERTION: No DC: 'aDC', file c:/work/mozilla/builds/ff/trunk/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp, line 459
cairo_win32_scaled_font_select_font:SelectObject: The handle is invalid.
###!!! ASSERTION: No DC: 'aDC', file c:/work/mozilla/builds/ff/trunk/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp, line 555
cairo_win32_scaled_font_select_font:SelectObject: The handle is invalid.

over to core gfx win
Assignee: nobody → win32
Component: Startup and Profile System → GFX: Win32
Product: Firefox → Core
QA Contact: startup → ian
Also saw this on XP Pro with the exact same assertions in comment #4. Updating summary.
Summary: Firefox trunk hangs on start on win2k3 → Firefox trunk hangs on start on win2k3 and winXP
Are you using 16 bit color depth? There have been reported issues with the cairo backend in those cases.
Component: GFX: Win32 → GFX: Thebes
(In reply to comment #6)
> Are you using 16 bit color depth? There have been reported issues with the
> cairo backend in those cases.
> 

32bit here.
Component: GFX: Thebes → GFX: Win32

Comment 8

13 years ago
Are you running this over a TS/RDP connection?  There have been reports of that not working.
(Reporter)

Comment 9

13 years ago
I don't see issues on my local winxp boxes which are at 32bit normally, but do access the win2k3 boxes via windows rdp which is 16bit. I can reproduce with my local machine when switching to 16bit however.

Comment 10

13 years ago
Ahhh...so this is a duplicate of 328432.  Marking as such.

*** This bug has been marked as a duplicate of 328432 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Ah, I was running over rdp. For some reason my color depth gets reduced to 16bit despite my connection settings... Running locally works as expected.

However, I don't think this is necessarily a dup of 328432. Those folks are seeing an invisible frame and not making any mention of the above assertions...

Comment 12

13 years ago
You've certainly added information to the bug.  That's why a notification is placed on the other bug as well.  Your logs will be much appreciated, I'm sure.  However, the bug 328432 report predates yours by 2 days, so I marked this one as the duplicate.  If you feel your work might be overlooked, feel free to attach it to the other bug or include a additional message pointing to this bug.

Personally, I've experienced this very bug daily since moving to Cairo, so I have great motivation to see it resolved quickly.  I'd be shooting myself in the foot if I was hiding something that might be important to fixing this issue.

Comment 13

13 years ago
it gets in to an infinite loop if aDC is null in that code.  aDC is only null in that code if it is 16bpp.  i'm pretty sure this is a dup.. I'm hoping to fix it this week.
Yeah, looks more like bug 328676 to me, although the two may be closely related.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 328676 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Assignee: win32 → nobody
Component: GFX: Win32 → GFX: Thebes
QA Contact: ian → thebes
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.