Bad virtual folder unread count in IMAP account

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: Mahesh Asolkar, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: version 1.6a1 (20060228)

I use Mozilla Thunderbird to access my IMAP account. I have a couple of saved searches (virtual folders). The unread mail count in them is hardly ever correct.

Say I do not have any unread email. When I first refresh the folder, it correctly shos 0 unread email (the folder name is not bold). When new messages arrive in the inbox, the virtual folder increments the count of unread messages, becomes bold etc.

When I read the new message while still in the Inbox (I have not navigated to the virtual folder), I expect the count to be decremented. The count stays the same.

So at the end of the day, it appears that I have tens of unread messages. Although I have read all new mail.

If I navigate to the virtual folder, the count is restored to the correct one.

Reproducible: Always

Steps to Reproduce:
1. When there is no new email, go to a virtual folder (say, one that has messages 2 days or newer). This will refresh the folder, set the new message count to 0.
2. Navigate out of the virtual folder. 
3. Wait for a new mail to arrive. Do not go to the virtual folder. It will probably have a count that indicates number of new messages.
3. Read the new message while still in Inbox (or other actual folder)
4. Stay out of the virtual folder in test for next few times a new message arrives.

Actual Results:  
The count of new messages keeps increasing when new messages arrive, but never decreases when the messages are read.

Expected Results:  
When a new message arrives, the count of unread messages in virtual folders should increase. When a new message is read, the count should decrease.
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 1

12 years ago
what search criteria are used on your virtual folders? In particular, do you search for any text in the message body, or custom headers?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> what search criteria are used on your virtual folders? In particular, do you
> search for any text in the message body, or custom headers?
> 

I have two such folders:

1. "Todays" : [Age In Days] [is less than] [1]
2. "Unread" : [Status] [isn't] [Read]

I do not search for any text in the body of messages. I do not use custom headers.

Comment 3

12 years ago
are these virtual folders on the inbox only, i.e., they just search over messages in the inbox? And what version of TB are you using?
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> are these virtual folders on the inbox only, i.e., they just search over
> messages in the inbox? And what version of TB are you using?
> 

They search messages in the inbox and the hierarchy of real folders under inbox.

However, the virtual folder itself is located in 'Local Folders', since I am using IMAP, and don't want the virtual folder to show up on the IMAP server (from what I understand).
(Reporter)

Comment 5

12 years ago
An, I am using the trunk build...

  Build Identifier: version 1.6a1 (20060228)
QA Contact: front-end

Comment 6

10 years ago
This bug still exists in Thunderbird 2.0.0.12 (20080227).  I have a "saved search" folder collecting new messages from several different folders in various IMAP accounts.  When messages arrive, the new message count is updated correctly, however when I click on messages (change their status to read), the count is NOT updated.  Nor is it updated when messages are automatically marked as junk and moved by Thunderbird.  This results in the new message count for the virtual folder (in the folder pain) never going down.

My saved search is looking for any "Status is New," "Status is Starred," "Tags contains Important," or "Tags contains To Do" in several folders across 4 different IMAP accounts.  The message count I am referring to is in parentheses after the folder name in the "All Folders" sidebar.  If I can provide any other pertinent information, let me know.

I believe the following bugs are dupes of this one: #365392, #372372, #394481.

Comment 7

10 years ago
Each search term requires separate issues to work correctly. Note there have been a number of fixes in this area since 2006. Triaging this bug:

1) Reporter's terms in comment 2 WFM on 2008-04-17 trunk.

Other terms mentioned in comment 6:

2) Starred should also now work.
3) Issues with tags are being dealt with in bug 428427
4) Issues with NEW will be covered in bug 372372

Unless other commenters object, I propose that we close this as WFM and deal with other issues in the mentioned bugs.

Comment 8

10 years ago
I don't object as you should organise however is most helpful for the developers.  I just wanted to add that, from a user perspective, this is one issue, dealing with saved search folders.  I understand that technically it is several different issues, but perhaps this should stay open as a catch-all, to direct users to, until the saved search function works 100%.

I do think those other bugs I mentioned should be closed as dupes of this one, though.

Updated

10 years ago
Blocks: 438257

Comment 9

9 years ago
I have a related instance. I hope this is a good place to leave it.

a) It's in Penelope, but appears to be of TBird DNA.

b) I have a filter moving some IMAP Inbox messages to a REAL FOLDER.

c) There's a search folder sucking on that folder with "From contains NAME" criteria.

d) When I get a new message from NAME; the Mailboxes page shows me 1 new message in REAL FOLDER {correct} and 30-odd {wrong} in the virtual folder.

Updated

6 years ago
Assignee: dbienvenu → nobody

Comment 10

5 years ago
WFM then per comment 7. ANd David's issue may be covered in bug 372372
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.