Folders disappear inside folder after dragging link inside bookmark toolbar

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: martijn.martijn, Assigned: enndeakin)

Tracking

({qawanted, regression})

Trunk
x86
Windows XP
qawanted, regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
I'll attach some screenshots which hopefully makes this bug clearer and reproducable.
I think it's a regression from bug 285631. The fix for bug 326712 improved things considerably, but not this case.

To reproduce, you must have bookmark folders in the bookmarks toolbar.
The bookmark folders just before the bookmarks-chevron must have bookmark folders inside them.
Now drag an url at the beginning of the bookmarks toolbar.
After that the bookmark folders in the bookmark folder just before the bookmarks-chevron are not visible anymore. A restart of the browser or opening a new window fixes the bug.
(Reporter)

Comment 1

13 years ago
Created attachment 213684 [details]
Screenshot1

Here you can see the folder inside the 'nws' folder.

After this, I'm adding a bookmark at the start of the bookmarks toolbar.
(Reporter)

Comment 2

13 years ago
Created attachment 213685 [details]
Screenshot2

Here you can see I added a 'about:blank' bookmark to the bookmarks toolbar.
And now the folder inside the 'nws' folder has disappeared.

It only happens with the 'nws' folder, so I guess there might be some weird interaction with the bookmarks-chevron code.
(Assignee)

Comment 3

13 years ago
I think I know what is going on here, but will need to do some testing
Assignee: jag → enndeakin
Flags: blocking1.9a1+
Summary: Folders disappear inside folder after draggin link inside bookmark toolbar → Folders disappear inside folder after dragging link inside bookmark toolbar
(Assignee)

Comment 4

13 years ago
In case anyone wasn't aware, this bug requires a non-places build in order to reproduce it. So if we could come up with a testcase, that would be great, although I'm sure that would be hard to do.
(Assignee)

Comment 5

12 years ago
I don't see this bug currently. Martijn, can you still reproduce it?
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> I don't see this bug currently. Martijn, can you still reproduce it?

Well, I can't reproduce with current trunk build, but like you said in comment 4, one needs a non-places build to test this. Current trunk builds are places builds, afaik. Is there a place where I can download trunk non-places builds?
Flags: blocking1.9a1+
(Assignee)

Comment 7

12 years ago
It's possible that the patch in bug 378173 fixes this.

Updated

12 years ago
Keywords: qawanted
(Reporter)

Comment 8

12 years ago
Neil, can I close this bug? (worksforme?)
(Reporter)

Comment 9

12 years ago
I'm marking this worksforme.
If you want to, you can reopen it, Neil.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.